WLAN application (R&S FSW-K91)
Contents
  • Welcome to the WLAN Application
  • Measurements and Result Displays
  • Measurement Basics
  • Configuration
  • Analysis
  • I/Q Data Import and Export
  • How to Perform Measurements in the WLAN Application
  • Optimizing and Troubleshooting the Measurement
  • Remote Commands for WLAN Measurements
  • List of Commands
Top


Welcome to the WLAN Application

WLAN application (R&S FSW-K91) > Welcome to the WLAN Application
Welcome to the WLAN Application

The R&S FSW WLAN application extends the functionality of the R&S FSW to enable accurate and reproducible Tx measurements of a WLAN device under test (DUT) in accordance with the standards specified for the device. The following standards are currently supported (if the corresponding firmware option is installed):

  • IEEE standards 802.11a
  • IEEE standards 802.11ac (SISO + MIMO)
  • IEEE standards 802.11b
  • IEEE standards 802.11g (OFDM)
  • IEEE standards 802.11g (DSSS)
  • IEEE standards 802.11n (SISO + MIMO)
  • IEEE standards 802.11p

The R&S FSW WLAN application features:

Modulation measurements
  • Constellation diagram for demodulated signal
  • Constellation diagram for individual carriers
  • I/Q offset and I/Q imbalance
  • Modulation error (EVM) for individual carriers or symbols
  • Amplitude response and group-delay distortion (spectrum flatness)
Further measurements and results
  • Amplitude statistics (CCDF) and crest factor
  • FFT, also over a selected part of the signal, e.g. preamble
  • Payload bit information

This user manual contains a description of the functionality that is specific to the application, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage

http://www2.rohde-schwarz.com/product/FSW.html.

Installation

You can find detailed installation instructions in the R&S FSW Getting Started manual or in the Release Notes.

Contents
  • Starting the WLAN Application
  • Understanding the Display Information


Starting the WLAN Application

WLAN application (R&S FSW-K91) > Welcome to the WLAN Application > Starting the WLAN Application
Starting the WLAN Application

The WLAN measurements require a special application on the R&S FSW.

To activate the WLAN application

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "WLAN" item.

    The R&S FSW opens a new measurement channel for the WLAN application.

For details see "Operating Modes" .

The measurement is started immediately with the default settings. It can be configured in the WLAN "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration Overview").


Understanding the Display Information

WLAN application (R&S FSW-K91) > Welcome to the WLAN Application > Understanding the Display Information
Understanding the Display Information

The following figure shows a measurement diagram during analyzer operation. All information areas are labeled. They are explained in more detail in the following sections.

1 = Channel bar for firmware and measurement settings
2 = Window title bar with diagram-specific (trace) information
3 = Diagram area with marker information
4 = Diagram footer with diagram-specific information, depending on result display
5 = Instrument status bar with error messages, progress bar and date/time display
Channel bar information

In the WLAN application, the R&S FSW shows the following settings:

Information displayed in the channel bar in the WLAN application
Label | Description
Sample Rate Fs | Input sample rate
PPDU / MCS Index / GI | WLAN 802.11a,ac,n: The PPDU type, MCS Index and Guard Interval used for the analysis of the signal; Depending on the demodulation settings, these values are either detected automatically from the signal or the user settings are applied.
PPDU / Data Rate | WLAN 802.11b: The PPDU type and data rate used for the analysis of the signal; Depending on the demodulation settings, these values are either detected automatically from the signal or the user settings are applied.
Standard | Selected WLAN measurement standard
Meas Setup | Number of Transmitter (Tx) and Receiver (Rx) channels used in the measurement (for MIMO)
Capt time / No. of Samples | Duration of signal capture and number of samples captured
No. of Data Symbols | The minimum and maximum number of data symbols that a PPDU may have if it is to be considered in results analysis.
Analyzed PPDUs [x of y (z)] | For statistical evaluation over PPDUs (see "PPDU Statistic Count / No of PPDUs to Analyze"): <x> PPDUs of totally required <y> PPDUs have been analyzed so far. <z> PPDUs were analyzed in the most recent sweep.

In addition, the channel bar also displays information on instrument settings that affect the measurement results even though this is not immediately apparent from the display of the measured values (e.g. transducer or trigger settings). This information is displayed only when applicable for the current measurement. For details see the R&S FSW Getting Started manual.

Window title bar information

For each diagram, the header provides the following information:

Window title bar information in the WLAN application
1 = Window number
2 = Window type
3 = Trace color
4 = Trace number
6 = Trace mode
Diagram footer information

The diagram footer (beneath the diagram) contains the start and stop values for the displayed x-axis range.

Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar. Click on a displayed warning or error message to obtain more details (see also .


Measurements and Result Displays

WLAN application (R&S FSW-K91) > Measurements and Result Displays
Measurements and Result Displays

The R&S FSW WLAN application provides several different measurements in order to determine the parameters described by the WLAN 802.11 specifications.

For details on selecting measurements see "Selecting the measurement type".

Contents
  • WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance)
  • Frequency Sweep Measurements


WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance)

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance)
WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance)

The default WLAN I/Q measurement captures the I/Q data from the WLAN signal using a (nearly rectangular) filter with a relatively large bandwidth. The I/Q data captured with this filter includes magnitude and phase information, which allows the R&S FSW WLAN application to demodulate broadband signals and determine various characteristic signal parameters such as the modulation accuracy, spectrum flatness, center frequency tolerance and symbol clock tolerance in just one measurement.

Other parameters specified in the WLAN 802.11 standard require a better signal-to-noise level or a smaller bandwidth filter than the I/Q measurement provides and must be determined in separate measurements (see "Frequency Sweep Measurements").

Contents
  • Modulation Accuracy, Flatness and Tolerance Parameters
  • Evaluation Methods for WLAN IQ Measurements


Modulation Accuracy, Flatness and Tolerance Parameters

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Modulation Accuracy, Flatness and Tolerance Parameters
Modulation Accuracy, Flatness and Tolerance Parameters

The default WLAN I/Q measurement (Modulation Accuracy, Flatness,...) captures the I/Q data from the WLAN signal and determines all the following I/Q parameters in a single sweep.

WLAN I/Q parameters for IEEE 802.11a, g (OFDM), ac , n, p

Parameter

Description

Sample Rate Fs

Input sample rate

PPDU

Type of analyzed PPDUs

MCS Index

Modulation and Coding Scheme (MCS) index of the analyzed PPDUs

GI

Guard interval length for current measurement

Standard

Selected WLAN measurement standard

Meas Setup

Number of Transmitter (Tx) and Receiver (Rx) channels used in the measurement

Capture time

Duration of signal capture

No. of Samples

Number of samples captured

No. of Data Symbols

The minimum and maximum number of data symbols that a PPDU may have if it is to be considered in results analysis.

Analyzed PPDUs

For statistical evaluation of PPDUs (see "PPDU Statistic Count / No of PPDUs to Analyze"): <x> PPDUs of totally required <y> PPDUs have been analyzed so far. <z> indicates the number of analyzed PPDUs in the most recent sweep.

Number of recognized PPDUs (global)

Number of PPDUs recognized in capture buffer

Number of analyzed PPDUs (global)

Number of analyzed PPDUs in capture buffer

Number of analyzed PPDUs in physical channel

Number of PPDUs analyzed in entire signal (if available)

Pilot bit error rate [%]

EVM all carriers [%/dB]

EVM (Error Vector Magnitude) of the payload symbols over all carriers; the corresponding limits specified in the standard are also indicated*)

EVM data carriers [%/dB]

EVM (Error Vector Magnitude) of the payload symbols over all data carriers; the corresponding limits specified in the standard are also indicated*)

EVM pilot carriers [%/dB]

EVM (Error Vector Magnitude) of the payload symbols over all pilot carriers; the corresponding limits specified in the standard are also indicated*)

Center frequency error [Hz]

Frequency error between the signal and the current center frequency of the R&S FSW; the corresponding limits specified in the standard are also indicated*)

The absolute frequency error includes the frequency error of the R&S FSW and that of the DUT. If possible, the transmitterR&S FSW and the DUT should be synchronized (using an external reference).

See "Reference Frequency Input"

Symbol clock error [ppm]

Clock error between the signal and the sample clock of the R&S FSW in parts per million (ppm), i.e. the symbol timing error; the corresponding limits specified in the standard are also indicated *)

If possible, the transmitterR&S FSW and the DUT should be synchronized (using an external reference).

See "Reference Frequency Input"

I/Q offset [dB]

Transmitter center frequency leakage relative to the total Tx channel power (see "I/Q Offset")

Gain imbalance [%/dB]

Amplification of the quadrature phase component of the signal relative to the amplification of the in-phase component (see "Gain Imbalance")

Quadrature offset [°]

Deviation of the quadrature phase angle from the ideal 90° (see "Quadrature Offset").

PPDU power [dBm]

Mean PPDU power

Crest factor [dB]

The ratio of the peak power to the mean power of the signal (also called Peak to Average Power Ratio, PAPR).

*) the limits can be changed via remote control (not manually, see "Limits"); in this case, the currently defined limits are displayed here

WLAN I/Q parameters for IEEE 802.11b or g (DSSS)

Parameter

Description

Sample Rate Fs

Input sample rate

PPDU

Type of the analyzed PPDU

Data Rate

Data rate used for analysis of the signal

SGL

Indicates single measurement mode (as opposed to continuous)

Standard

Selected WLAN measurement standard

Meas Setup

Number of Transmitter (Tx) and Receiver (Rx) channels used in the measurement

Capture time

Duration of signal capture

No. of Samples

Number of samples captured (= sample rate * capture time)

No. of Data Symbols

The minimum and maximum number of data symbols that a PPDU may have if it is to be considered in results analysis

Analyzed PPDUs

For statistical evaluation of PPDUs (see "PPDU Statistic Count / No of PPDUs to Analyze"): <x> PPDUs of totally required <y> PPDUs have been analyzed so far. <z> indicates the number of analyzed PPDUs in the most recent sweep.

Number of recognized PPDUs (global)

Number of PPDUs recognized in capture buffer

Number of analyzed PPDUs (global)

Number of analyzed PPDUs in capture buffer

Number of analyzed PPDUs in physical channel

Number of PPDUs analyzed in entire signal (if available)

Peak vector error

Peak vector error (EVM) over the complete PPDU including the preamble in % and in dB; calculated according to the IEEE 802.11b or g (DSSS) definition of the normalized error vector magnitude (see "Peak Vector Error (IEEE method)");

The corresponding limits specified in the standard are also indicated *)

PPDU EVM

EVM (Error Vector Magnitude) over the complete PPDU including the preamble in % and dB

I/Q offset [dB]

Transmitter center frequency leakage relative to the total Tx channel power (see "I/Q Offset")

Gain imbalance [%/dB]

Amplification of the quadrature phase component of the signal relative to the amplification of the in-phase component (see "Gain Imbalance")

Quadrature error [°]

Measure for the crosstalk of the Q-branch into the I-branch (see "Gain imbalance, I/Q offset, quadrature error").

Center frequency error [Hz]

Frequency error between the signal and the current center frequency of the R&S FSW; the corresponding limits specified in the standard are also indicated*)

The absolute frequency error includes the frequency error of the R&S FSW and that of the DUT. If possible, the transmitterR&S FSW and the DUT should be synchronized (using an external reference).

See "Reference Frequency Input"

Chip clock error [ppm]

Clock error between the signal and the chip clock of the R&S FSW in parts per million (ppm), i.e. the chip timing error; the corresponding limits specified in the standard are also indicated *)

If possible, the transmitterR&S FSW and the DUT should be synchronized (using an external reference).

See "Reference Frequency Input"

Rise time

Time the signal needs to increase its power level from 10% to 90% of the maximum or the average power (depending on the reference power setting)

The corresponding limits specified in the standard are also indicated *)

Fall time

Time the signal needs to decrease its power level from 90% to 10% of the maximum or the average power (depending on the reference power setting)

The corresponding limits specified in the standard are also indicated *)

Mean power [dBm]

Mean PPDU power

Peak power [dBm]

Peak PPDU power

Crest factor [dB]

The ratio of the peak power to the mean power of the PPDU (also called Peak to Average Power Ratio, PAPR).

The R&S FSW WLAN application also performs statistical evaluation over several PPDUs and displays one or more of the following results:

Calculated summary results
Result type | Description
Min | Minimum measured value
Mean/ Limit | Mean measured value / limit defined in standard
Max/Limit | Maximum measured value / limit defined in standard
Contents
  • I/Q Offset
  • Gain Imbalance
  • Quadrature Offset
  • I/Q Skew
  • I/Q Mismatch
  • RF Carrier Suppression (IEEE 802.11b, g (DSSS))
  • EVM Measurement


I/Q Offset

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Modulation Accuracy, Flatness and Tolerance Parameters > I/Q Offset
I/Q Offset

An I/Q offset indicates a carrier offset with fixed amplitude. This results in a constant shift of the I/Q axes. The offset is normalized by the mean symbol power and displayed in dB.

I/Q offset in a vector diagram


Gain Imbalance

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Modulation Accuracy, Flatness and Tolerance Parameters > Gain Imbalance
Gain Imbalance

An ideal I/Q modulator amplifies the I and Q signal path by exactly the same degree. The imbalance corresponds to the difference in amplification of the I and Q channel and therefore to the difference in amplitude of the signal components. In the vector diagram, the length of the I vector changes relative to the length of the Q vector.

The result is displayed in dB and %, where 1 dB offset corresponds to roughly 12 % difference between the I and Q gain, according to the following equation:

Imbalance [dB] = 20log (| GainQ |/| GainI |)

Positive values mean that the Q vector is amplified more than the I vector by the corresponding percentage. For example using the figures mentioned above:

0.98 ≈ 20*log10(1.12/1)

Positive gain imbalance

Negative values mean that the I vector is amplified more than the Q vector by the corresponding percentage. For example using the figures mentioned above:

-0.98 ≈ 20*log10(1/1.12)

Negative gain imbalance


Quadrature Offset

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Modulation Accuracy, Flatness and Tolerance Parameters > Quadrature Offset
Quadrature Offset

An ideal I/Q modulator sets the phase angle between the I and Q path mixer to exactly 90 degrees. With a quadrature offset, the phase angle deviates from the ideal 90 degrees, the amplitudes of both components are of the same size. In the vector diagram, the quadrature offset causes the coordinate system to shift.

A positive quadrature offset means a phase angle greater than 90 degrees:

Positive quadrature offset

A negative quadrature offset means a phase angle less than 90 degrees:

Negative quadrature offset


I/Q Skew

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Modulation Accuracy, Flatness and Tolerance Parameters > I/Q Skew
I/Q Skew

If transmission of the data on the I path is delayed compared to the Q path, or vice versa, the I/Q data becomes skewed.

The I/Q skew results are currently not measured directly, but can be compensated for together with "Gain Imbalance" and "Quadrature Offset" (see "I/Q Mismatch Compensation").


I/Q Mismatch

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Modulation Accuracy, Flatness and Tolerance Parameters > I/Q Mismatch
I/Q Mismatch

I/Q mismatch is a comprehensive term for "Gain Imbalance", "Quadrature Offset", and "I/Q Skew".

Compensation for I/Q mismatch is useful, for example, if the device under test is known to be affected by these impairments but the EVM without these effects is of interest. Note, however, that measurements strictly according to IEEE 802.11-2012, IEEE P802.11ac/D5.0 WLAN standard may not use compensation.


RF Carrier Suppression (IEEE 802.11b, g (DSSS))

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Modulation Accuracy, Flatness and Tolerance Parameters > RF Carrier Suppression (IEEE 802.11b, g (DSSS))
RF Carrier Suppression (IEEE 802.11b, g (DSSS))
Standard definition

The RF carrier suppression, measured at the channel center frequency, shall be at least 15 dB below the peak SIN(x)/x power spectrum. The RF carrier suppression shall be measured while transmitting a repetitive 01 data sequence with the scrambler disabled using DQPSK modulation. A 100 kHz resolution bandwidth shall be used to perform this measurement.

Comparison to IQ offset measurement in the R&S FSW WLAN application

The IQ offset measurement in the R&S FSW WLAN application returns the current carrier feedthrough normalized to the mean power at the symbol timings. This measurement does not require a special test signal and is independent of the transmit filter shape.

The RF carrier suppression measured according to the standard is inversely proportional to the IQ offset measured in the R&S FSW WLAN application. The difference (in dB) between the two values depends on the transmit filter shape and should be determined with a reference measurement.

The following table lists the difference exemplarily for three transmit filter shapes (±0.5 dB):

Transmit filter | – IQ-Offset [dB] – RF-Carrier-Suppression [dB]
Rectangular | 11 dB
Root raised cosine, "α" = 0.3 | 10 dB
Gaussian, "α" = 0.3 | 9 dB


EVM Measurement

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Modulation Accuracy, Flatness and Tolerance Parameters > EVM Measurement
EVM Measurement

The R&S FSW WLAN application provides two different types of EVM calculation.

Contents
  • PPDU EVM (Direct method)
  • Peak Vector Error (IEEE method)


PPDU EVM (Direct method)

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Modulation Accuracy, Flatness and Tolerance Parameters > EVM Measurement > PPDU EVM (Direct method)
PPDU EVM (Direct method)

The PPDU EVM (direct) method evaluates the root mean square EVM over one PPDU. That is the square root of the averaged error power normalized by the averaged reference power:

Before calculation of the EVM, tracking errors in the measured signal are compensated for if specified by the user. In the ideal reference signal, the tracking errors are always compensated for. Tracking errors include phase (center frequency error + common phase error), timing (sampling frequency error) and gain errors. quadrature offset and gain imbalance errors, however, are not corrected.

The PPDU EVM is not part of the IEEE standard and no limit check is specified. Nevertheless, this commonly used EVM calculation can provide some insight in modulation quality and enables comparisons to other modulation standards.

I/Q diagram for EVM calculation


Peak Vector Error (IEEE method)

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Modulation Accuracy, Flatness and Tolerance Parameters > EVM Measurement > Peak Vector Error (IEEE method)
Peak Vector Error (IEEE method)

The peak vector error (Peak EVM) is defined in section 18.4.7.8 "Transmit modulation accuracy" of the IEEE 802.11b standard. The phase, timing and gain tracking errors of the measurement signal (center frequency error, common phase error, sampling frequency error) are compensated for before EVM calculation.

The standard does not specify a normalization factor for the error vector magnitude. To get an EVM value that is independent of the level, the R&S FSW WLAN application normalizes the EVM values. Thus, an EVM of 100% indicates that the error power on the I- or Q-channels equals the mean power on the I- or Q-channels, respectively.

The peak vector error is the maximum EVM over all payload symbols and all active carriers for one PPDU. If more than one PPDU is analyzed (several analyzed PPDUs in the capture buffer or due to the "PPDU Statistic Count / No of PPDUs to Analyze" setting), the Min / Mean / Max columns show the minimum, mean or maximum Peak EVM of all analyzed PPDUs.

The IEEE 802.11b or g (DSSS) standards allow a peak vector error of less than 35%. In contrary to the specification, the R&S FSW WLAN application does not limit the measurement to 1000 chips length, but searches the maximum over the whole PPDU.


Evaluation Methods for WLAN IQ Measurements

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements
Evaluation Methods for WLAN IQ Measurements

The captured I/Q data from the WLAN signal can be evaluated using various different methods without having to start a new measurement or sweep. Which results are displayed depends on the selected evaluation.

The selected evaluation method not only affects the result display in a window, but also the results of the trace data query in remote control (see TRACe<n>[:​DATA]).

All evaluations available for the selected WLAN measurement are displayed in SmartGrid mode.

To activate SmartGrid mode, do one of the following:
  • Select the "SmartGrid" icon from the toolbar.
  • Select the "Display Config" button in the configuration "Overview" (see "Display Configuration").
  • Press the MEAS CONFIG hardkey and then select the "Display Config" softkey.

To close the SmartGrid mode and restore the previous softkey menu select the [image] "Close" icon in the righthand corner of the toolbar, or press any key on the front panel.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .

MIMO measurements

When you capture more than one data stream (MIMO measurement setup, see "Signal Processing for MIMO Measurements (IEEE 802.11ac, n)"), each result display contains several tabs. The results for each data stream are displayed in a separate tab. In addition, an overview tab is provided in which all data streams are displayed at once, in individual subwindows.

The WLAN measurements provide the following evaluation methods:

└ AM/AM
└ AM/PM
└ AM/EVM
└ Bitstream
└ Constellation
└ Constellation vs Carrier
└ EVM vs Carrier
└ EVM vs Chip
└ EVM vs Symbol
└ FFT Spectrum
└ Freq. Error vs Preamble
└ Group Delay
└ Magnitude Capture
└ Phase Error vs Preamble
└ PLCP Header (IEEE 802.11b, g (GSSS)
└ PvT Full PPDU
└ PvT Rising Edge
└ PvT Falling Edge
└ Result Summary Detailed
└ Result Summary Global
└ Signal Field
└ Spectrum Flatness


AM/AM

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > AM/AM
AM/AM

This result display shows the measured and the reference signal in the time domain. For each sample, the x-axis value represents the amplitude of the reference signal and the y-axis value represents the amplitude of the measured signal.

The reference signal is derived from the measured signal after frequency and time synchronisation, channel equalization and demodulation of the signal. The equivalent time domain representation of the reference signal is calculated by reapplying all the impairments that have been removed prior to demodulation.

The trace is determined by calculating a polynomial regression model of a specified degree (see "AM/AM Configuration") for the scattered measurement vs. reference signal data. The resulting regression polynomial is indicated in the window title of the result display.

Note: The measured signal and reference signal are complex signals.

This result display is not available for single-carrier measurements (IEEE 802.11b, g (DSSS)).

Remote command:

LAY:ADD? '1',RIGH,AMAM, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​AM:​AM[:​IMMediate]

Polynomial degree:

CONFigure:​BURSt:​AM:​AM:​POLYnomial


AM/PM

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > AM/PM
AM/PM

This result display shows the measured and the reference signal in the time domain. For each sample, the x-axis value represents the amplitude of the reference signal. The y-axis value represents the angle difference of the measured signal minus the reference signal.

This result display is not available for single-carrier measurements (IEEE 802.11b, g (DSSS)).

Remote command:

LAY:ADD? '1',RIGH,AMPM, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​AM:​PM[:​IMMediate]


AM/EVM

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > AM/EVM
AM/EVM

This result display shows the measured and the reference signal in the time domain. For each sample, the x-axis value represents the amplitude of the reference signal. The y-axis value represents the length of the error vector between the measured signal and the reference signal.

The length of the error vector is normalised with the power of the corresponding reference signal sample.

This result display is not available for single-carrier measurements (IEEE 802.11b, g (DSSS)).

Remote command:

LAY:ADD? '1',RIGH,AMEV, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​AM:​EVM[:​IMMediate]


Bitstream

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > Bitstream
Bitstream

This result display shows and demodulated payload data stream for all analyzed PPDUs of the currently captured I/Q data as indicated in the "Magnitude Capture" display. The bitstream is derived from the constellation diagram points using the 'constellation bit encoding' from the corresponding WLAN standard. See for example IEEE Std. 802.11-2012 'Fig. 18-10 BPSK, QPSK, 16-QAM and 64-QAM constellation bit encoding'. Thus, the bitstream is NOT channel-decoded.

For multicarrier measurements (IEEE 802.11a, g (OFDM), ac, n, p) the results are grouped by symbol and carrier.

Note: MIMO measurements. When you capture more than one data stream (MIMO measurement setup, see "Signal Processing for MIMO Measurements (IEEE 802.11ac, n)"), each result display contains several tabs. The results for each data stream are displayed in a separate tab. In addition, an overview tab is provided in which all data streams are displayed at once, in individual subwindows.

For single-carrier measurements (IEEE 802.11b, g (DSSS)) the results are grouped by PPDU.

The numeric trace results for this evaluation method are described in "Bitstream".

Remote command:

LAY:ADD? '1',RIGH, BITS, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​STATistics:​BSTReam[:​IMMediate]


Constellation

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > Constellation
Constellation

This result display shows the in-phase and quadrature phase results for all payload symbols and all carriers for the analyzed PPDUs of the current capture buffer. The Tracking/Channel Estimation according to the user settings is applied.

The inphase results (I) are displayed on the x-axis, the quadrature phase (Q) results on the y-axis.

Note: MIMO measurements. When you capture more than one data stream (MIMO measurement setup, see "Signal Processing for MIMO Measurements (IEEE 802.11ac, n)"), each result display contains several tabs. The results for each data stream are displayed in a separate tab. In addition, an overview tab is provided in which all data streams are displayed at once, in individual subwindows.

The numeric trace results for this evaluation method are described in "Constellation".

Remote command:

LAY:ADD? '1',RIGH, CONS, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​CONSt:​CSYMbol[:​IMMediate]


Constellation vs Carrier

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > Constellation vs Carrier
Constellation vs Carrier

This result display shows the in-phase and quadrature phase results for all payload symbols and all carriers for the analyzed PPDUs of the current capture buffer. The Tracking/Channel Estimation according to the user settings is applied.

This result display is not available for single-carrier measurements (IEEE 802.11b, g (DSSS)).

The x-axis represents the carriers. The magnitude of the in-phase and quadrature part is shown on the y-axis, both are displayed as separate traces (I-> trace 1, Q-> trace 2).

Note: MIMO measurements. When you capture more than one data stream (MIMO measurement setup, see "Signal Processing for MIMO Measurements (IEEE 802.11ac, n)"), each result display contains several tabs. The results for each data stream are displayed in a separate tab. In addition, an overview tab is provided in which all data streams are displayed at once, in individual subwindows.

The numeric trace results for this evaluation method are described in "Constellation vs Carrier".

Remote command:

LAY:ADD? '1',RIGH, CVC, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​CONSt:​CCARrier[:​IMMediate]


EVM vs Carrier

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > EVM vs Carrier
EVM vs Carrier

This result display shows all EVM values recorded on a per-subcarrier basis over the number of analyzed PPDUs as defined by the "Evaluation Range > Statistics". The Tracking/Channel Estimation according to the user settings is applied (see "Tracking and Channel Estimation"). The Minhold, Average and Maxhold traces are displayed.

This result display is not available for single-carrier measurements (IEEE 802.11b, g (DSSS)).

Note: MIMO measurements. When you capture more than one data stream (MIMO measurement setup, see "Signal Processing for MIMO Measurements (IEEE 802.11ac, n)"), each result display contains several tabs. The results for each data stream are displayed in a separate tab. In addition, an overview tab is provided in which all data streams are displayed at once, in individual subwindows.

The numeric trace results for this evaluation method are described in "EVM vs Carrier".

Remote command:

LAY:ADD? '1',RIGH, EVC, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​EVM:​ECARrier[:​IMMediate]


EVM vs Chip

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > EVM vs Chip
EVM vs Chip

This result display shows the error vector magnitude per chip.

Note: MIMO measurements. When you capture more than one data stream (MIMO measurement setup, see "Signal Processing for MIMO Measurements (IEEE 802.11ac, n)"), each result display contains several tabs. The results for each data stream are displayed in a separate tab. In addition, an overview tab is provided in which all data streams are displayed at once, in individual subwindows.

This result display is only available for single-carrier measurements (IEEE 802.11b, g (DSSS)).

Since the R&S FSW WLAN application provides two different methods to calculate the EVM, two traces are displayed:

  • "Vector Error IEEE" shows the error vector magnitude as defined in the IEEE 802.11b or g (DSSS) standards (see also "Error vector magnitude (EVM) - IEEE 802.11b or g (DSSS) method")
  • "EVM" shows the error vector magnitude calculated with an alternative method that provides higher accuracy of the estimations (see also "Error vector magnitude (EVM) - R&S FSW method").
Remote command:

LAY:ADD? '1',RIGH, EVCH, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​EVM:​ECHip[:​IMMediate]

CONFigure:​BURSt:​EVM:​ESYMbol[:​IMMediate]


EVM vs Symbol

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > EVM vs Symbol
EVM vs Symbol

This result display shows all EVM values calculated on a per-carrier basis over the number of analyzed PPDUs as defined by the "Evaluation Range > Statistics" settings (see "PPDU Statistic Count / No of PPDUs to Analyze"). The Tracking/Channel Estimation according to the user settings is applied (see "Tracking and Channel Estimation"). The MinHold, Maxhold, and Average traces are displayed.

Note: MIMO measurements. When you capture more than one data stream (MIMO measurement setup, see "Signal Processing for MIMO Measurements (IEEE 802.11ac, n)"), each result display contains several tabs. The results for each data stream are displayed in a separate tab. In addition, an overview tab is provided in which all data streams are displayed at once, in individual subwindows.

This result display is not available for single-carrier measurements (IEEE 802.11b, g (DSSS)).

Remote command:

LAY:ADD? '1',RIGH, EVSY, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​EVM:​ESYMbol[:​IMMediate]


FFT Spectrum

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > FFT Spectrum
FFT Spectrum

This result display shows the power vs frequency values obtained from a FFT. The FFT is performed over the complete data in the current capture buffer, without any correction or compensation.

Note: MIMO measurements. When you capture more than one data stream (MIMO measurement setup, see "Signal Processing for MIMO Measurements (IEEE 802.11ac, n)"), each result display contains several tabs. The results for each data stream are displayed in a separate tab. In addition, an overview tab is provided in which all data streams are displayed at once, in individual subwindows.

The numeric trace results for this evaluation method are described in "FFT Spectrum".

Remote command:

LAY:ADD? '1',RIGH, FSP, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​SPECtrum:​FFT[:​IMMediate]


Freq. Error vs Preamble

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > Freq. Error vs Preamble
Freq. Error vs Preamble

Displays the frequency error values recorded over the preamble part of the PPDU. A minimum, average and maximum trace are displayed.

Remote command:

LAY:ADD? '1',RIGH,FEVP, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​PREamble[:​IMMediate]

CONFigure:​BURSt:​PREamble:​SELect


Group Delay

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > Group Delay
Group Delay

Displays all Group Delay (GD) values recorded on a per-subcarrier basis - over the number of analyzed PPDUs as defined by the "Evaluation Range > Statistics" settings (see "PPDU Statistic Count / No of PPDUs to Analyze".

All 57 carriers are shown, including the unused carrier 0.

This result display is not available for single-carrier measurements (IEEE 802.11b, g (DSSS)).

Note: MIMO measurements. When you capture more than one data stream (MIMO measurement setup, see "Signal Processing for MIMO Measurements (IEEE 802.11ac, n)"), each result display contains several tabs. The results for each data stream are displayed in a separate tab. In addition, an overview tab is provided in which all data streams are displayed at once, in individual subwindows.

Group delay is a measure of phase distortion and defined as the derivation of phase over frequency.

To calculate the group delay, the estimated channel is upsampled, inactive carriers are interpolated and phases are unwrapped before they are differentiated over the carrier frequencies. Thus, the group delay indicates the time a pulse in the channel is delayed for each carrier frequency. However, not the absolute delay is of interest, but rather the deviation between carriers. Thus, the mean delay over all carriers is deducted.

For an ideal channel, the phase increases linearly, which causes a constant time delay over all carriers. In this case, a horizontal line at the zero value would be the result.

The numeric trace results for this evaluation method are described in "Group Delay".

Remote command:

LAY:ADD? '1',RIGH, GDEL, see LAYout:​ADD[:​WINDow]?

or:

CONF:BURS:SPEC:FLAT:SEL GRD, see CONFigure:​BURSt:​SPECtrum:​FLATness:​SELect and

CONFigure:​BURSt:​SPECtrum:​FLATness[:​IMMediate]


Magnitude Capture

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > Magnitude Capture
Magnitude Capture

The Magnitude Capture Buffer display shows the complete range of captured data for the last sweep. Green bars at the bottom of the Magnitude Capture Buffer display indicate the positions of the analyzed PPDUs.

Note: MIMO measurements. When you capture more than one data stream (MIMO measurement setup, see "Signal Processing for MIMO Measurements (IEEE 802.11ac, n)"), each result display contains several tabs. The results for each data stream are displayed in a separate tab. In addition, an overview tab is provided in which all data streams are displayed at once, in individual subwindows.

Magnitude Capture display for MIMO measurement with 4 Rx antennas
For the Magnitude Capture display, each subwindow contains additional information for each Rx antenna, namely:
  • Antenna number
  • Center frequency
  • (Mechanical) attenuation (ATT) in dB
  • Electronical attenuation (EL) in dB
  • Reference offset (EXT) in dB
  • Preamplification (PA) in dB

Numeric trace results are not available for this evaluation method.

Remote command:

LAY:ADD? '1',RIGH, CMEM, see LAYout:​ADD[:​WINDow]?


Phase Error vs Preamble

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > Phase Error vs Preamble
Phase Error vs Preamble

Displays the phase error values recorded over the preamble part of the PPDU. A minimum, average and maximum trace are displayed.

Remote command:

LAY:ADD? '1',RIGH,PEVP, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​PREamble[:​IMMediate]

CONFigure:​BURSt:​PREamble:​SELect


PLCP Header (IEEE 802.11b, g (GSSS)

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > PLCP Header (IEEE 802.11b, g (GSSS)
PLCP Header (IEEE 802.11b, g (GSSS)

This result display shows the decoded data from the PLCP header of the PPDU.

This result display is only available for single-carrier measurements (IEEE 802.11b, g (DSSS)); for other standards, use "Signal Field" instead.

The following information is provided:

(The signal field information is provided as a decoded bit sequence and, where appropriate, also in human-readable form beneath the bit sequence for each PPDU.)

Demodulation results in PLCP Header result display (IEEE 802.11b, g (DSSS))
Result | Description | Example
PPDU | Number of the decoded PPDU A colored block indicates that the PPDU was successfully decoded. | PPDU 1
Signal | Information in "signal" field The decoded data rate is shown below. | 01101110 11 MBits/s
Service | Information in "service" field <Symbol clock state> /<Modulation format> / <Length extension bit state> where: <Symbol clock state>: Locked / - - <Modulation format>: see table "Supported modulation formats, PPDU formats and channel bandwidths depending on standard" <Length extension bit state>: 1 (set) / - - (not set) | 00100000 Lock/CCK/- -
PSDU Length | Information in "length" field Time required to transmit the PSDU | 0000000001111000 120 µs
CRC | Information in "CRC" field Result of cyclic redundancy code check: "OK" or "Failed" | 1110100111001110 OK
Remote command:

LAY:ADD? '1',RIGH, SFI, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​STATistics:​SFIeld[:​IMMediate]


PvT Full PPDU

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > PvT Full PPDU
PvT Full PPDU

Displays the minimum, average and maximum power vs time diagram for all PPDUs.

Note: MIMO measurements. When you capture more than one data stream (MIMO measurement setup, see "Signal Processing for MIMO Measurements (IEEE 802.11ac, n)"), each result display contains several tabs. The results for each data stream are displayed in a separate tab. In addition, an overview tab is provided in which all data streams are displayed at once, in individual subwindows.

For single-carrier measurements (IEEE 802.11b, g (DSSS)), the PVT results are displayed as percentage values of the reference power. The reference can be set to either the maximum or mean power of the PPDU.

Remote command:

LAY:ADD:WIND '2',RIGH,PFPP see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​PVT:​SELect

CONFigure:​BURSt:​PVT[:​IMMediate]


PvT Rising Edge

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > PvT Rising Edge
PvT Rising Edge

Displays the minimum, average and maximum power vs time diagram for the rising edge of all PPDUs.

Remote command:

LAY:ADD:WIND '2',RIGH,PRIS see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​PVT:​SELect

CONFigure:​BURSt:​PVT[:​IMMediate]


PvT Falling Edge

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > PvT Falling Edge
PvT Falling Edge

Displays the minimum, average and maximum power vs time diagram for the falling edge of all PPDUs.

Remote command:

LAY:ADD:WIND '2',RIGH,PFAL see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​PVT:​SELect

CONFigure:​BURSt:​PVT[:​IMMediate]


Result Summary Detailed

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > Result Summary Detailed
Result Summary Detailed

The detailed result summary contains individual measurement results for the Transmitter and Receiver channels and for the bitstream.

This result display is not available for single-carrier measurements (IEEE 802.11b, g (DSSS)).

Note: MIMO measurements. When you capture more than one data stream (MIMO measurement setup, see "Signal Processing for MIMO Measurements (IEEE 802.11ac, n)"), each result display contains several tabs. The results for each data stream are displayed in a separate tab. In addition, an overview tab is provided in which all data streams are displayed at once, in individual subwindows.

The "Result Summary Detailed" contains the following information:

Note: You can configure which results are displayed (see "Result Configuration"). However, the results are always calculated, regardless of their visibility.

Tx channel ("Tx All"):
  • I/Q offset [dB]
  • Gain imbalance [%/dB]
  • Quadrature offset [°]
  • I/Q skew [ps]
  • PPDU power [dBm]
  • Crest factor [dB]
Receive channel ("Rx All"):
  • PPDU power [dBm]
  • Crest factor [dB]
Bitstream ("Stream All"):
  • Pilot bit error rate [%]
  • EVM all carriers [%/dB]
  • EVM data carriers [%/dB]
  • EVM pilot carriers [%/dB]

For details on the individual parameters and the summarized values see "Modulation Accuracy, Flatness and Tolerance Parameters".

Remote command:

LAY:ADD? '1',RIGH, RSD, see LAYout:​ADD[:​WINDow]?


Result Summary Global

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > Result Summary Global
Result Summary Global

The global result summary provides measurement results based on the complete signal, consisting of all channels and streams. The observation length is the number of PPDUs to be analyzed as defined by the "Evaluation Range > Statistics" settings. In contrast, the detailed result summary provides results for each individual channel and stream.

For MIMO measurements (IEEE 802.11ac, n), the global result summary provides the results for all data streams, whereas the detailed result summary provides the results for individiual streams.

The "Result Summary Global" contains the following information:

Note: You can configure which results are displayed (see "Result Configuration"). However, the results are always calculated, regardless of their visibility.

  • Number of recognized PPDUs
  • Number of analyzed PPDUs
  • Number of analyzed PPDUs in entire physical channel (if available)
IEEE 802.11a, g (OFDM), ac, n, p standards:
  • Pilot bit error rate [%]
  • EVM all carriers [%/dB]
  • EVM data carriers [%/dB]
  • EVM pilot carriers [%/dB]
  • Center frequency error [Hz]
  • Symbol clock error [ppm]
IEEE 802.11b, g (DSSS) standards:
  • Peak vector error
  • PPDU EVM
  • Quadrature offset
  • Gain imbalance
  • Quadrature error
  • Center frequency error
  • Chip cock error
  • Rise time
  • Fall time
  • Mean power
  • Peak power
  • Crest power

For details on the individual results and the summarized values see "Modulation Accuracy, Flatness and Tolerance Parameters".

Remote command:

LAY:ADD? '1',RIGH, RSG, see LAYout:​ADD[:​WINDow]?


Signal Field

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > Signal Field
Signal Field

This result display shows the decoded data from the "Signal" field of each recognized PPDU. This field contains information on the modulation used for transmission.

This result display is not available for single-carrier measurements (IEEE 802.11b, g (DSSS)); use "PLCP Header (IEEE 802.11b, g (GSSS)" instead.

The signal field information is provided as a decoded bit sequence and, where appropriate, also in human-readable form, beneath the bit sequence for each PPDU.

The currently applied demodulation settings (as defined by the user, see "Demodulation") are indicated beneath the table header for reference. Since the demodulation settings define which PPDUs are to be analyzed, this logical filter may be the reason if the "Signal Field" display is not as expected.

Demodulation parameters and results for Signal Field result display (IEEE 802.11a, g (OFDM), p)
Parameter | Description
Format | PPDU format used for measurement (Not part of the IEEE 802.11a, g (OFDM), p signal field, displayed for convenience; see "PPDU Format to measure")
CBW | Channel bandwidth to measure (Not part of the signal field, displayed for convenience)
Rate / Mbit/s | Symbol rate per second
R | Reserved bit
Length / Sym | Human-readable length of payload in OFDM symbols
P | Parity bit
(Signal) Tail | Signal tail (preset to 0)
Demodulation parameters and results for Signal Field result display (IEEE 802.11ac)
Parameter | Description
Format | PPDU format used for measurement (Not part of the IEEE 802.11ac signal field, displayed for convenience; see "PPDU Format to measure")
MCS | Modulation and Coding Scheme (MCS) index of the PPDU as defined in IEEE Std 802.11-2012 section "20.6 Parameters for HT MCSs"
BW | Channel bandwidth to measure 0: 20 MHz 1: 40 MHz 2: 80 MHz 3: 80+80 MHz and 160MHz
L-SIG Length / Sym | Human-readable length of payload in OFDM symbols
STBC | Space-Time Block Coding 0: no spatial streams of any user has space time block coding 1: all spatial streams of all users have space time block coding
GI | Guard interval length PPDU must have to be measured 1: short guard interval is used in the Data field 0: short guard interval is not used in the Data field
Ness | Number of extension spatial streams (NESS, see "Extension Spatial Streams (sounding)")
CRC | Cyclic redundancy code
Demodulation parameters and results for Signal Field result display (IEEE 802.11n)
Parameter | Description
Format | PPDU format used for measurement (Not part of the IEEE 802.11n signal field, displayed for convenience; see "PPDU Format to measure")
MCS | Modulation and Coding Scheme (MCS) index of the PPDU as defined in IEEE Std 802.11-2012 section "20.6 Parameters for HT MCSs"
CBW | Channel bandwidth to measure 0: 20 MHz or 40 MHz upper/lower 1: 40 MHz
HT-SIG Length / Sym | Human-readable length of payload in OFDM symbols The number of octets of data in the PSDU in the range of 0 to 65 535
SNRA | Smoothing/Not Sounding/Reserved/Aggregation: Smoothing: 1: channel estimate smoothing is recommended 0: only per-carrier independent (unsmoothed) channel estimate is recommended Not Sounding: 1: PPDU is not a sounding PPDU 0: PPDU is a sounding PPDU Reserved: Set to 1 Aggregation: 1: PPDU in the data portion of the packet contains an AMPDU 0: otherwise
STBC | Space-Time Block Coding 00: no STBC (NSTS = NSS) ≠0: the difference between the number of spacetime streams (NSTS) and the number of spatial streams (NSS) indicated by the MCS
GI | Guard interval length PPDU must have to be measured 1: short GI used after HT training 0: otherwise
Ness | Number of extension spatial streams (NESS, see "Extension Spatial Streams (sounding)")
CRC | Cyclic redundancy code of bits 0–23 in HT-SIG1 and bits 0–9 in HT-SIG2
Tail Bits | Used to terminate the trellis of the convolution coder. Set to 0.

The values for the individual demodulation parameters are described in "Demodulation". The following abbreviations are used in the "Signal Field" table:

Abbreviations for demodulation parameters shown in "Signal Field" display
Abbreviation in "Signal Field" display | Parameter in "Demodulation" settings
A1st | Auto, same type as first PPDU
AI | Auto, individual for each PPDU
M<x> | Meas only the specified PPDUs (<x>)
D<x> | Demod all with specified parameter <y>

The Signal Field measurement indicates certain inconsistencies in the signal or discrepancies between the demodulation settings and the signal to be analyzed. In both cases, an appropriate warning is displayed and the results for the PPDU are highlighted orange - both in the "Signal Field" display and the "Magnitude Capture" display. If the signal was analyzed with warnings the results – indicated by a message - also contribute to the overall analysis results.

PPDUs detected in the signal that do not pass the logical filter, i.e. are not to be included in analysis, are dismissed. An appropriate message is provided. The corresponding PPDU in the capture buffer is not highlighted.

The numeric trace results for this evaluation method are described in "Signal Field".

Remote command:

LAY:ADD? '1',RIGH, SFI, see LAYout:​ADD[:​WINDow]?

or:

CONFigure:​BURSt:​STATistics:​SFIeld[:​IMMediate]


Spectrum Flatness

WLAN application (R&S FSW-K91) > Measurements and Result Displays > WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Methods for WLAN IQ Measurements > Spectrum Flatness
Spectrum Flatness

The Spectrum Flatness trace is derived from the magnitude of the estimated channel transfer function. Since this estimated channel is calculated from all payload symbols of the PPDU, it represents a carrier-wise mean gain of the channel. Assuming that we have a cable connection between the DUT and the R&S FSW that adds no residual channel distortion, the "Spectrum Flatness" shows the spectral distortion caused by the DUT (for example the transmit filter).

This result display is not available for single-carrier measurements (IEEE 802.11b, g (DSSS)).

The diagram shows the absolute power per carrier. All 57 carriers are displayed, including the unused carrier 0.

In contrast to the SISO measurements in previous Rohde & Schwarz signal and spectrum analyzers, the trace is no longer normalized to 0 dB (scaled by the mean gain of all carriers).

For more information see "Crosstalk and Spectrum Flatness".

Note: MIMO measurements. When you capture more than one data stream (MIMO measurement setup, see "Signal Processing for MIMO Measurements (IEEE 802.11ac, n)"), each result display contains several tabs. The results for each data stream are displayed in a separate tab. In addition, an overview tab is provided in which all data streams are displayed at once, in individual subwindows.

The numeric trace results for this evaluation method are described in "Spectrum Flatness".

Remote command:

LAY:ADD? '1',RIGH, SFL, see LAYout:​ADD[:​WINDow]?

or:

CONF:BURS:SPEC:FLAT:SEL FLAT (see CONFigure:​BURSt:​SPECtrum:​FLATness:​SELect) and

CONFigure:​BURSt:​SPECtrum:​FLATness[:​IMMediate]


Frequency Sweep Measurements

WLAN application (R&S FSW-K91) > Measurements and Result Displays > Frequency Sweep Measurements
Frequency Sweep Measurements

As described above, the WLAN IQ measurement captures the I/Q data from the WLAN signal using a (nearly rectangular) filter with a relatively large bandwidth. However, some parameters specified in the WLAN 802.11 standard require a better signal-to-noise level or a smaller bandwidth filter than the I/Q measurement provides and must be determined in separate measurements.

Parameters that are common to several digital standards and are often required in signal and spectrum test scenarios can be determined by the standard measurements provided in the R&S FSW base unit (Spectrum application). These measurements are performed using a much narrower bandwidth filter, and they capture only the power level (magnitude, which we refer to as RF data) of the signal, as opposed to the two components provided by I/Q data.

Frequency sweep measurements can tune on a constant frequency ("Zero span measurement") or sweep a frequency range ("Frequency sweep measurement")

The signal cannot be demodulated based on the captured RF data. However, the required power information can be determined much more precisely, as more noise is filtered out of the signal.

The Frequency sweep measurements provided by the R&S FSW WLAN application are identical to the corresponding measurements in the base unit, but are pre-configured according to the requirements of the selected WLAN 802.11 standard.

For details on these measurements see "Measurements" .

The R&S FSW WLAN application provides the following frequency sweep measurements:

Contents
  • Measurement Types and Results for Frequency Sweep Measurements
  • Evaluation Methods for Frequency Sweep Measurements


Measurement Types and Results for Frequency Sweep Measurements

WLAN application (R&S FSW-K91) > Measurements and Result Displays > Frequency Sweep Measurements > Measurement Types and Results for Frequency Sweep Measurements
Measurement Types and Results for Frequency Sweep Measurements

The R&S FSW WLAN application provides the following pre-configured frequency sweep measurements:

└ Channel Power ACLR
└ Spectrum Emission Mask
└ Occupied Bandwidth
└ CCDF


Channel Power ACLR

WLAN application (R&S FSW-K91) > Measurements and Result Displays > Frequency Sweep Measurements > Measurement Types and Results for Frequency Sweep Measurements > Channel Power ACLR
Channel Power ACLR

Channel Power ACLR performs an adjacent channel power (also known as adjacent channel leakage ratio) measurement according to WLAN 802.11 specifications.

The R&S FSW measures the channel power and the relative power of the adjacent channels and of the alternate channels. The results are displayed in the Result Summary.

For details see "Channel Power (ACLR) Measurements".

Remote command:

CONFigure:​BURSt:​SPECtrum:​ACPR[:​IMMediate]

Querying results:

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?


Spectrum Emission Mask

WLAN application (R&S FSW-K91) > Measurements and Result Displays > Frequency Sweep Measurements > Measurement Types and Results for Frequency Sweep Measurements > Spectrum Emission Mask
Spectrum Emission Mask

The Spectrum Emission Mask (SEM) measurement determines the power of the WLAN signal in defined offsets from the carrier and compares the power values with a spectral mask specified by the WLAN 802.11 specifications. The limits depend on the selected bandclass.Thus, the performance of the DUT can be tested and the emissions and their distance to the limit be identified.

Note: The WLAN 802.11 standard does not distinguish between spurious and spectral emissions.

For details see "Spectrum Emission Mask".

Remote command:

CONFigure:​BURSt:​SPECtrum:​MASK[:​IMMediate]

Querying results:

CALCulate:​LIMit<k>:​FAIL?

TRAC:DATA? LIST, see TRACe<n>[:​DATA]


Occupied Bandwidth

WLAN application (R&S FSW-K91) > Measurements and Result Displays > Frequency Sweep Measurements > Measurement Types and Results for Frequency Sweep Measurements > Occupied Bandwidth
Occupied Bandwidth

The Occupied Bandwidth (OBW) measurement determines the bandwidth in which – in default settings - 99 % of the total signal power is to be found. The percentage of the signal power to be included in the bandwidth measurement can be changed.

The occupied bandwidth is indicated as the "Occ BW" function result in the marker table; the frequency markers used to determine it are also displayed.

For details see "Occupied Bandwidth".

Remote command:

CONFigure:​BURSt:​SPECtrum:​OBWidth[:​IMMediate]

Querying results:

CALC:MARK:FUNC:POW:RES? OBW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?


CCDF

WLAN application (R&S FSW-K91) > Measurements and Result Displays > Frequency Sweep Measurements > Measurement Types and Results for Frequency Sweep Measurements > CCDF
CCDF

The CCDF (complementary cumulative distribution function) measurement determines the distribution of the signal amplitudes. . The measurement captures a user-definable amount of samples and calculates their mean power. As a result, the probability that a sample's power is higher than the calculated mean power + x dB is displayed. The crest factor is displayed in the Result Summary.

For details see "CCDF".

Remote command:

CONFigure:​BURSt:​STATistics:​CCDF[:​IMMediate]

Querying results:

CALCulate<n>:​MARKer<m>:​Y?

CALCulate:​STATistics:​RESult<t>?


Evaluation Methods for Frequency Sweep Measurements

WLAN application (R&S FSW-K91) > Measurements and Result Displays > Frequency Sweep Measurements > Evaluation Methods for Frequency Sweep Measurements
Evaluation Methods for Frequency Sweep Measurements

The evaluation methods for frequency sweep measurements in the R&S FSW WLAN application are identical to those in the R&S FSW base unit (Spectrum application).

└ Diagram
└ Result Summary
└ Marker Table
└ Marker Peak List


Diagram

WLAN application (R&S FSW-K91) > Measurements and Result Displays > Frequency Sweep Measurements > Evaluation Methods for Frequency Sweep Measurements > Diagram
Diagram

Displays a basic level vs. frequency or level vs. time diagram of the measured data to evaluate the results graphically. This is the default evaluation method. Which data is displayed in the diagram depends on the "Trace" settings. Scaling for the y-axis can be configured.

Remote command:

LAY:ADD? '1',RIGH, DIAG, see LAYout:​ADD[:​WINDow]?


Result Summary

WLAN application (R&S FSW-K91) > Measurements and Result Displays > Frequency Sweep Measurements > Evaluation Methods for Frequency Sweep Measurements > Result Summary
Result Summary

Result summaries provide the results of specific measurement functions in a table for numerical evaluation. The contents of the result summary vary depending on the selected measurement function. See the description of the individual measurement functions for details.

Remote command:

LAY:ADD? '1',RIGH, RSUM, see LAYout:​ADD[:​WINDow]?


Marker Table

WLAN application (R&S FSW-K91) > Measurements and Result Displays > Frequency Sweep Measurements > Evaluation Methods for Frequency Sweep Measurements > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Marker Peak List

WLAN application (R&S FSW-K91) > Measurements and Result Displays > Frequency Sweep Measurements > Evaluation Methods for Frequency Sweep Measurements > Marker Peak List
Marker Peak List

The marker peak list determines the frequencies and levels of peaks in the spectrum or time domain. How many peaks are displayed can be defined, as well as the sort order. In addition, the detected peaks can be indicated in the diagram. The peak list can also be exported to a file for analysis in an external application.

Remote command:

LAY:ADD? '1',RIGH, PEAK, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Measurement Basics

WLAN application (R&S FSW-K91) > Measurement Basics
Measurement Basics

Some background knowledge on basic terms and principles used in WLAN measurements is provided here for a better understanding of the required configuration settings.

Contents
  • Signal Processing for Multicarrier Measurements (IEEE 802.11a, g (OFDM))
  • Signal Processing for Single-Carrier Measurements (IEEE 802.11b, g (DSSS))
  • Signal Processing for MIMO Measurements (IEEE 802.11ac, n)
  • Channels and Carriers
  • Recognized vs. Analyzed PPDUs
  • Demodulation Parameters - Logical Filters
  • Receiving Data Input and Providing Data Output
  • Preparing the R&S FSW for the Expected Input Signal - Frontend Parameters
  • Triggered measurements


Signal Processing for Multicarrier Measurements (IEEE 802.11a, g (OFDM))

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for Multicarrier Measurements (IEEE 802.11a, g (OFDM))
Signal Processing for Multicarrier Measurements (IEEE 802.11a, g (OFDM))

This description gives a rough view of the signal processing when using the R&S FSW WLAN application with the IEEE 802.11a, or g (OFDM) standard. Details are disregarded in order to provide a concept overview.

Abbreviations
al,k | symbol at symbol l of subcarrier k
EVMk | error vector magnitude of subcarrier k
EVM | error vector magnitude of current packet
g | signal gain
Δf | frequency deviation between Tx and Rx
l | symbol index l = {1 ... nof_Symbols}
nof_symbols | number of symbols of payload
Hk | channel transfer function of subcarrier k
k | channel index k = {–31 ... 32}
Kmod | modulation-dependent normalization factor
ξ | relative clock error of reference oscillator
rl,k | subcarrier of symbol l
Contents
  • Block Diagram for Multicarrier Measurements
  • Literature on the IEEE 802.11a Standard


Block Diagram for Multicarrier Measurements

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for Multicarrier Measurements (IEEE 802.11a, g (OFDM)) > Block Diagram for Multicarrier Measurements
Block Diagram for Multicarrier Measurements

A diagram of the significant blocks when using the IEEE 802.11a, or g (OFDM) standard in the R&S FSW WLAN application is shown in figure "Block diagram for the R&S FSW WLAN application using the IEEE 802.11a, or g (OFDM) standard".

First the RF signal is downconverted to the IF frequency fIF. The resulting IF signal rIF(t) is shown on the left-hand side of the figure. After bandpass filtering, the signal is sampled by an analog to digital converter (ADC) at a sample rate of fs1. This digital sequence is resampled. Thus, the sample rate of the downsampled sequence r(i) is the Nyquist rate of fs3 = 20 MHz. Up to this point the digital part is implemented in an ASIC.

Block diagram for the R&S FSW WLAN application using the IEEE 802.11a, or g (OFDM) standard

In the lower part of the figure the subsequent digital signal processing is shown.

Packet search and timing detection

In the first block the packet search is performed. This block detects the long symbol (LS) and recovers the timing. The coarse timing is detected first. This search is implemented in the time domain. The algorithm is based on cyclic repetition within the LS after N = 64 samples. Numerous treatises exist on this subject, e.g. [1] to [3].

Furthermore, a coarse estimate Δ [image] coarse of the Rx-Tx frequency offset Δf is derived from the metric in [6]. (The hat generally indicates an estimate, e.g. is the estimate of x.) This can easily be understood because the phase of r(i) ·Δ r* (i + N) is determined by the frequency offset. As the frequency deviation Δf can exceed half a bin (distance between neighboring sub-carriers) the preceding short symbol (SS) is also analyzed in order to detect the ambiguity.

After the coarse timing calculation the time estimate is improved by the fine timing calculation. This is achieved by first estimating the coarse frequency response Ĥ(LS)k, where k = {–26.. 26} denotes the channel index of the occupied sub-carriers. First the FFT of the LS is calculated. After the FFT calculation the known symbol information of the LS sub-carriers is removed by dividing by the symbols. The result is a coarse estimate Ĥk of the channel transfer function. In the next step, the complex channel impulse response is computed by an IFFT. Then the energy of the windowed impulse response (the window size is equal to the guard period) is calculated for each trial time. Afterwards the trial time of the maximum energy is detected. This trial time is used to adjust the timing.

Determing the payload window

Now the position of the LS is known and the starting point of the useful part of the first payload symbol can be derived. In the next block this calculated time instant is used to position the payload window. Only the payload part is windowed. This is sufficient because the payload is the only subject of the subsequent measurements.

In the next block the windowed sequence is compensated by the coarse frequency estimate Δ [image] course. This is necessary because otherwise inter-channel interference (ICI) would occur in the frequency domain.

The transition to the frequency domain is achieved by an FFT of length 64. The FFT is performed symbol-wise for each symbol of the payload ("nof_symbols"). The calculated FFTs are described byrl,k with:

  • l = {1 .. nof_symbols} as the symbol index
  • k = {–31 .. 32} as the channel index

In case of an additive white Gaussian noise (AWGN) channel, the FFT is described by [4], [5]

FFT

with:

  • Kmod: the modulation-dependant normalization factor
  • al,k: the symbol of sub-carrier k at symbol l
  • gl: the gain at the symbol l in relation to the reference gain g = 1 at the long symbol (LS)
  • Hk: the channel frequency response at the long symbol (LS)
  • phasel (common): the common phase drift phase of all sub-carriers at symbol l (see equation "Common phase drift")
  • phasel,k (timing): the phase of sub-carrier k at symbol l caused by the timing drift (see equation "Common phase drift")
  • nl,k: the independent Gaussian distributed noise samples
Phase drift and frequency deviation

The common phase drift in equation "FFT" is given by:

Common phase drift

with

  • Ns = 80: the number of Nyquist samples of the symbol period
  • N = 64: the number of Nyquist samples of the useful part of the symbol
  • Δ frest: the (not yet compensated) frequency deviation
  • dϒ l: the phase jitter at the symbol l

In general, the coarse frequency estimate Δ [image] coarse (see figure "Block diagram for the R&S FSW WLAN application using the IEEE 802.11a, or g (OFDM) standard") is not error-free. Therefore the remaining frequency error Δfrest represents the frequency deviation in rl,k not yet compensated. Consequently, the overall frequency deviation of the device under test (DUT) is calculated by:

Δf = Δ [image] coarse + Δfrest

The common phase drift in equation "Common phase drift" is divided into two parts to calculate the overall frequency deviation of the DUT.

The reason for the phase jitter dγ l in equation "Common phase drift" may be different. The nonlinear part of the phase jitter may be caused by the phase noise of the DUT oscillator. Another reason for nonlinear phase jitter may be the increase of the DUT amplifier temperature at the beginning of the PPDU. Note that besides the nonlinear part the phase jitter, dγ l also contains a constant part. This constant part is caused by the frequency deviation Δ frest not yet compensated. To understand this, keep in mind that the measurement of the phase starts at the first symbol l = 1 of the payload. In contrast, the channel frequency response Hk in equation "FFT" represents the channel at the long symbol of the preamble. Consequently, the frequency deviation Δ frest not yet compensated produces a phase drift between the long symbol and the first symbol of the payload. Therefore, this phase drift appears as a constant value ("DC value") in dϒ l.

Tracking the phase drift, timing jitter and gain

Referring to the IEEE 802.11a, g (OFDM) measurement standard, chapter 17.3.9.7 "Transmit modulation accuracy test'' [6], the common phase drift phasel (common) must be estimated and compensated from the pilots. Therefore this "symbol-wise phase tracking'' is activated as the default setting of the R&S FSW WLAN application (see "Phase Tracking").

Furthermore, the timing drift in equation "FFT" is given by:

Timing drift

with ξ: the relative clock deviation of the reference oscillator

Normally, a symbol-wise timing jitter is negligible and thus not modeled in equation "Timing drift". However, there may be situations where the timing drift has to be taken into account. This is illustrated by an example: In accordance to [6], the allowed clock deviation of the DUT is up to ξ max = 20 ppm. Furthermore, a long packet with 400 symbols is assumed. The result of equation "FFT" and equation "Timing drift" is that the phase drift of the highest sub-carrier k = 26 in the last symbol l = nof_symbols is 93 degrees. Even in the noise-free case, this would lead to symbol errors. The example shows that it is actually necessary to estimate and compensate the clock deviation, which is accomplished in the next block.

Referring to the IEEE 802.11a, g (OFDM) measurement standard [6], the timing drift phasel,k(timing) is not part of the requirements. Therefore the "time tracking" is not activated as the default setting of the R&S FSW WLAN application (see "Timing Error Tracking"). The time tracking option should rather be seen as a powerful analyzing option.

In addition, the tracking of the gain gl in equation "FFT" is supported for each symbol in relation to the reference gain g = 1 at the time instant of the long symbol (LS). At this time the coarse channel transfer function Ĥ(LS)k is calculated.

This makes sense since the sequence r'l,k is compensated by the coarse channel transfer function Ĥ(LS)k before estimating the symbols. Consequently, a potential change of the gain at the symbol l (caused, for example, by the increase of the DUT amplifier temperature) may lead to symbol errors especially for a large symbol alphabet M of the MQAM transmission. In this case, the estimation and the subsequent compensation of the gain are useful.

Referring to the IEEE 802.11a, g (OFDM) measurement standard [6], the compensation of the gain gl is not part of the requirements. Therefore the "gain tracking" is not activated as the default setting of the R&S FSW WLAN application (see ."Level Error (Gain) Tracking").

Determining the error parameters (log likelihood function)

How can the parameters above be calculated? In this application the optimum maximum likelihood algorithm is used. In the first estimation step the symbol-independent parameters Δ frest and ξ are estimated. The symbol dependent parameters can be neglected in this step, i.e. the parameters are set to gl = 1 and dγ = 0. Referring to equation "FFT", the log likelihood function L must be calculated as a function of the trial parameters Δ [image] rest and [image]. (The tilde generally describes a trial parameter. Example: is the trial parameter of x.)

Log likelihood function (step 1)

The trial parameters leading to the minimum of the log likelihood function are used as estimates Δ [image] rest and [image]. In equation "Log likelihood function (step 1)" the known pilot symbols al,k are read from a table.

In the second step, the log likelihood function is calculated for every symbol l as a function of the trial parameters [image] l and d [image] l:

Log likelihood function (step 2)

Finally, the trial parameters leading to the minimum of the log likelihood function are used as estimates ĝl and [image].

This robust algorithm works well even at low signal to noise ratios with the Cramer Rao Bound being reached.

Compensation

After estimation of the parameters, the sequence rl,k is compensated in the compensation blocks.

In the upper analyzing branch the compensation is user-defined i.e. the user determines which of the parameters are compensated. This is useful in order to extract the influence of these parameters. The resulting output sequence is described by: γ'δ,k.

Data symbol estimation

In the lower compensation branch the full compensation is always performed. This separate compensation is necessary in order to avoid symbol errors. After the full compensation the secure estimation of the data symbols âl,k is performed. From equation "FFT" it is clear that first the channel transfer function Hk must be removed. This is achieved by dividing the known coarse channel estimate Ĥ(LS)k calculated from the LS. Usually an error free estimation of the data symbols can be assumed.

Improving the channel estimation

In the next block a better channel estimate Ĥ(PL)k of the data and pilot sub-carriers is calculated by using all "nof_symbols" symbols of the payload (PL). This can be accomplished at this point because the phase is compensated and the data symbols are known. The long observation interval of nof_symbols symbols (compared to the short interval of 2 symbols for the estimation of Ĥ(LS)k) leads to a nearly error-free channel estimate.

In the following equalizer block, Ĥ(LS)k is compensated by the channel estimate. The resulting channel-compensated sequence is described by γδ,k''. The user may either choose the coarse channel estimate Ĥ(LS)k (from the long symbol) or the nearly error-free channel estimate Ĥ(PL)k (from the payload) for equalization. If the improved estimate Ĥ(LS)k is used, a 2 dB reduction of the subsequent EVM measurement can be expected.

According to the IEEE 802.11a measurement standard [6], the coarse channel estimation Ĥ(LS)k (from the long symbol) has to be used for equalization. Therefore the default setting of the R&S FSW WLAN application is equalization from the coarse channel estimate derived from the long symbol.

Calculating error parameters

In the last block the parameters of the demodulated signal are calculated. The most important parameter is the error vector magnitude of the sub-carrier "k" of the current packet:

Error vector magnitude of the subcarrier k in current packet

Furthermore, the packet error vector magnitude is derived by averaging the squared EVMk versus k:

Error vector magnitude of the entire packet

Finally, the average error vector magnitude is calculated by averaging the packet EVM of all nof_symbols detected packets:

Average error vector magnitude

This parameter is equivalent to the "RMS average of all errors": ErrorRMS of the IEEE 802.11a measurement commandment (see [6]).


Literature on the IEEE 802.11a Standard

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for Multicarrier Measurements (IEEE 802.11a, g (OFDM)) > Literature on the IEEE 802.11a Standard
Literature on the IEEE 802.11a Standard
[1] | Speth, Classen, Meyr: ''Frame synchronization of OFDM systems in frequency selective fading channels", VTC '97, pp. 1807-1811
[2] | Schmidl, Cox: ''Robust Frequency and Timing Synchronization of OFDM", IEEE Trans. on Comm., Dec. 1997, pp. 1613-621
[3] | Minn, Zeng, Bhargava: ''On Timing Offset Estimation for OFDM", IEEE Communication Letters, July 2000, pp. 242-244
[4] | Speth, Fechtel, Fock, Meyr: ''Optimum receive antenna Design for Wireless Broad-Band Systems Using OFDM – Part I", IEEE Trans. On Comm. VOL. 47, NO 11, Nov. 1999
[5] | Speth, Fechtel, Fock, Meyr: ''Optimum receive antenna Design for Wireless Broad-Band Systems Using OFDM – Part II", IEEE Trans. On Comm. VOL. 49, NO 4, April. 2001
[6] | IEEE 802.11a, Part 11: WLAN Medium Access Control (MAC) and Physical Layer (PHY) specifications


Signal Processing for Single-Carrier Measurements (IEEE 802.11b, g (DSSS))

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for Single-Carrier Measurements (IEEE 802.11b, g (DSSS))
Signal Processing for Single-Carrier Measurements (IEEE 802.11b, g (DSSS))

This description gives a rough overview of the signal processing concept of the WLAN 802.11 application for IEEE 802.11b or g (DSSS) signals.

Abbreviations
ε | timing offset
Δ"f" | frequency offset
ΔΦ | phase offset
ĝI | estimate of the gain factor in the I-branch
ĝQ | estimate of the gain factor in the Q-branch
ΔĝQ | accurate estimate of the crosstalk factor of the Q-branch in the I-branch
ĥs(v) | estimated baseband filter of the transmit antenna
ĥr(v) | estimated baseband filter of the receive antenna
ôI | estimate of the IQ-offset in the I-branch
ôQ | estimate of the IQ-offset in the I-branch
r(v) | measurement signal
ŝ(v) | estimate of the reference signal
ŝn(v) | estimate of the power-normalized and undisturbed reference signal
ARG{...} | calculation of the angle of a complex value
EVM | error vector magnitude
IMAG{...} | calculation of the imaginary part of a complex value
PPDU | protocol data unit - a burst in the signal containing transmission data
PSDU | protocol service data unit- a burst in the signal containing service data
REAL{...} | calculation of the real part of a complex value
Contents
  • Block Diagram for Single-Carrier Measurements
  • Calculation of Signal Parameters
  • Literature on the IEEE 802.11b Standard


Block Diagram for Single-Carrier Measurements

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for Single-Carrier Measurements (IEEE 802.11b, g (DSSS)) > Block Diagram for Single-Carrier Measurements
Block Diagram for Single-Carrier Measurements

A block diagram of the measurement application is shown below in figure "Signal processing for IEEE 802.11b or g (DSSS) signals". The baseband signal of an IEEE 802.11b or g (DSSS) wireless LAN system transmit antenna is sampled with a sample rate of 44 MHz.

The first task of the measurement application is to detect the position of the PPDU within the measurement signal r1(v). The detection algorithm is able to find the the beginning of short and long PPDUs and can distinguish between them. The algorithm also detects the initial state of the scrambler, which is not specified by the IEEE 802.11 standard.

If the start position of the PPDU is known, the header of the PPDU can be demodulated. The bits transmitted in the header provide information about the length of the PPDU and the modulation type used in the PSDU.

Once the start position and the PPDU length are fully known, better estimates of timing offset, timing drift, frequency offset and phase offset can be calculated using the entire data of the PPDU.

At this point of the signal processing, demodulation can be performed without decision error. After demodulation the normalized (in terms of power) and undisturbed reference signal s(v) is available.

If the frequency offset is not constant and varies with time, the frequency offset and phase offset in several partitions of the PPDU must be estimated and corrected. Additionally, timing offset, timing drift and gain factor can be estimated and corrected in several partitions of the PPDU. These corrections can be switched off individually in the demodulation settings of the application.

Signal processing for IEEE 802.11b or g (DSSS) signals

Once the the normalized and undisturbed reference signal is available, the transmit antenna baseband filter (Tx filter) is estimated by minimizing the cost function of a maximum-likelihood-based estimator:

transmit antenna baseband filter (Tx filter) estimation


Calculation of Signal Parameters

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for Single-Carrier Measurements (IEEE 802.11b, g (DSSS)) > Calculation of Signal Parameters
Calculation of Signal Parameters

The frequency offset, the phase offset and the IQ-offset are estimated jointly with the coefficients of the transmit filter to increase the estimation quality.

Once the transmit filter is known, all other unknown signal parameters are estimated with a maximum-likelihood-based estimation, which minimizes the cost function:

Cost function for signal parameters

The unknown signal parameters are estimated in a joint estimation process to increase the accuracy of the estimates.

The accurate estimates of the frequency offset, the gain imbalance, the quadrature error and the normalized I/Q offset are displayed by the measurement software.

Gain imbalance, I/Q offset, quadrature error

The gain imbalance is the quotient of the estimates of the gain factor of the Q-branch, the crosstalk factor and the gain factor of the I-branch:

Gain imbalance

The quadrature error is a measure for the crosstalk of the Q-branch into the I-branch:

Quadrature error (crosstalk)

The normalized I/Q offset is defined as the magnitude of the I/Q offset normalized by the magnitude of the reference signal:

I/Q offset

At this point of the signal processing all unknown signal parameters such as timing offset, frequency offset, phase offset, I/Q offset and gain imbalance have been evaluated and the measurement signal can be corrected accordingly.

Error vector magnitude (EVM) - R&S FSW method

Using the corrected measurement signal r(v) and the estimated reference signal ŝ(v), the modulation quality parameters can be calculated. The mean error vector magnitude (EVM) is the quotient of the root-mean-square values of the error signal power and the reference signal power:

Mean error vector magnitude (EVM)

Whereas the symbol error vector magnitude is the momentary error signal magnitude normalized by the root mean square value of the reference signal power:

Symbol error vector magnitude
Error vector magnitude (EVM) - IEEE 802.11b or g (DSSS) method

In [2] a different algorithm is proposed to calculate the error vector magnitude. In a first step the IQ-offset in the I-branch and the IQ-offset of the Q-branch are estimated separately:

I/Q offset I-branch
I/Q offset Q-branch

where r(v) is the measurement signal which has been corrected with the estimates of the timing offset, frequency offset and phase offset, but not with the estimates of the gain imbalance and I/Q offset

With these values the gain imbalance of the I-branch and the gain imbalance of the Q-branch are estimated in a non-linear estimation in a second step:

Gain imbalance I-branch
Gain imbalance Q-branch

Finally, the mean error vector magnitude can be calculated with a non-data-aided calculation:

Mean error vector magnitude

The symbol error vector magnitude is the error signal magnitude normalized by the root mean square value of the estimate of the measurement signal power:

Symbol error vector magnitude

The advantage of this method is that no estimate of the reference signal is needed, but the I/Q offset and gain imbalance values are not estimated in a joint estimation procedure. Therefore, each estimation parameter disturbs the estimation of the other parameter and the accuracy of the estimates is lower than the accuracy of the estimations achieved by equation "transmit antenna baseband filter (Tx filter) estimation". If the EVM value is dominated by Gaussian noise this method yields similar results as equation "Cost function for signal parameters".

The EVM vs Symbol result display shows two traces, each using a different calculation method, so you can easily compare the results (see "EVM vs Symbol").


Literature on the IEEE 802.11b Standard

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for Single-Carrier Measurements (IEEE 802.11b, g (DSSS)) > Literature on the IEEE 802.11b Standard
Literature on the IEEE 802.11b Standard
[1] | Institute of Electrical and Electronic Engineers, Part 11: Wireless LAN Medium Access Control (MAC) and Physical Layer (PHY) specifications, IEEE Std 802.11-1999, Institute of Electrical and Electronic Engineers, Inc., 1999.
[2] | Institute of Electrical and Electronic Engineers, Part 11: Wireless LAN Medium Access Control (MAC) and Physical Layer (PHY) specifications: Higher-Speed Physical Layer Extensions in the 2.4 GHz Band, IEEE Std 802.11b-1999, Institute of Electrical and Electronic Engineers, Inc., 1999.


Signal Processing for MIMO Measurements (IEEE 802.11ac, n)

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for MIMO Measurements (IEEE 802.11ac, n)
Signal Processing for MIMO Measurements (IEEE 802.11ac, n)

For measurements according to the IEEE 802.11a, b, g standards, only a single transmit antenna and a single receive antenna are required (SISO = single in, single out). For measurements according to the IEEE 802.11ac or n standard, the R&S FSW can measure multiple data streams between multiple transmit antennas and multiple receive antennas (MIMO = multiple in, multiple out).

As opposed to other Rohde & Schwarz signal and spectrum analyzers, in the R&S FSW WLAN application, MIMO is not selected as a specific standard. Rather, when you select the IEEE 802.11ac or n standard, MIMO is automatically available. In the default configuration, a single transmit antenna and a single receive antenna are assumed, which corresponds to the common SISO setup.

Basic technologies

Some basic technologies used in MIMO systems are introduced briefly here. For more detailed information, see the Rohde & Schwarz Application Note "Introduction to MIMO" (1MA142_0e), available for download from the Rohde & Schwarz website.

MIMO systems use transmit diversity or space-division multiplexing, or both. With transmit diversity, a bit stream is transmitted simultaneously via two antennas, but with different coding in each case. This improves the signal-to-noise ratio and the cell edge capacity.

For space-division multiplexing, multiple (different) data streams are sent simultaneously from the transmit antennas. Each receive antenna captures the superposition of all transmit antennas. In addition, channel effects caused by reflections and scattering etc., are added to the received signals. The receiver determines the originally sent symbols by multiplying the received symbols with the inverted channel matrix (that is, the mapping between the streams and the transmit antennas, see "Spatial Mapping").

Using space-division multiplexing, the transmitted data rates can be increased significantly by using additional antennas.

To reduce the correlation between the propagation paths, the transmit antenna can delay all of the transmission signals except one. This method is referred to as cyclic delay diversity or cyclic delay shift.

The basis of the majority of the applications for broadband transmission is the OFDM method. In contrast to single-carrier methods, an OFDM signal is a combination of many orthogonal, separately modulated carriers. Since the data is transmitted in parallel, the symbol length is significantly smaller than in single-carrier methods with identical transmission rates.

Signal processing chain

In a test setup with multiple antennas, the R&S FSW is likely to receive multiple spatial streams, one from each antenna. Each stream has gone through a variety of transformations during transmission. The signal processing chain is displayed in figure "Data flow from the transmit antenna to the receive antenna", starting with the creation of the spatial streams in the transmitting device, through the wireless transmission and ending with the merging of the spatial streams in the receiving device. This processing chain has been defined by IEEE.

The following figure shows the basic processing steps performed by the transmit antenna and the complementary blocks in reverse order applied at the receive antenna:

Data flow from the transmit antenna to the receive antenna
Contents
  • Space-Time Block Coding (STBC)
  • Spatial Mapping
  • Physical vs Effective Channels
  • Capturing Data from MIMO Antennas
  • Calculating Results
  • Crosstalk and Spectrum Flatness


Space-Time Block Coding (STBC)

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for MIMO Measurements (IEEE 802.11ac, n) > Space-Time Block Coding (STBC)
Space-Time Block Coding (STBC)

The coded bits to be transmitted are modulated to create a data stream, referred to as a spatial stream, by the stream parser in the transmitting device under test (see figure "Data flow from the transmit antenna to the receive antenna").

The Space-Time Block Encoder (STBC) implements the transmit diversity technique (see "Basic technologies"). It creates multiple copies of the data streams, each encoded differently, which can then be transmitted by a number of antennas.

To do so, the STBC encodes only the data carriers in the spatial stream using a matrix. Each row in the matrix represents an OFDM symbol and each column represents one antenna's transmissions over time (thus the term space-time encoder). This means each block represents the same data, but with a different coding. The resulting blocks are referred to as space-time streams (STS). Each stream is sent to a different Tx antenna. This diversity coding increases the signal-to-noise ratio at the receive antenna. The pilot carriers are inserted after the data carriers went through the STBC. Thus, only the data carriers are decoded by the analyzer to determine characteristics of the demodulated data (see also figure "Results at individual processing stages").

In order to transmit the space-time streams, two or more antennas are required by the sender, and one or more antennas are required by the receive antenna.


Spatial Mapping

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for MIMO Measurements (IEEE 802.11ac, n) > Spatial Mapping
Spatial Mapping

The Spatial Encoder (see figure "Data flow from the transmit antenna to the receive antenna") is responsible for the spatial multiplexing. It defines the mapping between the streams and the transmit antennas - referred to as spatial mapping - or as a matrix: the spatial mapping matrix.

In the R&S FSW WLAN application, the mapping can be defined using the following methods:
  • Direct mapping: one single data stream is mapped to an exclusive Tx antenna
    (The spatial matrix contains "1" on the diagonal and otherwise zeros.)
  • Spatial Expansion: multiple (different) data streams are assigned to each antenna in a defined pattern
  • User-defined mapping: the data streams are mapped to the antennas by a user-defined matrix
User-defined spatial mapping

You can define your own spatial mapping between streams and Tx antennas.

For each antenna (Tx1..4), the complex element of each STS-stream is defined. The upper value is the real part part of the complex element. The lower value is the imaginary part of the complex element.

Additionally, a "Time Shift" can be defined for cyclic delay diversity (CSD).

The stream for each antenna is calculated as:


Physical vs Effective Channels

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for MIMO Measurements (IEEE 802.11ac, n) > Physical vs Effective Channels
Physical vs Effective Channels

The effective channel refers to the transmission path starting from the space-time stream and ending at the receive antenna. It is the product of the following components:

  • the spatial mapping
  • the crosstalk inside the device under test (DUT) transmission paths
  • the crosstalk of the channel between the transmit antennas and the receive antennas

For each space-time stream, at least one training field (the (V)HT-LTF) is included in every PPDU preamble (see figure "Training fields (TF) in the preamble of PPDUs in IEEE 802.11n standard"). Each sender antenna transmits these training fields, which are known by the receive antenna. The effective channel can be calculated from the received (and known) (V)HT-LTF symbols of the preamble, without knowledge of the spatial mapping matrix or the physical channel. Thus, the effective channel can always be calculated.

Training fields (TF) in the preamble of PPDUs in IEEE 802.11n standard

The effective channel is sufficient to calculate the EVM, the constellation diagram and the bitstream results of the measured signal, so these results are always available.

The physical channel refers to the transmission path starting from the transmit antenna streams and ending at the receive antenna. It is the product of the following components:

  • the crosstalk inside the device under test (DUT) transmission paths
  • the crosstalk of the channel between the transmit antennas and the receive antennas

The physical channel is derived from the effective channel using the inverted spatial mapping matrix Q:

Hphy = HeffQ-1

Thus, if the spatial mapping matrix cannot be inverted, the physical channel cannot be calculated. This may be the case, for example, if the signal contains fewer streams than Rx antenna signals, or if the spatial matrix is close to numerical singularity.

In this case, results that are based on the transmit antenna such as I/Q offset, gain imbalance and quadrature offset are not available.

Crosstalk in estimated channels
Note that the estimated channel transfer function contains crosstalk from various sources, for example:
  • from the transmission paths inside the DUT
  • from the connection between the analyzer and the DUT
  • from the analyzer itself

The crosstalk from the analyzer can be neglected. If the analyzer and DUT are connected by cable, this source of crosstalk can also be neglected. For further information on crosstalk see "Crosstalk and Spectrum Flatness".


Capturing Data from MIMO Antennas

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for MIMO Measurements (IEEE 802.11ac, n) > Capturing Data from MIMO Antennas
Capturing Data from MIMO Antennas

The primary purpose of many test applications that verify design parameters, or are used in production, is to determine if the transmitted signals adhere to the relevant standards and whether the physical characteristics fall within the specified limits. In such cases there is no need to measure the various transmit paths simultaneously. Instead, they can either be tested as single antenna measurements, or sequentially (with restrictions, see also "Sequential MIMO Measurement"). Then only one analyzer is needed to measure parameters such as error vector magnitude (EVM), power and I/Q imbalance.

Measurements that have to be carried out for development or certification testing are significantly more extensive. In order to fully reproduce the data in transmit signals or analyze the crosstalk between the antennas, for example, measurements must be performed simultaneously on all antennas. One analyzer is still sufficient if the system is using transmit diversity (multiple input single output – MISO). However, space-division multiplexing requires two or more analyzers to calculate the precoding matrix and demodulate the signals.

The R&S FSW WLAN application provides the following methods to capture data from the MIMO antennas:

  • Simultaneous MIMO operation
    The data streams are measured simultaneously by multiple analyzers. One of the analyzers is defined as a master, which receives the I/Q data from the other analyzers (the slaves). The IP addresses of each slave analyzer must be provided to the master. The only function of the slaves is to record the data that is then accumulated centrally by the master.
    (Note that only the MIMO master analyzer requires the R&S FSW-K91n or ac option. The slave analyzers do not require a R&S FSW WLAN application.)
    The number of Tx antennas on the DUT defines the number of analyzers required for this measurement setup.
    The master calculates the measurement results based on the I/Q data captured by all analyzers (master and slaves) and displays them in the selected result displays.
  • Sequential using open switch platform
    The data streams are measured sequentially by a single analyzer connected to an additional switch platform that switches between antenna signals. No manual interaction is necessary during the measurement. The R&S FSW WLAN application captures the I/Q data for all antennas sequentially and calculates and displays the results (individually for each data stream) in the selected result displays automatically.
    A single analyzer and the Rohde & Schwarz OSP Switch Platform is required to measure the multiple DUT Tx antennas (the switch platform must be fitted with at least one R&S®OSP-B101 option; the number depends on the number of Tx antennas to measure). The IP address of the OSP and the used module (configuration bank) must be defined on the analyzer; the required connections between the DUT Tx antennas, the switch box and the analyzer are indicated in the MIMO "Signal Capture" dialog box.
    For important restrictions concerning sequential measurement see "Sequential MIMO Measurement".
  • Sequential using manual operation
    The data streams are captured sequentially by a single analyzer. The antenna signals must be connected to the single analyzer input sequentially by the user.
    In the R&S FSW WLAN application, individual capture buffers are provided (and displayed) for each antenna input source, so that results for the individual data streams can be calculated. The user must initiate data capturing for each antenna and result calculation for all data streams manually.
    For important restrictions concerning sequential measurement see "Sequential MIMO Measurement".
  • Single antenna measurement
    The data from the Tx antenna is measured and evaluated as a single antenna (SISO) measurement ("DUT MIMO configuration" = "1 Tx antenna").
Contents
  • Sequential MIMO Measurement


Sequential MIMO Measurement

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for MIMO Measurements (IEEE 802.11ac, n) > Capturing Data from MIMO Antennas > Sequential MIMO Measurement
Sequential MIMO Measurement

Sequential MIMO measurement allows for MIMO analysis with a single analyzer by capturing the receive antennas one after another (sequentially). However, sequential MIMO measurement requires each Tx antenna to transmit the same PPDU over time. (The PPDU content from different Tx antennas, on the other hand, may be different.) If this requirement can not be fulfilled, use the simultaneous MIMO capture method (see "Capturing Data from MIMO Antennas").

In addition, the following PPDU attributes must be identical for ALL antennas:
  • PPDU length
  • PPDU type
  • Channel bandwidth
  • MCS Index
  • Guard Interval Length
  • Number of STBC Streams
  • Number of Extension Streams

Thus, for each PPDU the Signal Field bit vector has to be identical for ALL antennas!

Basic principle of “Sequential MIMO Measurement” with 2 receive antennas

Note that, additionally, the data contents of the sent PPDU payloads must also be the same for each Tx antenna, but this is not checked. Thus, useless results are returned if different data was sent.

To provide identical PPDU content for each Tx antenna in the measurement, you can use the same pseudo-random bit sequence (PRBS) with the same PRBS seed (initial bit sequence), for example, when generating the useful data for the PPDU.


Calculating Results

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for MIMO Measurements (IEEE 802.11ac, n) > Calculating Results
Calculating Results

When you analyze a WLAN signal in a MIMO setup, the R&S FSW acts as the receiving device. Since most measurement results have to be calculated at a particular stage in the processing chain, the R&S FSW WLAN application has to do the same decoding that the receive antenna does.

The following diagram takes a closer look at the processing chain and the results at its individual stages.

Results at individual processing stages
Receive antenna results
The R&S FSW WLAN application can determine receive antenna results directly from the captured data at the receive antenna, namely:
  • PPDU Power
  • Crest factor

For all other results, the R&S FSW WLAN application has to revert the processing steps to determine the signal characteristics at those stages.

Transmit antenna results (based on the physical channel)
If the R&S FSW WLAN application can determine the physical channel (see "Physical vs Effective Channels"), it can evaluate the following results:
  • Channel Flatness (based on the physical channel)
  • Group Delay (based on the physical channel)
  • I/Q Offset
  • Quadrature Offset
  • Gain Imbalance
Space-time stream results (based on the effective channel)
If the application knows the effective channel (see "Physical vs Effective Channels"), it can evaluate the following results:
  • Channel Flatness (based on the effective channel)
  • Group Delay (based on the effective channel)
  • EVM of pilot carriers
  • Constellation of pilot carriers
  • Bitstream of pilot carriers
Spatial stream results
If space-time encoding is implemented, the demodulated data must first be decoded to determine the following results:
  • EVM of data carriers
  • Constellation diagram
  • Bitstream

The pilot carriers are inserted directly after the data carriers went through the STBC (see also "Space-Time Block Coding (STBC)"). Thus, only the data carriers need to be decoded by the analyzer to determine characteristics of the demodulated data. Because of this approach to calculate the EVM, Constellation and Bitstream results, you might get results for a different number of streams for pilots and data carriers if STBC is applied.


Crosstalk and Spectrum Flatness

WLAN application (R&S FSW-K91) > Measurement Basics > Signal Processing for MIMO Measurements (IEEE 802.11ac, n) > Crosstalk and Spectrum Flatness
Crosstalk and Spectrum Flatness

In contrast to the SISO measurements in previous Rohde & Schwarz signal and spectrum analyzers, the spectrum flatness trace is no longer normalized to 0 dB (scaled by the mean gain of all carriers).

For MIMO there may be different gains in the transmission paths and you do not want to lose the relation between these transmission paths. For example, in a MIMO transmission path matrix we have paths carrying power (usually the diagonal elements for the transmitted streams), but also elements with only residual crosstalk power. The power distribution of the transmission matrix depends on the spatial mapping of the transmitted streams. But even if all matrix elements carry power, the gains may be different. This is the reason why the traces are no longer scaled to 0 dB. Although the absolute gain of the Spectrum Flatness is not of interrest, it is now maintained in order to show the different gains in the transmission matrix elements. Nevertheless, the limit lines are still symmetric to the mean trace, individually for each element of the transmission matrix.


Channels and Carriers

WLAN application (R&S FSW-K91) > Measurement Basics > Channels and Carriers
Channels and Carriers

In an OFDM system such as WLAN, the channel is divided into carriers using FFT / IFFT. Depending on the channel bandwidth, the FFT window varies between 64 and 512 (see also "Demodulation Parameters - Logical Filters"). Some of these carriers can be used (active carriers), others are inactive (e.g. guard carriers at the edges). The channel can then be determined using the active carriers as known points; inactive carriers are interpolated.


Recognized vs. Analyzed PPDUs

WLAN application (R&S FSW-K91) > Measurement Basics > Recognized vs. Analyzed PPDUs
Recognized vs. Analyzed PPDUs

A PPDU in a WLAN signal consists of the following parts:

(For IEEE 802.11n see also figure "Training fields (TF) in the preamble of PPDUs in IEEE 802.11n standard")

  • Preamble
    Information required to recognize the PPDU within the signal, for example training fields
  • Signal Field
    Information on the modulation used for transmission of the useful data
  • Payload
    The useful data

During signal processing, PPDUs are recognized by their preamble symbols. The recognized PPDUs and the information on the modulation used for transmission of the useful data are shown in the "Signal Field" result display (see "Signal Field").

Not all of the recognized PPDUs are analyzed. Some are dismissed because the PPDU parameters do not match the user-defined demodulation settings, which act as a logical filter (see also "Demodulation Parameters - Logical Filters"). Others may be dismissed because they contain too many or too few payload symbols (as defined by the user), or due to other irregularities or inconsistency.

Dismissed PPDUs are indicated as such in the "Signal Field" result display (highlighted red, with a reason for dismissal).

PPDUs with detected inconsistencies are indicated by orange highlighting and a warning in the "Signal Field" result display, but are nevertheless analyzed and included in statistical and global evaluations.

The remaining correct PPDUs are highlighted green in the "Magnitude Capture" buffer and "Signal Field" result displays and analyzed according to the current user settings.

Example:

The evaluation range is configured to take the "Source of Payload Length" from the signal field. If the power period detected for a PPDU deviates from the PPDU length coded in the signal field, a warning is assigned to this PPDU. The decoded signal field length is used to analyze the PPDU. The decoded and measured PPDU length together with the apropriate information is shown in the "Signal Field" result display.


Demodulation Parameters - Logical Filters

WLAN application (R&S FSW-K91) > Measurement Basics > Demodulation Parameters - Logical Filters
Demodulation Parameters - Logical Filters

The demodulation settings define which PPDUs are to be analyzed, thus they define a logical filter. They can either be defined using specific values or according to the first measured PPDU.

Which of the WLAN demodulation parameter values are supported depends on the selected digital standard, some are also interdependant.

Supported modulation formats, PPDU formats and channel bandwidths depending on standard
Standard | Modulation formats | PPDU formats | Channel bandwidths
IEEE 802.11a, g (OFDM), p | BPSK (6 Mbps & 9 Mbps) QPSK (12 Mbps & 18 Mbps) 16QAM (24 Mbps & 36 Mbps) 64QAM (48 Mbps & 54 Mbps) | Non-HT Short PPDU Long PPDU | 5 MHz, 10 MHz, 20 MHz*)
IEEE 802.11ac | 16QAM 64QAM 256QAM 1024QAM | VHT | 20 MHz*), 40 MHz*), 80 MHz*), 160 MHz*)
IEEE 802.11b, g (DSSS) | DBPSK (1 Mbps) DQPSK (2 Mbps) CCK (5.5 Mbps & 11 Mbps) PBCC (5.5 Mbps & 11 Mbps) | Short PPDU Long PPDU | 22 MHz
IEEE 802.11n | SISO: BPSK (6.5, 7.2, 13.5 & 15 Mbps) QPSK (13, 14.4, 19.5, 21.7, 27, 30, 40,5 & 45 Mbps) 16QAM (26, 28.9, 39, 43.3, 54, 60, 81 & 90 Mbps) 64QAM (52, 57.8, 58.5, 65, 72.2, 108, 121.5, 135, 120, 135 & 150 Mbps) | HT-MF (Mixed format) HT-GF (Greenfield format) | 20 MHz*), 40 MHz*)
 | MIMO: depends on the MCS index
*): requires R&S FSW bandwidth extension option, see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input"


Receiving Data Input and Providing Data Output

WLAN application (R&S FSW-K91) > Measurement Basics > Receiving Data Input and Providing Data Output
Receiving Data Input and Providing Data Output

The R&S FSW can analyze signals from different input sources and provide various types of output (such as noise or trigger signals).

Contents
  • RF Input Protection
  • Input from Noise Sources
  • Receiving and Providing Trigger Signals


RF Input Protection

WLAN application (R&S FSW-K91) > Measurement Basics > Receiving Data Input and Providing Data Output > RF Input Protection
RF Input Protection

The RF input connector of the R&S FSW must be protected against signal levels that exceed the ranges specified in the data sheet. Therefore, the R&S FSW is equipped with an overload protection mechanism. This mechanism becomes active as soon as the power at the input mixer exceeds the specified limit. It ensures that the connection between RF input and input mixer is cut off.

When the overload protection is activated, an error message is displayed in the status bar ("INPUT OVLD"), and a message box informs you that the RF Input was disconnected. Furthermore, a status bit (bit 3) in the STAT:QUES:POW status register is set. In this case you must decrease the level at the RF input connector and then close the message box. Then measurement is possible again. Reactivating the RF input is also possible via the remote command INPut:​ATTenuation:​PROTection:​RESet.


Input from Noise Sources

WLAN application (R&S FSW-K91) > Measurement Basics > Receiving Data Input and Providing Data Output > Input from Noise Sources
Input from Noise Sources

The R&S FSW provides a connector (NOISE SOURCE CONTROL) with a voltage supply for an external noise source. By switching the supply voltage for an external noise source on or off in the firmware, you can activate or deactive the device as required.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of an amplifier.

In this case, you can first connect an external noise source (whose noise power level is known in advance) to the R&S FSW and measure the total noise power. From this value you can determine the noise power of the R&S FSW. Then when you measure the power level of the actual DUT, you can deduct the known noise level from the total power to obtain the power level of the DUT.

The noise source is controlled in the "Output" settings, see "Noise Source"


Receiving and Providing Trigger Signals

WLAN application (R&S FSW-K91) > Measurement Basics > Receiving Data Input and Providing Data Output > Receiving and Providing Trigger Signals
Receiving and Providing Trigger Signals

Using one of the variable TRIGGER INPUT/OUTPUT connectors of the R&S FSW, the R&S FSW can use a signal from an external reference as a trigger to capture data. Alternatively, the internal trigger signal used by the R&S FSW can be output for use by other connected devices. Using the same trigger on several devices is useful to synchronize the transmitted and received signals within a measurement.

For details on the connectors see the R&S FSW "Getting Started" manual.

External trigger as input

If the trigger signal for the R&S FSW is provided by an external reference, the reference signal source must be connected to the R&S FSW and the trigger source must be defined as "External" on the R&S FSW.

Trigger output

The R&S FSW can provide output to another device either to pass on the internal trigger signal, or to indicate that the R&S FSW itself is ready to trigger.

The trigger signal can be output by the R&S FSW automatically, or manually by the user. If it is provided automatically, a high signal is output when the R&S FSW has triggered due to a sweep start ("Device Triggered"), or when the R&S FSW is ready to receive a trigger signal after a sweep start ("Trigger Armed").

Manual triggering

If the trigger output signal is initiated manually, the length and level (high/low) of the trigger pulse is also user-definable. Note, however, that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is provided.

Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .


Preparing the R&S FSW for the Expected Input Signal - Frontend Parameters

WLAN application (R&S FSW-K91) > Measurement Basics > Preparing the R&S FSW for the Expected Input Signal - Frontend Parameters
Preparing the R&S FSW for the Expected Input Signal - Frontend Parameters

On the R&S FSW, the input data can only be processed optimally if the hardware settings match the signal characteristics as closely as possible. On the other hand, the hardware must be protected from powers or frequencies that exceed the allowed limits. Therefore, you must set the hardware so that it is optimally prepared for the expected input signal, without being overloaded. You do this using the frontend parameters. Consider the following recommendations:

Reference level

Adapt the R&S FSW's hardware to the expected maximum signal level by setting the "Reference Level" to this maximum. Compensate for any external attenuation or gain into consideration by defining a "Reference Level" offset.

Attenuation

To optimize the signal-to-noise ratio of the measurement for high signal levels and to protect the R&S FSW from hardware damage, provide for a high attenuation. Use AC coupling for DC input voltage.

Amplification

To optimize the signal-to-noise ratio of the measurement for low signal levels, the signal level in the R&S FSW should be as high as possible but without introducing compression, clipping, or overload. Provide for early amplification by the preamplifier and a low attenuation.

Impedance

When measuring in a 75 Ω system, connect an external matching pad to the RF input and adapt the reference impedance for power results. The insertion loss is compensated for numerically.


Triggered measurements

WLAN application (R&S FSW-K91) > Measurement Basics > Triggered measurements
Triggered measurements

In a basic sweep measurement with default settings, the sweep is started immediately when you start the measurement, for example by pressing the RUN SINGLE key. However, sometimes you want the measurement to start only when a specific condition is fulfilled, for example a signal level is exceeded, or in certain time intervals. For these cases you can define a trigger for the measurement. In FFT sweep mode, the trigger defines when the data acquisition starts for the FFT conversion.

An "Offset" can be defined to delay the measurement after the trigger event, or to include data before the actual trigger event in time domain measurements (pre-trigger offset).

For complex tasks, advanced trigger settings are available:
  • Hysteresis to avoid unwanted trigger events caused by noise
  • Holdoff to define exactly which trigger event will cause the trigger in a jittering signal
Contents
  • Trigger Offset
  • Trigger Hysteresis
  • Trigger Drop-Out Time
  • Trigger Holdoff
  • Trigger Synchronization Using an R&S FS-Z11 Trigger Unit


Trigger Offset

WLAN application (R&S FSW-K91) > Measurement Basics > Triggered measurements > Trigger Offset
Trigger Offset

An offset can be defined to delay the measurement after the trigger event, or to include data before the actual trigger event in time domain measurements (pre-trigger offset). Pre-trigger offsets are possible because the R&S FSW captures data continuously in the time domain, even before the trigger occurs.

See "Trigger Offset".


Trigger Hysteresis

WLAN application (R&S FSW-K91) > Measurement Basics > Triggered measurements > Trigger Hysteresis
Trigger Hysteresis

Setting a hysteresis for the trigger helps avoid unwanted trigger events caused by noise, for example. The hysteresis is a threshold to the trigger level that the signal must fall below on a rising slope or rise above on a falling slope before another trigger event occurs.

Example:

In the following example, the second possible trigger event is ignored as the signal does not exceed the hysteresis (threshold) before it reaches the trigger level again on the rising edge. On the falling edge, however, two trigger events occur as the signal exceeds the hysteresis before it falls to the trigger level the second time.

Effects of the trigger hysteresis

See "Hysteresis"


Trigger Drop-Out Time

WLAN application (R&S FSW-K91) > Measurement Basics > Triggered measurements > Trigger Drop-Out Time
Trigger Drop-Out Time

If a modulated signal is instable and produces occassional "drop-outs" during a burst, you can define a minimum duration that the input signal must stay below the trigger level before triggering again. This is called the "drop-out" time. Defining a dropout time helps you stabilize triggering when the analyzer is triggering on undesired events.

Effect of the trigger drop-out time

See "Drop-Out Time".

Drop-out times for falling edge triggers

If a trigger is set to a falling edge ("Slope" = "Falling", see "Slope") the measurement is to start when the power level falls below a certain level. This is useful, for example, to trigger at the end of a burst, similar to triggering on the rising edge for the beginning of a burst.

If a drop-out time is defined, the power level must remain below the trigger level at least for the duration of the drop-out time (as defined above). However, if a drop-out time is defined that is longer than the pulse width, this condition cannot be met before the final pulse, so a trigger event will not occur until the pulsed signal is over!

Trigger drop-out time for falling edge trigger

For gated measurements, a combination of a falling edge trigger and a drop-out time is generally not allowed.


Trigger Holdoff

WLAN application (R&S FSW-K91) > Measurement Basics > Triggered measurements > Trigger Holdoff
Trigger Holdoff

The trigger holdoff defines a waiting period before the next trigger after the current one will be recognized.

Effect of the trigger holdoff

See "Trigger Holdoff".


Trigger Synchronization Using an R&S FS-Z11 Trigger Unit

WLAN application (R&S FSW-K91) > Measurement Basics > Triggered measurements > Trigger Synchronization Using an R&S FS-Z11 Trigger Unit
Trigger Synchronization Using an R&S FS-Z11 Trigger Unit

For MIMO measurements in which the data from the multiple antennas is captured simultaneously by multiple analyzers (see "Simultaneous Signal Capture Setup", the data streams to be analyzed must be synchronized in time. The R&S FS-Z11 Trigger Unit can ensure that all analyzers start capturing I/Q data at the same time.

The Trigger Unit is connected to the DUT and all involved analyzers. Then the Trigger Unit can be used in the following operating modes:

  • External mode: If the DUT has a trigger output, the trigger signal from the DUT triggers all analyzers simultaneously.
    The DUT's TRIGGER OUTPUT is connected to the Trigger Unit's TRIG INPUT connector. Each of the Trigger Unit's TRIG OUT connectors is connected to one of the analyzer's TRIGGER INPUT connectors.
  • Free Run mode: This mode is used if no trigger signal is available. The master analyzer sends a trigger impulse to the Trigger Unit to start the measurement as soon as all slave analyzers are ready to measure.
    The NOISE SOURCE output of the master analyzer is connected to the Trigger Unit's NOISE SOURCE input. Each of the Trigger Unit's TRIG OUT connectors is connected to one of the analyzer's TRIGGER INPUT connectors. When the master analyzer sends a signal to the Trigger Unit via its NOISE SOURCE output, the Trigger Unit triggers all analyzers simultaneously via its TRIGGER OUTPUT.
  • Manual mode: a trigger is generated by the Trigger Unit and triggers all analyzers simultaneously. No connection to the DUT is required.
    Each of the Trigger Unit's TRIG OUT connectors is connected to one of the analyzer's TRIGGER INPUT connectors. A trigger signal is generated when you press (release) the "TRIG MANUAL" button on the Trigger unit.
    Note: In manual mode you must turn on the NOISE SOURCE output of the master analyzer manually (see the manual of the analyzer)!

A Trigger Unit is activated in the "Trigger Source Settings". The required connections between the analyzers, the trigger unit, and the DUT are visualized in the dialog box.

The NOISE SOURCE output of the master analyzer must be connected to the Trigger Unit's NOISE SOURCE input for all operating modes to supply the power for the Trigger Unit.

For more detailed information on the R&S FS-Z11 Trigger Unit and the required connections, see the "R&S FS-Z11 Trigger Unit Manual".


Configuration

WLAN application (R&S FSW-K91) > Configuration
Configuration

The default WLAN I/Q measurement captures the I/Q data from the WLAN signal and determines various characteristic signal parameters such as the modulation accuracy, spectrum flatness, center frequency tolerance and symbol clock tolerance in just one measurement (see "WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance)")

Other parameters specified in the WLAN 802.11 standard must be determined in separate measurements (see "Frequency Sweep Measurements").

In settings required to configure each of these measurements are described here.

Selecting the measurement type
►

To select a different measurement type, do one of the following:

  • Select the "Overview" softkey. In the "Overview", select the "Select Measurement" button. Select the required measurement.
  • Press the MEAS key on the front panel. In the "Select Measurement" dialog box, select the required measurement.
Contents
  • Multiple Measurement Channels and Sequencer Function
  • Display Configuration
  • WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...)
  • Frequency Sweep Measurements


Multiple Measurement Channels and Sequencer Function

WLAN application (R&S FSW-K91) > Configuration > Multiple Measurement Channels and Sequencer Function
Multiple Measurement Channels and Sequencer Function

When you activate an application, a new measurement channel is created which determines the measurement settings for that application. These settings include the input source, the type of data to be processed (I/Q or RF data), frequency and level settings, measurement functions etc. If you want to perform the same measurement but with different center frequencies, for instance, or process the same input data with different measurement functions, there are two ways to do so:

  • Change the settings in the measurement channel for each measurement scenario.
    In this case the results of each measurement are updated each time you change the settings and you cannot compare them or analyze them together without storing them on an external medium.
  • Activate a new measurement channel for the same application.
    In the latter case, the two measurement scenarios with their different settings are displayed simultaneously in separate tabs, and you can switch between the tabs to compare the results.
    For example, you can activate one WLAN measurement channel to perform a WLAN modulation accuracy measurement, and a second channel to perform an SEM measurement using the same WLAN input source. Then you can monitor all results at the same time in the "MultiView" tab.

The number of channels that can be configured at the same time depends on the available memory on the instrument.

Only one measurement can be performed on the R&S FSW at any time. If one measurement is running and you start another, or switch to another channel, the first measurement is stopped. In order to perform the different measurements you configured in multiple channels, you must switch from one tab to another.

However, you can enable a Sequencer function that automatically calls up each activated measurement channel in turn. This means the measurements configured in the channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the corresponding tab (as well as the "MultiView") as the measurements are performed. Sequencer operation is independent of the currently displayed tab; for example, you can analyze the SEM measurement while the modulation accuracy measurement is being performed by the Sequencer.

For details on the Sequencer function see "Running a Sequence of Measurements" .

The Sequencer functions are only available in the "MultiView" tab.

└ Sequencer State
└ Sequencer Mode


Sequencer State

WLAN application (R&S FSW-K91) > Configuration > Multiple Measurement Channels and Sequencer Function > Sequencer State
Sequencer State

Activates or deactivates the Sequencer. If activated, sequential operation according to the selected Sequencer mode is started immediately.

For details on sequential operation see "The Sequencer Concept" .

Remote command:

SYSTem:​SEQuencer

INITiate:​SEQuencer:​IMMediate

INITiate:​SEQuencer:​ABORt


Sequencer Mode

WLAN application (R&S FSW-K91) > Configuration > Multiple Measurement Channels and Sequencer Function > Sequencer Mode
Sequencer Mode

Defines how often which measurements are performed. The currently selected mode softkey is highlighted blue. During an active Sequencer process, the selected mode softkey is highlighted orange.

For details on sequential operation see "Sequencer modes" .

"Single Sequence" | Each measurement is performed once, until all measurements in all active channels have been performed.
"Continuous Sequence" | The measurements in each active channel are performed one after the other, repeatedly, in the same order, until sequential operation is stopped. This is the default Sequencer mode.
Remote command:

INITiate:​SEQuencer:​MODE


Display Configuration

WLAN application (R&S FSW-K91) > Configuration > Display Configuration
Display Configuration

The measurement results can be displayed using various evaluation methods. All evaluation methods available for the R&S FSW WLAN application are displayed in the evaluation bar in SmartGrid mode when you do one of the following:

  • Select the [image] "SmartGrid" icon from the toolbar.
  • Select the "Display Config" button in the "Overview".
  • Select the "Display Config" softkey in any WLAN menu.

Then you can drag one or more evaluations to the display area and configure the layout as required.

Up to 16 evaluation methods can be displayed simultaneously in separate windows. The WLAN evaluation methods are described in "Measurements and Result Displays".

To close the SmartGrid mode and restore the previous softkey menu select the [image] "Close" icon in the righthand corner of the toolbar, or press any key on the front panel.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .


WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...)
WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...)

WLAN measurements require a special application on the R&S FSW, which you activate using the MODE key on the front panel. For details see "Applications and Operating Modes" .

When you activate the WLAN application, an I/Q measurement of the input signal is started automatically with the default configuration. The "WLAN" menu is displayed and provides access to the most important configuration functions. This menu is also displayed when you press the MEAS CONFIG key on the front panel.

For a description see
  • "Signal Description"
  • "Input and Frontend Settings"
  • "Signal Capture (Data Acquisition)"
  • "Synchronization and OFDM Demodulation"
  • "Tracking and Channel Estimation"
  • "Demodulation"
  • "Evaluation Range"
  • "Result Configuration"
  • "Display Configuration"

The "Span", "Bandwidth", "Lines", and "Marker Functions" menus are not available for WLAN IQ measurements.

WLAN measurements can be configured easily in the "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu.

Contents
  • Default Settings for WLAN Measurements
  • Configuration Overview
  • Signal Description
  • Input and Frontend Settings
  • Signal Capture (Data Acquisition)
  • Synchronization and OFDM Demodulation
  • Tracking and Channel Estimation
  • Demodulation
  • Evaluation Range
  • Result Configuration
  • Automatic Settings
  • Sweep Settings
  • BW, Span, Lines and Marker Function Menus


Default Settings for WLAN Measurements

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Default Settings for WLAN Measurements
Default Settings for WLAN Measurements

When you activate the WLAN application the first time, a set of parameters is passed on from the currently active application:

  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation
  • input coupling
  • YIG filter state

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from the settings above, the following default settings are activated directly after the WLAN application is activated, or after selecting "Preset Channel":

Default settings for WLAN channels
Parameter | Value
Common WLAN settings
Digital standard | IEEE 802 11a
Measurement | WLAN I/Q measurement
Input source | RF input
Attenuation | 10.0 dB
Capture time | 1.0 ms
Input sample rate | 40.0 MHz
Trigger mode | Free run
MIMO Capture method | Simultaneous
Channel estimation | Preamble
Tracking | Phase
Pilot tracking | According to standard
PPDU format | Auto (same type as first PPDU)
Channel bandwidth to measure | Auto (same type as first PPDU)
MCS to use | Auto (same type as first PPDU)
Evaluations | Window 1: Magnitude Capture Window 2: Constellation


Configuration Overview

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

The "Overview" not only shows the main measurement settings, it also provides quick access to the main settings dialog boxes. The indicated signal flow shows which parameters affect which processing stage in the measurement. Thus, you can easily configure an entire measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

The available settings and functions in the "Overview" vary depending on the currently selected measurement. For frequency sweep measurements see "Frequency Sweep Measurements".

For the WLAN IQ measurement, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. "Select Measurement"

    See "Selecting the measurement type"

  2. "Signal Description"

    See "Signal Description"

  3. "Input/ Frontend"

    See and "Input and Frontend Settings"

  4. "Signal Capture"

    See "Signal Capture (Data Acquisition)"

  5. "Synchronization / OFDM demodulation"

    See "Synchronization and OFDM Demodulation"

  6. "Tracking / Channel Estimation"

    See "Tracking and Channel Estimation"

  7. "Demodulation"

    See "Demodulation"

  8. "Evaluation Range"

    See "Evaluation Range"

  9. "Display Configuration"

    See "Display Configuration"

To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

└ Preset Channel
└ Select Measurement
└ Specifics for


Preset Channel

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

See "Default Settings for WLAN Measurements" for details.

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Select Measurement

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Configuration Overview > Select Measurement
Select Measurement

Selects a measurement to be performed.

See "Selecting the measurement type".


Specifics for

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Signal Description

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Description
Signal Description

The signal description provides information on the expected input signal.

└ Standard
└ Frequency
└ Tolerance Limit


Standard

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Description > Standard
Standard

Defines the WLAN standard (depending on which WLAN options are installed). The measurements are performed according to the specified standard with the correct limit values and limit lines.

Many other WLAN measurement settings depend on the selected standard (see "Demodulation Parameters - Logical Filters").

Remote command:

CONFigure:​STANdard


Frequency

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Description > Frequency
Frequency

Specifies the center frequency of the signal to be measured.

Remote command:

[SENSe:​]FREQuency:​CENTer


Tolerance Limit

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Description > Tolerance Limit
Tolerance Limit

Defines the tolerance limit to be used for the measurement. The required tolerance limit depends on the used standard:

"Prior IEEE 802.11-2012 Standard" | Tolerance limits are based on the IEEE 802.11 specification prior to 2012. Default for OFDM standards (except 802.11ac).
"In line with IEEE 802.11-2012 Standard" | Tolerance limits are based on the IEEE 802.11 specification from 2012. Required for DSSS standards. Also possible for OFDM standards (except 802.11ac).
"In line with IEEE 802.11ac standard" | Tolerance limits are based on the IEEE 802.11ac specification. Required by IEEE 802.11ac standard.
Remote command:

CALCulate:​LIMit:​TOLerance


Input and Frontend Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings
Input and Frontend Settings

The R&S FSW can analyze signals from different input sources and provide various types of output (such as noise or trigger signals).

Importing and Exporting I/Q Data

The I/Q data to be analyzed for WLAN 802.11 can not only be measured by the WLAN application itself, it can also be imported to the application, provided it has the correct format. Furthermore, the analyzed I/Q data from the WLAN application can be exported for further analysis in external applications.

See "Import/Export Functions" .

Frequency, amplitude and y-axis scaling settings represent the "frontend" of the measurement setup.

For more information on the use and effects of these settings, see "Preparing the R&S FSW for the Expected Input Signal - Frontend Parameters".

Contents
  • Input Source Settings
  • Output Settings
  • Frequency Settings
  • Amplitude Settings


Input Source Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings
Input Source Settings

The input source determines which data the R&S FSW will analyze.

Input settings can be configured in the "Input" dialog box.

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

Output settings are described in "Output Settings".

The Digital I/Q input source is currently not available in the R&S FSW WLAN application.

Contents
  • Radio Frequency Input
  • Digital I/Q Input Settings
  • Analog Baseband Input Settings


Radio Frequency Input

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is "Radio Frequency", i.e. the signal at the RF INPUT connector on the front panel of the R&S FSW. If no additional options are installed, this is the only available input source.

└ Radio Frequency State
└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector


Radio Frequency State

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > Radio Frequency State
Radio Frequency State

Activates input from the RF INPUT connector.

Remote command:

INPut:​SELect


Input Coupling

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71). For analog baseband input, an impedance of 50 Ω is always used.

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, the YIG filter may limit the bandwidth of the I/Q data and will add some magnitude and phase distortions. You can check the impact in the Spectrum Flatness and Group Delay result displays.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Remote command:

INPut:​FILTer:​YIG[:​STATe]


Digital I/Q Input Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings
Digital I/Q Input Settings

The following settings and functions are available to provide input via the Digital Baseband Interface (R&S FSW-B17) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see " Processing Data from the Digital Baseband Interface (-B17)" .

└ Digital I/Q Input State
└ Input Sample Rate
└ Full Scale Level
└ Adjust Reference Level to Full Scale Level
└ Connected Instrument
└ DigIConf


Digital I/Q Input State

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Digital I/Q Input State
Digital I/Q Input State

Enables or disable the use of the "Digital IQ" input source for measurements. "Digital IQ" is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

Remote command:

INPut:​SELect


Input Sample Rate

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Input Sample Rate
Input Sample Rate

Defines the sample rate of the digital I/Q signal source. This sample rate must correspond with the sample rate provided by the connected device, e.g. a generator.

If "Auto" is selected, the sample rate is adjusted automatically by the connected device.

The allowed range is from 100 Hz to 10 GHz.

Remote command:

INPut:​DIQ:​SRATe

INPut:​DIQ:​SRATe:​AUTO


Full Scale Level

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Full Scale Level
Full Scale Level

The "Full Scale Level" defines the level and unit that should correspond to an I/Q sample with the magnitude "1".

If "Auto" is selected, the level is automatically set to the value provided by the connected device.

Remote command:

INPut:​DIQ:​RANGe[:​UPPer]

INPut:​DIQ:​RANGe[:​UPPer]:​UNIT

INPut:​DIQ:​RANGe[:​UPPer]:​AUTO


Adjust Reference Level to Full Scale Level

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Adjust Reference Level to Full Scale Level
Adjust Reference Level to Full Scale Level

If enabled, the reference level is adjusted to the full scale level automatically if any change occurs.

Remote command:

INPut:​DIQ:​RANGe:​COUPling


Connected Instrument

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > Connected Instrument
Connected Instrument

Displays the status of the Digital Baseband Interface connection.

This function is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
  • Sample rate of the data currently being transferred via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level"), if provided by connected instrument
Remote command:

INPut:​DIQ:​CDEVice


DigIConf

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Digital I/Q Input Settings > DigIConf
DigIConf

Starts the optional R&S DigIConf application. This softkey is available in the In-/Output menu, but only if the optional software is installed.

Note that R&S DigIConf requires a USB connection (not LAN!) from the R&S FSW to the R&S EX-IQ-BOX in addition to the Digital Baseband Interface (R&S FSW-B17) connection. R&S DigIConf version 2.20.360.86 Build 170 or higher is required.

To return to the R&S FSW application, press any key on the front panel. The R&S FSW application is displayed with the "Input/Output" menu, regardless of which key was pressed.

For details on the R&S DigIConf application, see the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Note: If you close the R&S DigIConf window using the "Close" icon, the window is minimized, not closed.
If you select the "File > Exit" menu item in the R&S DigIConf window, the application is closed. Note that in this case the settings are lost and the EX-IQ-BOX functionality is no longer available until you restart the application using the "DigIConf" softkey in the R&S FSW once again.


Analog Baseband Input Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings
Analog Baseband Input Settings

The following settings and functions are available to provide input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see "Processing Data From the Analog Baseband Interface" .

└ Analog Baseband Input State
└ I/Q Mode
└ Input configuration
└ Center Frequency


Analog Baseband Input State

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings > Analog Baseband Input State
Analog Baseband Input State

Enables or disable the use of the "Analog Baseband" input source for measurements. "Analog Baseband" is only available if the Analog Baseband Interface (R&S FSW-B71) is installed.

Remote command:

INPut:​SELect


I/Q Mode

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings > I/Q Mode
I/Q Mode

Defines the format of the input signal.

For more information see "I/Q Processing Modes" .

"I + jQ"

The input signal is filtered and resampled to the sample rate of the application.

Two inputs are required for a complex signal, one for the in-phase component, and one for the quadrature component.

"I Only / Low IF I"

The input signal at the BASEBAND INPUT I connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband I).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF I).

"Q Only / Low IF Q"

The input signal at the BASEBAND INPUT Q connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband Q).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF Q).

Remote command:

INPut:​IQ:​TYPE


Input configuration

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings > Input configuration
Input configuration

Defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Note: Both single-ended and differential probes are supported as input; however, since only one connector is occupied by a probe, the "Single-ended" setting must be used for all probes.
For details on probes see "Using Probes" .

"Differential" | I, Q and inverse I,Q data
"Single Ended" | I, Q data only
Remote command:

INPut:​IQ:​BALanced[:​STATe]


Center Frequency

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Input Source Settings > Analog Baseband Input Settings > Center Frequency
Center Frequency

Defines the center frequency for analog baseband input.

For real-type baseband input (I or Q only), the center frequency is always 0 Hz.

Note: If the analysis bandwidth to either side of the defined center frequency exceeds the minimum frequency (0 Hz) or the maximum frequency (40 MHz/80 MHz), an error is displayed. In this case, adjust the center frequency or the analysis bandwidth.

Remote command:

[SENSe:​]FREQuency:​CENTer


Output Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Output Settings
Output Settings

The R&S FSW can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour" .

Providing trigger signals as output is described in "How to Output a Trigger Signal" .

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

└ Noise Source
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Noise Source

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

For details see "Input from Noise Sources"

Remote command:

DIAGnostic:​SERVice:​NSOurce


Trigger 2/3

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Output Settings > Trigger 2/3
Trigger 2/3

Defines the usage of the variable TRIGGER INPUT/OUTPUT connectors, where:

"Trigger 2": TRIGGER INPUT/OUTPUT connector on the front panel

"Trigger 3": TRIGGER 3 INPUT/ OUTPUT connector on the rear panel

(Trigger 1 is INPUT only.)

Note: Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .

"Input" | The signal at the connector is used as an external trigger source by the R&S FSW. No further trigger parameters are available for the connector.
"Output" | The R&S FSW sends a trigger signal to the output connector to be used by connected devices. Further trigger parameters are available for the connector.
Remote command:

OUTPut:​TRIGger<port>:​LEVel

OUTPut:​TRIGger<port>:​DIRection

└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Output Type

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Output Settings > Trigger 2/3 > Output Type
Output Type

Type of signal to be sent to the output

"Device Triggered" | (Default) Sends a trigger when the R&S FSW triggers.
"Trigger Armed" | Sends a (high level) trigger when the R&S FSW is in "Ready for trigger" state. This state is indicated by a status bit in the STATus:OPERation register (bit 5), as well as by a low level signal at the AUX port (pin 9).
"User Defined" | Sends a trigger when user selects "Send Trigger" button. In this case, further parameters are available for the output signal.
Remote command:

OUTPut:​TRIGger<port>:​OTYPe

└ Level
└ Pulse Length
└ Send Trigger


Level

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Output Settings > Trigger 2/3 > Output Type > Level
Level

Defines whether a constant high (1) or low (0) signal is sent to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​LEVel


Pulse Length

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Output Settings > Trigger 2/3 > Output Type > Pulse Length
Pulse Length

Defines the length of the pulse sent as a trigger to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​LENGth


Send Trigger

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Output Settings > Trigger 2/3 > Output Type > Send Trigger
Send Trigger

Sends a user-defined trigger to the output connector immediately. Note that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is sent.

Which pulse level will be sent is indicated by a graphic on the button.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​IMMediate


Frequency Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Frequency Settings
Frequency Settings

Frequency settings for the input signal can be configured via the "Frequency" dialog box, which is displayed when you do one of the following:

  • Select the FREQ key and then the "Frequency Config" softkey.
  • Select "Input/Frontend" from the "Overview" and then switch to the "Frequency" tab.
└ Center frequency
└ Center Frequency Stepsize
└ Frequency Offset


Center frequency

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Frequency Settings > Center frequency
Center frequency

Defines the normal center frequency of the signal. The allowed range of values for the center frequency depends on the frequency span.

fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​CENTer


Center Frequency Stepsize

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Frequency Settings > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size by which the center frequency is increased or decreased when the arrow keys are pressed. When you use the rotary knob the center frequency changes in steps of only 1/10 of the "Center Frequency Stepsize".

The step size can be coupled to another value or it can be manually set to a fixed value.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize" .

"= Center" | Sets the step size to the value of the center frequency. The used value is indicated in the "Value" field.
"Manual" | Defines a fixed step size for the center frequency. Enter the step size in the "Value" field.
Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP


Frequency Offset

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Frequency Settings > Frequency Offset
Frequency Offset

Shifts the displayed frequency range along the x-axis by the defined offset.

This parameter has no effect on the R&S FSW hardware, or on the captured data or on data processing. It is simply a manipulation of the final results in which absolute frequency values are displayed. Thus, the x-axis of a spectrum display is shifted by a constant offset if it shows absolute frequencies, but not if it shows frequencies relative to the signal's center frequency.

A frequency offset can be used to correct the display of a signal that is slightly distorted by the measurement setup, for example.

The allowed values range from -100 GHz to 100 GHz. The default setting is 0 Hz.

Remote command:

[SENSe:​]FREQuency:​OFFSet


Amplitude Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Amplitude Settings
Amplitude Settings

Amplitude settings determine how the R&S FSW must process or display the expected input power levels.

To configure the amplitude settings

Amplitude settings can be configured via the AMPT key or in the "Amplitude" dialog box.

►

To display the "Amplitude" dialog box, do one of the following:

  • Select "Input/Frontend" from the "Overview" and then switch to the "Amplitude" tab.
  • Select the AMPT key and then the "Amplitude Config" softkey.
└ Reference Level Settings
└ Reference Level Mode
└ Reference Level
└ Signal Level (RMS)
└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)
└ RF Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Reference Level Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Amplitude Settings > Reference Level Settings
Reference Level Settings

The reference level defines the expected maximum signal level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display.

└ Reference Level Mode
└ Reference Level
└ Signal Level (RMS)
└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)


Reference Level Mode

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Amplitude Settings > Reference Level Settings > Reference Level Mode
Reference Level Mode

By default, the reference level is automatically adapted to its optimal value for the current input data (continuously). At the same time, the internal attenuators and the preamplifier are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to define the reference level manually, switch to "Manual" mode. In this case you must define the following reference level parameters.

Remote command:

CONF:POW:AUTO ON, see CONFigure:​POWer:​AUTO


Reference Level

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Amplitude Settings > Reference Level Settings > Reference Level
Reference Level

Defines the expected maximum signal level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display.

This value is overwritten if "Auto Level" mode is turned on.

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)" . It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel


Signal Level (RMS)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Amplitude Settings > Reference Level Settings > Signal Level (RMS)
Signal Level (RMS)

Specifies the mean power level of the source signal as supplied to the instrument's RF input. This value is overwritten if "Auto Level" mode is turned on.

Remote command:

CONFigure:​POWer:​EXPected:​RF


Shifting the Display (Offset)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Amplitude Settings > Reference Level Settings > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


Unit

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Amplitude Settings > Reference Level Settings > Unit
Unit

The R&S FSW measures the signal voltage at the RF input. In the default state, the level is displayed at a power of 1 mW (= dBm). Via the known input impedance (50 Ω or 75 Ω, see "Impedance"), conversion to other units is possible. The following units are available and directly convertible:

  • dBm
  • dBmV
  • dBμV
  • dBμA
  • dBpW
  • Volt
  • Ampere
  • Watt
Remote command:

INPut:​IMPedance

CALCulate<n>:​UNIT:​POWer


Setting the Reference Level Automatically (Auto Level)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Amplitude Settings > Reference Level Settings > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

You can change the measurement time for the level measurement if necessary (see "Changing the Automatic Measurement Time (Meastime Manual)").

Remote command:

CONFigure:​POWer:​AUTO


RF Attenuation

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Amplitude Settings > RF Attenuation
RF Attenuation

Defines the attenuation applied to the RF input.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

└ Attenuation Mode / Value


Attenuation Mode / Value

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Amplitude Settings > RF Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation" .

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Amplitude Settings > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Input Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Preamplifier (option B24)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Input and Frontend Settings > Amplitude Settings > Input Settings > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Signal Capture (Data Acquisition)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition)
Signal Capture (Data Acquisition)

You can define how much and how data is captured from the input signal.

Contents
  • General Capture Settings
  • Trigger Settings
  • MIMO Capture Settings


General Capture Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > General Capture Settings
General Capture Settings

The general capture settings define how much and which data is to be captured during the WLAN IQ measurement.

└ Input Sample Rate
└ Capture Time
└ Swap I/Q
└ Suppressing (Filter out) Adjacent Channels (IEEE 802.11a, g (OFDM), ac, n, p)


Input Sample Rate

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > General Capture Settings > Input Sample Rate
Input Sample Rate

This is the sample rate the R&S FSW WLAN application expects the I/Q input data to have. If necessary, the R&S FSW has to resample the data.

During data processing in the R&S FSW, the sample rate usually changes (decreases). The RF input is captured by the R&S FSW using a high sample rate, and is resampled before it is processed by the R&S FSW WLAN application.

Remote command:

TRACe:​IQ:​SRATe


Capture Time

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > General Capture Settings > Capture Time
Capture Time

Specifies the duration (and therefore the amount of data) to be captured in the capture buffer. If the capture time is too short, demodulation will fail.

Remote command:

[SENSe:​]SWEep:​TIME


Swap I/Q

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > General Capture Settings > Swap I/Q
Swap I/Q

Activates or deactivates the inverted I/Q modulation. If the I and Q parts of the signal from the DUT are interchanged, the R&S FSW can do the same to compensate for it.

On | I and Q signals are interchanged Inverted sideband, Q+j*I
Off | I and Q signals are not interchanged Normal sideband, I+j*Q
Remote command:

[SENSe:​]SWAPiq


Suppressing (Filter out) Adjacent Channels (IEEE 802.11a, g (OFDM), ac, n, p)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > General Capture Settings > Suppressing (Filter out) Adjacent Channels (IEEE 802.11a, g (OFDM), ac, n, p)
Suppressing (Filter out) Adjacent Channels (IEEE 802.11a, g (OFDM), ac, n, p)

If activated (default), only the useful signal is analyzed, all signal data in adjacent channels is removed by the filter.

This setting improves the signal to noise ratio and thus the EVM results for signals with strong or a large number of adjacent channels. However, for some measurements information on the effects of adjacent channels on the measured signal may be of interest.

Remote command:

[SENSe:​]BANDwidth[:​RESolution]:​FILTer[:​STATe]


Trigger Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings
Trigger Settings

Trigger settings determine when the R&S FSW starts to capture the input signal.

External triggers from one of the TRIGGER INPUT/OUTPUT connectors on the R&S FSW are configured in a separate tab of the dialog box.

For more information on trigger settings see "Basics of Triggering and Gated Measurements" . For step-by-step instructions on configuring triggered measurements, see "How to Configure a Triggered and Gated Measurement" .

└ Trigger Source Settings
└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ I/Q Power
└ RF Power
└ Time
└ Power Sensor
└ IF Power/BB Power
└ Digital I/Q
└ Trigger Level Mode
└ Trigger Level (Repetition interval)
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope
└ FS-Z11 Trigger
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Trigger Source Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings
Trigger Source Settings

The Trigger Source settings define when data is captured.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ I/Q Power
└ RF Power
└ Time
└ Power Sensor
└ IF Power/BB Power
└ Digital I/Q
└ Trigger Level Mode
└ Trigger Level (Repetition interval)
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope
└ FS-Z11 Trigger


Trigger Source

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Trigger Source
Trigger Source

Defines whether a trigger is to be considered at all and if so, which signal (IF, RF, external signal etc.) will provide the trigger signal. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

For more information see "Trigger Source" .

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ I/Q Power
└ RF Power
└ Time
└ Power Sensor
└ IF Power/BB Power
└ Digital I/Q


Free Run

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector (on the front or rear panel) meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)").

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT" .

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce


I/Q Power

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Trigger Source > I/Q Power
I/Q Power

This trigger source is not available if the optional Digital Baseband Interface (R&S FSW-B17) or Analog Baseband Interface (R&S FSW-B71) is used for input. It is also not available for analysis bandwidths ≥ 160 MHz.

Triggers the measurement when the magnitude of the sampled I/Q data exceeds the trigger threshold.

The trigger bandwidth corresponds to the "Usable I/Q Bandwidth", which depends on the sample rate of the captured I/Q data (see "Input Sample Rate" and "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input").

Remote command:

TRIG:SOUR IQP, see TRIGger[:​SEQuence]:​SOURce


RF Power

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Trigger Source > RF Power
RF Power

Defines triggering of the measurement via signals which are outside the displayed measurement range.

For this purpose the instrument uses a level detector at the first intermediate frequency. The input signal must be in the frequency range between 500 MHz and 8 GHz.

The resulting trigger level at the RF input depends on the RF attenuation and preamplification. For details on available trigger levels see the data sheet.

Note: If the input signal contains frequencies outside of this range (e.g. for fullspan measurements), the sweep may be aborted and a message indicating the allowed input frequencies is displayed in the status bar.

A "Trigger Offset", "Trigger Polarity" and "Trigger Holdoff" (to improve the trigger stability) can be defined for the RF trigger, but no "Hysteresis".

This trigger source is not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71). If the trigger source "RF Power" is selected and digital I/Q or analog baseband input is activated, the trigger source is automatically switched to "Free Run".

Remote command:

TRIG:SOUR RFP, see TRIGger[:​SEQuence]:​SOURce


Time

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Trigger Source > Time
Time

Triggers in a specified repetition interval.

Remote command:

TRIG:SOUR TIME, see TRIGger[:​SEQuence]:​SOURce


Power Sensor

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Trigger Source > Power Sensor
Power Sensor

Uses an external power sensor as a trigger source. This option is only available if a power sensor is connected and configured.

Note: For R&S power sensors, the "Gate Mode" Lvl is not supported. The signal sent by these sensors merely reflects the instant the level is first exceeded, rather than a time period. However, only time periods can be used for gating in level mode. Thus, the trigger impulse from the sensors is not long enough for a fully gated measurement; the measurement cannot be completed.

Remote command:

TRIG:SOUR PSE, see TRIGger[:​SEQuence]:​SOURce


IF Power/BB Power

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Trigger Source > IF Power/BB Power
IF Power/BB Power

Depending on the input source type, this softkey defines triggering of the measurement using:

  • the baseband power (for baseband input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)
  • the third intermediate frequency(RF input)
    The R&S FSW is triggered as soon as the trigger threshold is exceeded around the selected frequency (= start frequency in the frequency sweep). The trigger threshold depends on the defined trigger level, as well as on the RF attenuation and preamplification. A reference level offset, if defined, is also considered. The trigger bandwidth at the intermediate frequency depends on the RBW and sweep type. For details on available trigger levels and trigger bandwidths see the data sheet.

Note: Be aware that in auto sweep type mode, due to a possible change in sweep types, the trigger bandwidth may vary considerably for the same RBW setting.

Remote command:

TRIG:SOUR IFP, see TRIGger[:​SEQuence]:​SOURce

TRIG:SOUR BBP, see TRIGger[:​SEQuence]:​SOURce


Digital I/Q

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Trigger Source > Digital I/Q
Digital I/Q

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available:

Defines triggering of the measurement directly via the LVDS connector. In the selection list you must specify which general purpose bit (GP0 to GP5) will provide the trigger data.

Note: If the Digital I/Q enhanced mode is used, i.e. the connected device supports transfer rates up to 200 Msps, only the general purpose bits GP0 and GP1 are available as a Digital I/Q trigger source.

The following table describes the assignment of the general purpose bits to the LVDS connector pins.

Assignment of general purpose bits to LVDS connector pins
Bit | LVDS pin
GP0 | SDATA4_P - Trigger1
GP1 | SDATA4_P - Trigger2
GP2 *) | SDATA0_P - Reserve1
GP3 *) | SDATA4_P - Reserve2
GP4 *) | SDATA0_P - Marker1
GP5 *) | SDATA4_P - Marker2
*): not available for Digital I/Q enhanced mode
Remote command:

TRIG:SOUR GP0, see TRIGger[:​SEQuence]:​SOURce


Trigger Level Mode

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Trigger Level Mode
Trigger Level Mode

By default, the optimum trigger level for power triggers is automatically measured and determined at the start of each sweep (for Modulation Accuracy, Flatness, Tolerance... measurements).

In order to define the trigger level manually, switch to "Manual" mode.

Remote command:

TRIG:SEQ:LEV:POW:AUTO ON, see TRIGger:​SEQuence:​LEVel:​POWer:​AUTO


Trigger Level (Repetition interval)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Trigger Level (Repetition interval)
Trigger Level (Repetition interval)

Defines the trigger level for the specified trigger source. For time triggers, the repetition interval is defined.

For details on supported trigger levels, see the data sheet.

Remote command:

TRIGger[:​SEQuence]:​LEVel:​IFPower

TRIGger[:​SEQuence]:​LEVel:​IQPower

TRIGger[:​SEQuence]:​LEVel[:​EXTernal<port>]


Drop-Out Time

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time".

Remote command:

TRIGger[:​SEQuence]:​DTIMe


Trigger Offset

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger)
Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Hysteresis

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

For more information see "Trigger Hysteresis".

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Trigger Holdoff

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff".

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Slope

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

TRIGger[:​SEQuence]:​SLOPe


FS-Z11 Trigger

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > Trigger Settings > Trigger Source Settings > FS-Z11 Trigger
FS-Z11 Trigger

If activated, the measurement is triggered by a connected R&S FS-Z11 trigger unit, simultaneously for all connected analyzers. This is useful for MIMO measurements in simultaneous measurement mode (see "Simultaneous Signal Capture Setup").

The "Trigger Source" is automatically set to "External Trigger 1/2/3". The required connections between the analyzers, the trigger unit, and the DUT are indicated in the graphic.

For details see "Trigger Synchronization Using an R&S FS-Z11 Trigger Unit".

Remote command:

TRIGger[:​SEQuence]:​SOURce


MIMO Capture Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings
MIMO Capture Settings

The following settings are only available for the IEEE 802.11ac and n standards.

└ DUT MIMO Configuration
└ MIMO Antenna Signal Capture Setup
└ Simultaneous Signal Capture Setup
└ State
└ Analyzer IP Address
└ Assignment
└ Joined RX Sync and Tracking
└ Sequential Using OSP Switch Setup
└ OSP IP Address
└ OSP Switch Bank Configuration
└ Manual Sequential MIMO Data Capture
└ Single / Cont.
└ Calc Results
└ Clear All Magnitude Capture Buffers
└ RUN SGL / RUN CONT updates


DUT MIMO Configuration

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > DUT MIMO Configuration
DUT MIMO Configuration

Defines the number of Tx antennas of the device under test (DUT). Currently up to eight Tx antennas are supported.

Remote command:

CONFigure:​WLAN:​DUTConfig


MIMO Antenna Signal Capture Setup

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > MIMO Antenna Signal Capture Setup
MIMO Antenna Signal Capture Setup

Defines the MIMO method used by the R&S FSW(s) to capture data from multiple Tx antennas sent by one device under test (DUT).

"Simultaneous" | Simultaneous normal MIMO operation The number of Tx antennas set in "DUT MIMO Configuration" defines the number of analyzers required for this measurement setup.
"Sequential using OSP switch" | Sequential using open switch platform A single analyzer and the Rohde & Schwarz OSP Switch Platform (with at least one fitted R&S®OSP-B101 option) is required to measure the number of DUT Tx Antennas as defined in "DUT MIMO Configuration".
"Sequential manual" | Sequential using manual operation A single analyzer is required to measure the number of DUT Tx Antennas as defined in "DUT MIMO Configuration". Data capturing is performed manually via the analyzer's user interface.
Remote command:

CONFigure:​WLAN:​MIMO:​CAPTure:​TYPE


Simultaneous Signal Capture Setup

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > Simultaneous Signal Capture Setup
Simultaneous Signal Capture Setup

For each RX antenna from which data is to be captured simultaneously, the settings are configured here.

Tip: the LED symbol indicates the state of the Rx antenna:

Color | State
gray | antenna off or IP address not available/valid
red | antenna on and IP address valid, but not accessible
green | antenna on and IP address accessible
└ State
└ Analyzer IP Address
└ Assignment
└ Joined RX Sync and Tracking


State

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > Simultaneous Signal Capture Setup > State
State

Switches the corresponding slave analyzer on or off. In "On" state the slave analyzer captures data. This data is transferred via LAN to the master for analysis of the MIMO system.

Remote command:

CONFigure:​WLAN:​ANTMatrix:​STATe<state>


Analyzer IP Address

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > Simultaneous Signal Capture Setup > Analyzer IP Address
Analyzer IP Address

Defines the IP addresses of the slaves connected via LAN to the master.

Tip: the LED symbol indicates the state of the Rx antenna:

Color | State
gray | antenna off or IP address not available/valid
red | antenna on and IP address valid, but not accessible
green | antenna on and IP address accessible
Remote command:

CONFigure:​WLAN:​ANTMatrix:​ADDRess<add>


Assignment

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > Simultaneous Signal Capture Setup > Assignment
Assignment

Assignment of the expected antenna to an analyzer. For a wired connection the assignment of the Tx antenna connected to the analyzer is a possibility. For a wired connection and Direct Spatial Mapping the Spectrum Flatness traces in the diagonal contain the useful information, in case the signal transmitted from the antennas matches with the expected antennas. Otherwise the secondary diagonal will contain the useful traces.

Remote command:

CONFigure:​WLAN:​ANTMatrix:​ANTenna<Analyzer>


Joined RX Sync and Tracking

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > Simultaneous Signal Capture Setup > Joined RX Sync and Tracking
Joined RX Sync and Tracking

This command configures how PPDU synchronization and tracking is performed for multiple captured antenna signals.

"ON" | RX antennas are synchronized and tracked together.
"OFF" | RX antennas are synchronized and tracked separately.
Remote command:

CONFigure:​WLAN:​RSYNc:​JOINed


Sequential Using OSP Switch Setup

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > Sequential Using OSP Switch Setup
Sequential Using OSP Switch Setup

A single analyzer and the Rohde & Schwarz OSP Switch Platform (with at least one fitted R&S®OSP-B101 option) is required to measure the DUT Tx Antennas.

Note: For sequential MIMO measurements the DUT has to transmit identical PPDUs over time! The signal field, for example, has to be identical for all PPDUs. For details see "Sequential MIMO Measurement".

This setup requires the analyzer and the OSP switch platform to be connected via LAN. A connection diagram is shown to assist you in connecting the specified number of DUT Tx antennas with the analyzer via the Rohde & Schwarz OSP switch platform.

The diagram shows an R&S®OSP-B101 option fitted in one of the three module slots at the rear of the OSP switch platform. The DUT Tx antennas, the OSP switching box and the analyzer have to be connected as indicated in the diagram.

  • Blue colored arrows represent the connections between the Tx antennas of the DUT and the corresponding SMA plugs of the R&S®OSP-B101 option.
  • Green colored arrows represent auxiliary connections of SMA plugs of the R&S®OSP-B101 option.
  • Yellow colored arrows represent the connection between the SMA plug of the R&S®OSP-B101 option with the RF or analog baseband input of the analyzer.
└ OSP IP Address
└ OSP Switch Bank Configuration


OSP IP Address

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > Sequential Using OSP Switch Setup > OSP IP Address
OSP IP Address

The analyzer and the R&S OSP switch platform have to be connected via LAN. Enter the IP address of the OSP switch platform.

When using an R&S®OSP130 switch platform, the IP address is shown in the front display.

When using a R&S®OSP120 switch platform, connect an external monitor to get the IP address or use the default IP address of the OSP switch platform. For details read the OSP operation manual.

An online keyboard is displayed to enter the address in dotted IPV4 format.

Tip: the LED symbol indicates the state of the OSP switch box:

Color | State
gray | OSP switch box off or IP address not available/valid
red | OSP switch box on and IP address valid, but not accessible
green | OSP switch box on and IP address accessible
Remote command:

CONFigure:​WLAN:​MIMO:​OSP:​ADDRess


OSP Switch Bank Configuration

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > Sequential Using OSP Switch Setup > OSP Switch Bank Configuration
OSP Switch Bank Configuration

The R&S®OSP-B101 option is fitted in one of the three module slots (switch banks) at the rear of the OSP switch platform. The DUT Tx antennas are connected with the analyzer via the R&S®OSP-B101 module fitted in the OSP switch platform. Select the R&S®OSP-B101 module that is used for this connection.

Remote command:

CONFigure:​WLAN:​MIMO:​OSP:​MODule


Manual Sequential MIMO Data Capture

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > Manual Sequential MIMO Data Capture
Manual Sequential MIMO Data Capture

Note: For sequential MIMO measurements the DUT has to transmit identical PPDUs over time! The signal field, for example, has to be identical for all PPDUs. For details see "Sequential MIMO Measurement".

For this MIMO method you must connect each Tx antenna of the WLAN DUT with the analyzer and start data capturing manually (see "Sweep Settings").

The dialog box shows a preview of the capture memories (one for each RX antenna).The PPDUs detected by the application are highlighted by the green bars.

Remote command:

CONF:WLAN:MIMO:CAPT:TYP MAN, see CONFigure:​WLAN:​MIMO:​CAPTure:​TYPE

└ Single / Cont.
└ Calc Results
└ Clear All Magnitude Capture Buffers
└ RUN SGL / RUN CONT updates


Single / Cont.

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > Manual Sequential MIMO Data Capture > Single / Cont.
Single / Cont.

Starts a single or continuous new measurement for the corresponding antenna.

Remote command:

CONF:WLAN:MIMO:CAPT RX1, see CONFigure:​WLAN:​MIMO:​CAPTure

INITiate[:​IMMediate]


Calc Results

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > Manual Sequential MIMO Data Capture > Calc Results
Calc Results

Calculates the results for the captured antenna signals.

Remote command:

CALCulate<n>:​BURSt[:​IMMediate]


Clear All Magnitude Capture Buffers

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > Manual Sequential MIMO Data Capture > Clear All Magnitude Capture Buffers
Clear All Magnitude Capture Buffers

Clears all the capture buffers and previews.


RUN SGL / RUN CONT updates

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Signal Capture (Data Acquisition) > MIMO Capture Settings > Manual Sequential MIMO Data Capture > RUN SGL / RUN CONT updates
RUN SGL / RUN CONT updates

Determines which capture buffer is used to store data if a measurement is started via the global RUN SGL / RUN CONT keys on the front panel of the R&S FSW.


Synchronization and OFDM Demodulation

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Synchronization and OFDM Demodulation
Synchronization and OFDM Demodulation

Synchronization settings have an effect on which parts of the input signal are processed during the WLAN measurement.

└ Power Interval Search
└ FFT Start Offset


Power Interval Search

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Synchronization and OFDM Demodulation > Power Interval Search
Power Interval Search

If enabled, the R&S FSW WLAN application initially performs a coarse burst search on the input signal in which increases in the power vs time trace are detected. Further time-consuming processing is then only performed where bursts are assumed. This improves the measurement speed for signals with low duty cycle rates.

However, for signals in which the PPDU power levels differ significantly, this option should be disabled as otherwise some PPDUs may not be detected.

Remote command:

[SENSe:​]DEMod:​TXARea


FFT Start Offset

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Synchronization and OFDM Demodulation > FFT Start Offset
FFT Start Offset

This command specifies the start offset of the FFT for OFDM demodulation (not for the FFT Spectrum display).

"AUTO" | The FFT start offset is automatically chosen to minimize the intersymbol interference.
"Guard Interval Cntr" | Guard Interval Center: The FFT start offset is placed to the center of the guard interval.
"Peak" | The peak of the fine timing metric is used to determine the FFT start offset.
Remote command:

[SENSe:​]DEMod:​FFT:​OFFSet


Tracking and Channel Estimation

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Tracking and Channel Estimation
Tracking and Channel Estimation

The channel estimation settings determine which channels are assumed in the input signal. Tracking settings allow for compensation of some transmission effects in the signal (see "Tracking the phase drift, timing jitter and gain").

└ Channel Estimation Range
└ Phase Tracking
└ Timing Error Tracking
└ Level Error (Gain) Tracking
└ I/Q Mismatch Compensation
└ Pilots for Tracking


Channel Estimation Range

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Tracking and Channel Estimation > Channel Estimation Range
Channel Estimation Range

Specifies the signal range used to estimate the channels.

This function is not available for IEEE 802.11b or g (DSSS).

"Preamble" | The channel estimation is performed in the preamble as required in the standard.
"Payload" | The channel estimation is performed in the preamble and the payload. The EVM results can be calculated more accurately.
Remote command:

[SENSe:​]DEMod:​CESTimation


Phase Tracking

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Tracking and Channel Estimation > Phase Tracking
Phase Tracking

Activates or deactivates the compensation for phase drifts. If activated, the measurement results are compensated for phase drifts on a per-symbol basis.

For details see "Tracking the phase drift, timing jitter and gain".

Remote command:

[SENSe:​]TRACking:​PHASe


Timing Error Tracking

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Tracking and Channel Estimation > Timing Error Tracking
Timing Error Tracking

Activates or deactivates the compensation for timing drift. If activated, the measurement results are compensated for timing error on a per-symbol basis.

For details see "Tracking the phase drift, timing jitter and gain".

Remote command:

[SENSe:​]TRACking:​TIME


Level Error (Gain) Tracking

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Tracking and Channel Estimation > Level Error (Gain) Tracking
Level Error (Gain) Tracking

Activates or deactivates the compensation for level drifts within a single PPDU. If activated, the measurement results are compensated for level error on a per-symbol basis.

For details see "Tracking the phase drift, timing jitter and gain".

Remote command:

[SENSe:​]TRACking:​LEVel


I/Q Mismatch Compensation

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Tracking and Channel Estimation > I/Q Mismatch Compensation
I/Q Mismatch Compensation

Activates or deactivates the compensation for I/Q mismatch.

If activated, the measurement results are compensated for gain imbalance and quadrature offset (frequency-dependant). As a consequence, I/Q skew impairments are compensated as well.

This setting is not available for standards IEEE 802.11b and g (DSSS).

For details see "I/Q Mismatch".

Note: For EVM measurements according to the IEEE 802.11-2012, IEEE P802.11ac/D5.0 WLAN standard, I/Q mismatch compensation must be deactivated.

Remote command:

[SENSe:​]TRACking:​IQMComp


Pilots for Tracking

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Tracking and Channel Estimation > Pilots for Tracking
Pilots for Tracking

In case tracking is used, the used pilot sequence has an effect on the measurement results.

This function is not available for IEEE 802.11b or g (DSSS).

"According to standard" | The pilot sequence is determined according to the corresponding WLAN standard. In case the pilot generation algorithm of the device under test (DUT) has a problem, the non-standard-conform pilot sequence might affect the measurement results, or the WLAN application might not synchronize at all onto the signal generated by the DUT.
"Detected" | The pilot sequence detected in the WLAN signal to be analyzed is used by the WLAN application. In case the pilot generation algorithm of the device under test (DUT) has a problem, the non-standard-conform pilot sequence will not affect the measurement results. In case the pilot sequence generated by the DUT is correct, it is recommended that you use the "According to Standard" setting because it generates more accurate measurement results.
Remote command:

[SENSe:​]TRACking:​PILots


Demodulation

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation
Demodulation

The demodulation settings define which PPDUs are to be analyzed, thus they define a logical filter.

The available demodulation settings vary depending on the selected digital standard in the "Signal Description" (see "Standard").

Contents
  • Demodulation - IEEE 802.11a, g (OFDM), p
  • Demodulation - IEEE 802.11ac
  • Demodulation - IEEE 802.11b, g (DSSS)
  • Demodulation - IEEE 802.11n
  • Demodulation - MIMO (IEEE 802.11ac, n)


Demodulation - IEEE 802.11a, g (OFDM), p

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11a, g (OFDM), p
Demodulation - IEEE 802.11a, g (OFDM), p

The following settings are available for demodulation of IEEE 802.11a, g (OFDM), p signals.

└ PPDU Analysis Mode
└ PPDU Format to measure
└ Channel Bandwidth to measure (CBW)
└ PSDU Modulation to use
└ PSDU Modulation


PPDU Analysis Mode

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11a, g (OFDM), p > PPDU Analysis Mode
PPDU Analysis Mode

Defines whether all or only specific PPDUs are to be analyzed.

"Auto, same type as first PPDU" | The signal symbol field, i.e. the PLCP header field, of the first recognized PPDU is analyzed to determine the details of the PPDU. All PPDUs identical to the first recognized PPDU are analyzed. All subsequent settings are set to "Auto" mode.
"Auto, individually for each PPDU" | All PPDUs are analyzed
"User-defined" | User-defined settings define which PPDUs are analyzed. This setting is automatically selected when any of the subsequent settings are changed to a value other than "Auto".
Remote command:

[SENSe:​]DEMod:​FORMat[:​BCONtent]:​AUTO


PPDU Format to measure

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11a, g (OFDM), p > PPDU Format to measure
PPDU Format to measure

Defines which PPDU formats are to be included in the analysis. Depending on which standards the communicating devices are using, different formats of PPDUs are available. Thus you can restrict analysis to the supported formats.

Note: The PPDU format determines the available channel bandwidths.

For details on supported PPDU formats and channel bandwidths depending on the standard see table "Supported modulation formats, PPDU formats and channel bandwidths depending on standard".

Note: The terms in brackets in the following description indicate how the setting is referred to in the Signal Field result display ("Format" column, see "Signal Field").

"Auto, same type as first PPDU(A1st)" | The format of the first valid PPDU is detected and subsequent PPDUs are analyzed only if they have the same format.
"Auto, individually for each PPDU(AI)" | All PPDUs are analyzed regardless of their format
"Meas only ...(M ...)" | Only PPDUs with the specified format are analyzed
"Demod all as ...(D ...)" | All PPDUs are assumed to have the specified PPDU format
Remote command:

[SENSe:​]DEMod:​FORMat:​BANalyze:​BTYPe:​AUTO:​TYPE

[SENSe:​]DEMod:​FORMat:​BANalyze


Channel Bandwidth to measure (CBW)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11a, g (OFDM), p > Channel Bandwidth to measure (CBW)
Channel Bandwidth to measure (CBW)

Defines the channel bandwidth of the PPDUs taking part in the analysis. Depending on which standards the communicating devices are using, different PPDU formats and channel bandwidths are supported.

For details on supported PPDU formats and channel bandwidths depending on the standard see table "Supported modulation formats, PPDU formats and channel bandwidths depending on standard".

Note: The terms in brackets in the following description indicate how the setting is referred to in the Signal Field result display ("CBW" column, see "Signal Field").

"Auto, same type as first PPDU""(A1st)" | The channel bandwidth of the first valid PPDU is detected and subsequent PPDUs are analyzed only if they have the same channel bandwidth.
"Auto, individually for each PPDU""(AI)" | All PPDUs are analyzed regardless of their channel bandwidth
"Meas only ... signal""(M ...)" | Only PPDUs with the specified channel bandwidth are analyzed
"Demod all as ... signal""(D ...)" | All PPDUs are assumed to have the specified channel bandwidth
Remote command:

[SENSe:​]BANDwidth:​CHANnel:​AUTO:​TYPE


PSDU Modulation to use

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11a, g (OFDM), p > PSDU Modulation to use
PSDU Modulation to use

Specifies which PSDUs are to be analyzed depending on their modulation. Only PSDUs using the selected modulation are considered in measurement analysis.

For details on supported modulation depending on the standard see table "Supported modulation formats, PPDU formats and channel bandwidths depending on standard".

"Auto, same type as first PPDU""(A1st)" | All PSDUs using the same modulation as the first recognized PPDU are analyzed.
"Auto, individually for each PPDU""(AI)" | All PSDUs are analyzed
"Meas only the specified PSDU Modulation""(M ...)" | Only PSDUs with the modulation specified by the "PSDU Modulation" setting are analyzed
"Demod all with specified PSDU modulation""(D ...)" | The PSDU modulation of the "PSDU Modulation" setting is used for all PSDUs.
Remote command:

[SENSe:​]DEMod:​FORMat:​BANalyze:​BTYPe:​AUTO:​TYPE

[SENSe:​]DEMod:​FORMat:​BANalyze


PSDU Modulation

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11a, g (OFDM), p > PSDU Modulation
PSDU Modulation

If analysis is restricted to PSDU with a particular modulation type, this setting defines which type.

For details on supported modulation depending on the standard see table "Supported modulation formats, PPDU formats and channel bandwidths depending on standard".

Remote command:

[SENSe:​]DEMod:​FORMat:​BANalyze


Demodulation - IEEE 802.11ac

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11ac
Demodulation - IEEE 802.11ac

The following settings are available for demodulation of IEEE 802.11ac signals.

└ PPDU Analysis Mode
└ PPDU Format to measure
└ Channel Bandwidth to measure (CBW)
└ MCS Index to use
└ MCS Index
└ Nsts to use
└ Nsts
└ STBC Field
└ Table info overview
└ Guard Interval Length


MCS Index to use

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11ac > MCS Index to use
MCS Index to use

Defines the PPDUs taking part in the analysis depending on their Modulation and Coding Scheme (MCS) index.

Note: The terms in brackets in the following description indicate how the setting is referred to in the Signal Field result display ("MCS" column, see "Signal Field").

"Auto, same type as first PPDU:""(A1st)" | All PPDUs using the MCS index identical to the first recognized PPDU are analyzed.
"Auto, individually for each PPDU""(AI)" | All PPDUs are analyzed
"Meas only the specified MCS""(M ...)" | Only PPDUs with the MCS index specified for the "MCS Index" setting are analyzed
"Demod all with specified MCS""(D ...)" | The "MCS Index" setting is used for all PPDUs.
Remote command:

[SENSe:​]DEMod:​FORMat:​MCSindex:​MODE


MCS Index

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11ac > MCS Index
MCS Index

Defines the MCS index of the PPDUs taking part in the analysis manually. This field is enabled for "MCS index to use" = "Meas only the specified MCS" or "Demod all with specified MCS".

Remote command:

[SENSe:​]DEMod:​FORMat:​MCSindex


Nsts to use

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11ac > Nsts to use
Nsts to use

Defines the the PPDUs taking part in the analysis depending on their Nsts.

Note: The terms in brackets in the following description indicate how the setting is referred to in the "Signal Field" result display ("NSTS" column, see "Signal Field").

"Auto, same type as first PPDU:""(A1st)" | All PPDUs using the Nsts identical to the first recognized PPDU are analyzed.
"Auto, individually for each PPDU""(AI)" | All PPDUs are analyzed
"Meas only the specified Nsts""(M ...)" | Only PPDUs with the Nsts specified for the "Nsts" setting are analyzed
"Demod all with specified Nsts""(D ...)" | The "Nsts" setting is used for all PPDUs.
Remote command:

[SENSe:​]DEMod:​FORMat:​NSTSindex:​MODE


Nsts

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11ac > Nsts
Nsts

Defines the Nsts of the PPDUs taking part in the analysis. This field is enabled for "Nsts to use" = "Meas only the specified Nsts" or "Demod all with specified Nsts".

Remote command:

[SENSe:​]DEMod:​FORMat:​NSTSindex


STBC Field

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11ac > STBC Field
STBC Field

Defines the PPDUs taking part in the analysis according to the Space-Time Block Coding (STBC) field content.

Note: The terms in brackets in the following description indicate how the setting is referred to in the Signal Field result display ("STBC" column, see "Signal Field").

"Auto, same type as first PPDU""(A1st)" | All PPDUs using a STBC field content identical to the first recognized PPDU are analyzed.
"Auto, individually for each PPDU""(AI)" | All PPDUs are analyzed.
"Meas only if STBC field = 1 (+1 Stream)""(M1)"(IEEE 802.11N) | Only PPDUs with the specified STBC field content are analyzed.
"Meas only if STBC field = 2 (+2 Stream)""(M2)"(IEEE 802.11N) | Only PPDUs with the specified STBC field content are analyzed.
"Demod all as STBC field = 1""(D1)"(IEEE 802.11N) | All PPDUs are analyzed assuming the specified STBC field content.
"Demod all as STBC field = 2""(D2)"(IEEE 802.11N) | All PPDUs are analyzed assuming the specified STBC field content.
"Meas only if STBC = 1 (Nsts = 2Nss)""(M1)"(IEEE 802.11AC) | Only PPDUs with the specified STBC field content are analyzed.
"Demod all as STBC = 1 (Nsts = 2Nss)""(D1)"(IEEE 802.11AC) | All PPDUs are analyzed assuming the specified STBC field content.
Remote command:

CONFigure:​WLAN:​STBC:​AUTO:​TYPE


Table info overview

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11ac > Table info overview
Table info overview

Depending on the selected channel bandwidth, MCS index or NSS (STBC), the relevant information from the modulation and coding scheme (MCS) as defined in the WLAN 802.11 standard is displayed here. This information is for reference only, for example so you can determine the required data rate.


Guard Interval Length

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11ac > Guard Interval Length
Guard Interval Length

Defines the PPDUs taking part in the analysis depending on the guard interval length.

Note: The terms in brackets in the following description indicate how the setting is referred to in the Signal Field result display ("GI" column, see "Signal Field").

"Auto, same type as first PPDU""(A1st)" | All PPDUs using the guard interval length identical to the first recognized PPDU are analyzed.
"Auto, individually for each PPDU""(AI)" | All PPDUs are analyzed.
"Meas only Short""(MS)" | Only PPDUs with short guard interval length are analyzed.
"Meas only Long""(ML)" | Only PPDUs with long guard interval length are analyzed.
"Demod all as short""(DS)" | All PPDUs are demodulated assuming short guard interval length.
"Demod all as long""(DL)" | All PPDUs are demodulated assuming long guard interval length.
Remote command:

CONFigure:​WLAN:​GTIMe:​AUTO

CONFigure:​WLAN:​GTIMe:​AUTO:​TYPE

CONFigure:​WLAN:​GTIMe:​SELect


Demodulation - IEEE 802.11b, g (DSSS)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11b, g (DSSS)
Demodulation - IEEE 802.11b, g (DSSS)

The following settings are available for demodulation of IEEE 802.11b or g (DSSS) signals.

└ PPDU Format to measure / PSDU Modulation to use
└ PPDU Format
└ PSDU Modulation


PPDU Format to measure / PSDU Modulation to use

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11b, g (DSSS) > PPDU Format to measure / PSDU Modulation to use
PPDU Format to measure / PSDU Modulation to use

Defines which PPDU formats/modulations are to be included in the analysis. Depending on which standards the communicating devices are using, different formats of PPDUs are available. Thus you can restrict analysis to the supported formats.

Note: The PPDU format determines the available channel bandwidths.

For details on supported PPDU formats, modulations, and channel bandwidths depending on the standard see table "Supported modulation formats, PPDU formats and channel bandwidths depending on standard".

"Auto, same type as first PPDU" | The format/modulation of the first valid PPDU is detected and subsequent PPDUs are analyzed only if they have the same format.
"Auto, individually for each PPDU" | All PPDUs are analyzed regardless of their format/modulation
"Meas only ..." | Only PPDUs with the specified format or PSDUs with the specified modulation are analyzed
"Demod all as ..." | All PPDUs are assumed to have the specified PPDU format/ PSDU modulation
Remote command:

[SENSe:​]DEMod:​FORMat:​BANalyze:​BTYPe:​AUTO:​TYPE

[SENSe:​]DEMod:​FORMat:​BANalyze

[SENSe<n>:​]DEMod:​FORMat:​SIGSymbol


PPDU Format

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11b, g (DSSS) > PPDU Format
PPDU Format

If analysis is restricted to PPDUs with a particular format (see "PPDU Format to measure / PSDU Modulation to use"), this setting defines which type.

For details on supported modulation depending on the standard see table "Supported modulation formats, PPDU formats and channel bandwidths depending on standard".

Remote command:

[SENSe:​]DEMod:​FORMat:​BANalyze

[SENSe:​]DEMod:​FORMat:​BANalyze:​BTYPe


Demodulation - IEEE 802.11n

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11n
Demodulation - IEEE 802.11n

The following settings are available for demodulation of IEEE 802.11n signals.

└ PPDU Analysis Mode
└ PPDU Format to measure
└ Channel Bandwidth to measure (CBW)
└ MCS Index to use
└ MCS Index
└ STBC Field
└ Extension Spatial Streams (sounding)
└ Table info overview
└ Guard Interval Length


Extension Spatial Streams (sounding)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11n > Extension Spatial Streams (sounding)
Extension Spatial Streams (sounding)

Defines the PPDUs taking part in the analysis according to the Ness field content.

Note: The terms in brackets in the following description indicate how the setting is referred to in the Signal Field result display ("NESS" column, see "Signal Field").

"Auto, same type as first PPDU""(A1st)" | All PPDUs using a Ness value identical to the first recognized PPDU are analyzed.
"Auto, individually for each PPDU""(AI)" | All PPDUs are analyzed.
"Meas only if Ness = <x>""(M ...)" | Only PPDUs with the specified Ness value are analyzed.
"Demod all as Ness = <x>" | All PPDUs are analyzed assuming the specified Ness value.
Remote command:

CONFigure:​WLAN:​EXTension:​AUTO:​TYPE


Table info overview

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - IEEE 802.11n > Table info overview
Table info overview

Depending on the selected channel bandwidth, MCS index or NSS (STBC), the relevant information from the modulation and coding scheme (MCS) as defined in the WLAN 802.11 standard is displayed here. This information is for reference only, for example so you can determine the required data rate.


Demodulation - MIMO (IEEE 802.11ac, n)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - MIMO (IEEE 802.11ac, n)
Demodulation - MIMO (IEEE 802.11ac, n)

The MIMO settings define the mapping between streams and antennas.

This tab is only available for the standard IEEE 802.11ac or n (MIMO).

└ Spatial Mapping Mode
└ Power Normalise
└ User Defined Spatial Mapping


Spatial Mapping Mode

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - MIMO (IEEE 802.11ac, n) > Spatial Mapping Mode
Spatial Mapping Mode

Defines the mapping between streams and antennas.

For details see "Spatial Mapping".

"Direct" | The mapping between streams and antennas is the identity matrix. See also section "20.3.11.10.1 Spatial Mapping" of the IEEE 802.11n WLAN standard.
"Spatial Expansion:" | For this mode all streams contribute to all antennas. See also section "20.3.11.10.1 Spatial Mapping" of the IEEE 802.11n WLAN standard.
"User defined" | The mapping between streams and antennas is defined by the "User Defined Spatial Mapping" table.
Remote command:

CONFigure:​WLAN:​SMAPping:​MODE


Power Normalise

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - MIMO (IEEE 802.11ac, n) > Power Normalise
Power Normalise

Specifies whether an amplification of the signal power due to the spatial mapping is performed according to the matrix entries.

"On" | Spatial mapping matrix is scaled by a constant factor to obtain a passive spatial mapping matrix which does not increase the total transmitted power.
"Off" | Normalization step is omitted
Remote command:

CONFigure:​WLAN:​SMAPping:​NORMalise


User Defined Spatial Mapping

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Demodulation > Demodulation - MIMO (IEEE 802.11ac, n) > User Defined Spatial Mapping
User Defined Spatial Mapping

Define your own spatial mapping between streams and antennas.

For each antenna (Tx1..4), the complex element of each STS-Stream is defined. The upper value is the real part part of the complex element. The lower value is the imaginary part of the complex element.

Additionally, a "Time Shift" can be defined for cyclic delay diversity (CSD).

For details see "Spatial Mapping".

Remote command:

CONFigure:​WLAN:​SMAPping:​TX<ch>

CONFigure:​WLAN:​SMAPping:​TX<ch>:​STReam<stream>

CONFigure:​WLAN:​SMAPping:​TX<ch>:​TIMeshift


Evaluation Range

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Evaluation Range
Evaluation Range

The evaluation range defines which objects the result displays are based on.

└ PPDU Statistic Count / No of PPDUs to Analyze
└ Source of Payload Length (IEEE 802.11 ac, n)
└ Equal PPDU Length
└ (Min./Max.) No. of Data Symbols (IEEE 802.11a, g (OFDM), ac, n, p)
└ (Min./Max.) Payload Length (IEEE 802.11b, g (DSSS))
└ PVT : Average Length (IEEE 802.11b, g (DSSS))
└ PVT : Reference Power (IEEE 802.11b, g (DSSS))
└ Peak Vector Error : Meas Range (IEEE 802.11b, g (DSSS))


PPDU Statistic Count / No of PPDUs to Analyze

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Evaluation Range > PPDU Statistic Count / No of PPDUs to Analyze
PPDU Statistic Count / No of PPDUs to Analyze

If the statistic count is enabled, the specified number of PPDUs is taken into consideration for the statistical evaluation. Sweeps are performed continuously until the required number of PPDUs are available. The number of captured and required PPDUs, as well as the number of PPDUs detected in the current sweep, are indicated as "Analyzed PPDUs" in the channel bar (see "Channel bar information").

If disabled, all valid PPDUs in the current capture buffer are considered. Note that in this case, the number of PPDUs contributing to the current results may vary extremely.

Remote command:

[SENSe:​]BURSt:​COUNt:​STATe

[SENSe:​]BURSt:​COUNt


Source of Payload Length (IEEE 802.11 ac, n)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Evaluation Range > Source of Payload Length (IEEE 802.11 ac, n)
Source of Payload Length (IEEE 802.11 ac, n)

Defines which signal source is used to determine the payload length of a PPDU.

"Take from Signal Field"(IEEE 802.11 A, P) | Uses the length defined by the signal field
"L-Signal"(IEEE 802.11 AC) | Determines the length of the L signal
"HT-Signal"(IEEE 802.11 N) | Determines the length of the HT signal
"Estimate from signal" | Uses an estimated length
Remote command:

CONFigure:​WLAN:​PAYLoad:​LENGth:​SRC


Equal PPDU Length

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Evaluation Range > Equal PPDU Length
Equal PPDU Length

If enabled, only PPDUs with the specified "(Min./Max.) Payload Length (IEEE 802.11b, g (DSSS))" are considered for measurement analysis.

If disabled, a maximum and minimum "(Min./Max.) Payload Length (IEEE 802.11b, g (DSSS))" can be defined and all PPDUs whose length is within this range are considered.

Remote command:

IEEE 802.11a, g (OFDM):

[SENSe:​]DEMod:​FORMat:​BANalyze:​SYMBols:​EQUal

IEEE 802.11 b, g (DSSS):

[SENSe:​]DEMod:​FORMat:​BANalyze:​DURation:​EQUal

[SENSe:​]DEMod:​FORMat:​BANalyze:​DBYTes:​EQUal


(Min./Max.) No. of Data Symbols (IEEE 802.11a, g (OFDM), ac, n, p)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Evaluation Range > (Min./Max.) No. of Data Symbols (IEEE 802.11a, g (OFDM), ac, n, p)
(Min./Max.) No. of Data Symbols (IEEE 802.11a, g (OFDM), ac, n, p)

If the "Equal PPDU Length" setting is enabled, the number of data symbols defines the exact length a PPDU must have to be considered for analysis.

If the "Equal PPDU Length" setting is disabled, you can define the minimum and maximum number of data symbols a PPDU must contain to be considered in measurement analysis.

Remote command:

[SENSe:​]DEMod:​FORMat:​BANalyze:​SYMBols:​MIN

[SENSe:​]DEMod:​FORMat:​BANalyze:​SYMBols:​MAX


(Min./Max.) Payload Length (IEEE 802.11b, g (DSSS))

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Evaluation Range > (Min./Max.) Payload Length (IEEE 802.11b, g (DSSS))
(Min./Max.) Payload Length (IEEE 802.11b, g (DSSS))

If the "Equal PPDU Length" setting is enabled, the payload length defines the exact length a PPDU must have to be considered for analysis.

If the "Equal PPDU Length" setting is disabled, you can define the minimum and maximum payload length a PPDU must contain to be considered in measurement analysis.

The payload length can be defined as a duration in μs or a number of bytes (only if specific PPDU modulation and format are defined for analysis, see "PPDU Format to measure / PSDU Modulation to use").

Remote command:

[SENSe:​]DEMod:​FORMat:​BANalyze:​DBYTes:​MIN

[SENSe:​]DEMod:​FORMat:​BANalyze:​DURation:​MIN

[SENSe:​]DEMod:​FORMat:​BANalyze:​DBYTes:​MAX

[SENSe:​]DEMod:​FORMat:​BANalyze:​DURation:​MAX


PVT : Average Length (IEEE 802.11b, g (DSSS))

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Evaluation Range > PVT : Average Length (IEEE 802.11b, g (DSSS))
PVT : Average Length (IEEE 802.11b, g (DSSS))

Defines the number of samples used to adjust the length of the smoothing filter for PVT measurement.

For details see "PvT Full PPDU".

Remote command:

CONFigure:​BURSt:​PVT:​AVERage


PVT : Reference Power (IEEE 802.11b, g (DSSS))

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Evaluation Range > PVT : Reference Power (IEEE 802.11b, g (DSSS))
PVT : Reference Power (IEEE 802.11b, g (DSSS))

Sets the reference for the rise and fall time in PVT calculation to the maximum or mean PPDU power.

For details see "PvT Full PPDU".

Remote command:

CONFigure:​BURSt:​PVT:​RPOWer


Peak Vector Error : Meas Range (IEEE 802.11b, g (DSSS))

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Evaluation Range > Peak Vector Error : Meas Range (IEEE 802.11b, g (DSSS))
Peak Vector Error : Meas Range (IEEE 802.11b, g (DSSS))

Displays the used measurement range for peak vector error measurement (for reference only).

"All Symbols" | Peak Vector Error results are calculated over the complete PPDU
"PSDU only" | Peak Vector Error results are calculated over the PSDU only
Remote command:

CONFigure:​WLAN:​PVERror:​MRANge?


Result Configuration

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Result Configuration
Result Configuration

For some result displays, additional settings are available.

The "Result Configuration" softkey in the main WLAN menu opens the "Result Configuration" dialog box. This softkey is only available if a window with additional settins is currently selected.

Alternatively, select a window from the "Specifics for" selection list in the "Overview" to display the "Result Configuration" dialog box.

Depending on the selected result display, different settings are available.

Contents
  • Result Summary Configuration
  • Spectrum Flatness and Group Delay Configuration
  • AM/AM Configuration


Result Summary Configuration

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Result Configuration > Result Summary Configuration
Result Summary Configuration

You can configure which results are displayed in Result Summary displays (see "Result Summary Detailed" and "Result Summary Global"). However, the results are always calculated, regardless of their visibility on the screen.

Remote command:

DISPlay[:​WINDow<n>]:​TABLe:​ITEM


Spectrum Flatness and Group Delay Configuration

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Result Configuration > Spectrum Flatness and Group Delay Configuration
Spectrum Flatness and Group Delay Configuration

For MIMO measurements, Spectrum Flatness and Group Delay results can be based on either the effective channels or the physical channels.

While the physical channels cannot always be determined, the effective channel can always be estimated from the known training fields. Thus, for some PPDUs or measurement scenarios, only the results based on the mapping of the space-time stream to the Rx antenna (effective channel) are available, as the mapping of the Rx antennas to the Tx antennas (physical channel) could not be determined.

For more information see "Physical vs Effective Channels".

Remote command:

CONFigure:​BURSt:​SPECtrum:​FLATness:​CSELect


AM/AM Configuration

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Result Configuration > AM/AM Configuration
AM/AM Configuration

For AM/AM result displays, the trace is determined by calculating a polynomial regression model for the scattered measurement vs. reference signal data (see "AM/AM"). The degree of this model can be specified in the "Result Config" dialog box for this result display.

The resulting regression polynomial is indicated in the window title of the result display.

Remote command:

CONFigure:​BURSt:​AM:​AM:​POLYnomial

Resulting coefficients:

CONFigure:​BURSt:​AM:​AM:​COEFficients?


Automatic Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Automatic Settings
Automatic Settings

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings and signal characteristics.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu or in the configuration dialog box for the setting, where available.

└ Setting the Reference Level Automatically (Auto Level)
└ Resetting the Automatic Measurement Time (Meastime Auto)
└ Changing the Automatic Measurement Time (Meastime Manual)
└ Upper Level Hysteresis
└ Lower Level Hysteresis


Setting the Reference Level Automatically (Auto Level)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Automatic Settings > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier (for analog baseband input: the full scale level) are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

Remote command:

[SENSe:​]ADJust:​LEVel


Resetting the Automatic Measurement Time (Meastime Auto)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Automatic Settings > Resetting the Automatic Measurement Time (Meastime Auto)
Resetting the Automatic Measurement Time (Meastime Auto)

Resets the measurement duration for automatic settings to the default value.

For details see "Adjusting Settings Automatically" .

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE


Changing the Automatic Measurement Time (Meastime Manual)

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Automatic Settings > Changing the Automatic Measurement Time (Meastime Manual)
Changing the Automatic Measurement Time (Meastime Manual)

This function allows you to change the measurement duration for automatic setting adjustments. Enter the value in seconds.

For details see "Adjusting Settings Automatically" .

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE

[SENSe:​]ADJust:​CONFigure:​DURation


Upper Level Hysteresis

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Automatic Settings > Upper Level Hysteresis
Upper Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​UPPer


Lower Level Hysteresis

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Automatic Settings > Lower Level Hysteresis
Lower Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​LOWer


Sweep Settings

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Sweep Settings
Sweep Settings

The sweep settings define how the data is measured.

The "Evaluation Range" settings are also available from the main "WLAN" menu and are described in "Evaluation Range".

└ Sweep Count
└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep


Sweep Count

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Sweep Settings > Sweep Count
Sweep Count

This setting is currently ignored. For statistical evaluation see "PPDU Statistic Count / No of PPDUs to Analyze".


Continuous Sweep/RUN CONT

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Sweep Settings > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Sweep Settings > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]


Continue Single Sweep

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > Sweep Settings > Continue Single Sweep
Continue Single Sweep

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.


BW, Span, Lines and Marker Function Menus

WLAN application (R&S FSW-K91) > Configuration > WLAN IQ Measurement (Modulation Accuracy, Flatness, Tolerance...) > BW, Span, Lines and Marker Function Menus
BW, Span, Lines and Marker Function Menus

The "Span", "Bandwidth", "Lines"and "Marker Function" menus are disabled for measurements in the WLAN application.


Frequency Sweep Measurements

WLAN application (R&S FSW-K91) > Configuration > Frequency Sweep Measurements
Frequency Sweep Measurements

When you activate a measurement channel in WLAN mode, an IQ measurement of the input signal is started automatically (see "WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance)"). However, some parameters specified in the WLAN 802.11 standard require a better signal-to-noise level or a smaller bandwidth filter than the default measurement on I/Q data provides and must be determined in separate measurements based on RF data (see "Frequency Sweep Measurements"). In these measurements, demodulation is not performed.

Selecting the measurement type

WLAN measurements require a special operating mode on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

►

To select a frequency sweep measurement type, do one of the following:

  • Select the "Overview" softkey. In the "Overview", select the "Select Measurement" button. Select the required measurement.
  • Press the MEAS key on the front panel. In the "Select Measurement" dialog box, select the required measurement.

The R&S FSW WLAN application uses the functionality of the R&S FSW base system (Spectrum application) to perform the WLAN frequency sweep measurements. Some parameters are set automatically according to the WLAN 802.11 standard the first time a measurement is selected (since the last PRESET operation). These parameters can be changed, but are not reset automatically the next time you re-enter the measurement. Refer to the description of each measurement type for details.

The main measurement configuration menus for the WLAN frequency sweep measurements are identical to the Spectrum application.

For details refer to "Common Measurement Settings" .

The measurement-specific settings for the following measurements are available via the "Overview".

Contents
  • Channel Power (ACLR) Measurements
  • Spectrum Emission Mask
  • Occupied Bandwidth
  • CCDF


Channel Power (ACLR) Measurements

WLAN application (R&S FSW-K91) > Configuration > Frequency Sweep Measurements > Channel Power (ACLR) Measurements
Channel Power (ACLR) Measurements

The Adjacent Channel Power measurement analyzes the power of the TX channel and the power of adjacent and alternate channels on the left and right side of the TX channel. The number of TX channels and adjacent channels can be modified as well as the band class. The bandwidth and power of the TX channel and the bandwidth, spacing and power of the adjacent and alternate channels are displayed in the Result Summary.

Channel Power ACLR measurements are performed as in the Spectrum application with the following predefined settings according to WLAN specifications (adjacent channel leakage ratio).

Predefined settings for WLAN ACLR Channel Power measurements
Setting | Default value
ACLR Standard | same as defined in WLAN signal description (see "Standard")
Number of adjacent channels | 3
Reference channel | Max power Tx channel
Channel bandwidth | 20 MHz

For further details about the Power measurement refer to "Channel Power and Adjacent-Channel Power (ACLR) Measurement" .

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • RBW, VBW
  • Sweep time
  • Span
  • Number of adjacent channels
  • Fast ACLR mode

The main measurement menus for the frequency sweep measurements are identical to the Spectrum application.


Spectrum Emission Mask

WLAN application (R&S FSW-K91) > Configuration > Frequency Sweep Measurements > Spectrum Emission Mask
Spectrum Emission Mask

The Spectrum Emission Mask measurement shows the quality of the measured signal by comparing the power values in the frequency range near the carrier against a spectral mask that is defined by the WLAN 802.11 specifications. The limits depend on the selected power class. Thus, the performance of the DUT can be tested and the emissions and their distance to the limit are identified.

Note that the WLAN standard does not distinguish between spurious and spectral emissions.

The Result Summary contains a peak list with the values for the largest spectral emissions including their frequency and power.

The WLAN application performs the SEM measurement as in the Spectrum application with the following settings:

Predefined settings for WLAN SEM measurements
Setting | Default value
Number of ranges | 3
Frequency Span | +/- 12.75 MHz
Fast SEM | OFF
Sweep time | 140 μs
RBW | 30 kHz
Power reference type | Channel Power
Tx Bandwidth | 3.84 MHz
Number of power classes | 1

You must select the SEM file with the pre-defined settings required by the standard manually (using the "Standard Files" softkey in the main "SEMask" menu). The subdirectory displayed in the SEM standard file selection dialog box depends on the standard you selected previously for the WLAN Modulation Accuracy, Flatness,... measurement (see "Standard").

For further details about the Spectrum Emission Mask measurements refer to "Spectrum Emission Mask (SEM) Measurement" .

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • Sweep time
  • Span

The main measurement menus for the frequency sweep measurements are identical to the Spectrum application.


Occupied Bandwidth

WLAN application (R&S FSW-K91) > Configuration > Frequency Sweep Measurements > Occupied Bandwidth
Occupied Bandwidth

The Occupied Bandwidth measurement is performed as in the Spectrum application with default settings.

Predefined settings for WLAN OBW measurements
Setting | Default value
% Power Bandwidth | 99 %
Channel bandwidth | 3.84 MHz

The Occupied Bandwidth measurement determines the bandwidth that the signal occupies. The occupied bandwidth is defined as the bandwidth in which – in default settings - 99 % of the total signal power is to be found. The percentage of the signal power to be included in the bandwidth measurement can be changed.

For further details about the Occupied Bandwidth measurements refer to "Occupied Bandwidth Measurement (OBW)" .

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • RBW, VBW
  • Sweep time
  • Span


CCDF

WLAN application (R&S FSW-K91) > Configuration > Frequency Sweep Measurements > CCDF
CCDF

The CCDF measurement determines the distribution of the signal amplitudes (complementary cumulative distribution function). The CCDF and the Crest factor are displayed. For the purposes of this measurement, a signal section of user-definable length is recorded continuously in zero span, and the distribution of the signal amplitudes is evaluated.

The measurement is useful to determine errors of linear amplifiers. The crest factor is defined as the ratio of the peak power and the mean power. The Result Summary displays the number of included samples, the mean and peak power and the crest factor.

The CCDF measurement is performed as in the Spectrum application with the following settings:

Predefined settings for WLAN CCDF measurements
Setting | Default value
CCDF | Active on trace 1
Analysis bandwidth | 10 MHz
Number of samples | 62500
Detector | Sample

For further details about the CCDF measurements refer to "Statistical Measurements (APD, CCDF)" .

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • Analysis bandwidth
  • Number of samples


Analysis

WLAN application (R&S FSW-K91) > Analysis
Analysis

General result analysis settings concerning the trace and markers etc. are currently not available for the standard WLAN measurements. Only one (Clear/Write) trace and one marker are available for these measurements.

Analysis of frequency sweep measurements

General result analysis settings concerning the trace, markers, lines etc. for RF measurements are identical to the analysis functions in the Spectrum application except for some special marker functions and spectrograms, which are not available in the WLAN application.

See
  • "Common Analysis and Display Functions"
  • "Analyzing Measurements (Basics)"

The remote commands required to perform these tasks are described in "Analysis".


I/Q Data Import and Export

WLAN application (R&S FSW-K91) > I/Q Data Import and Export
I/Q Data Import and Export

Baseband signals mostly occur as so-called complex baseband signals, i.e. a signal representation that consists of two channels; the in phase (I) and the quadrature (Q) channel. Such signals are referred to as I/Q signals. I/Q signals are useful because the specific RF or IF frequencies are not needed. The complete modulation information and even distortion that originates from the RF, IF or baseband domains can be analyzed in the I/Q baseband.

Importing and exporting I/Q signals is useful for various applications:
  • Generating and saving I/Q signals in an RF or baseband signal generator or in external software tools to analyze them with the R&S FSW later
  • Capturing and saving I/Q signals with an RF or baseband signal analyzer to analyze them with the R&S FSW or an external software tool later

For example, you can capture I/Q data using the I/Q Analyzer application, if available, and then perform a WLAN 802.11 measurement on that data later using the R&S FSW WLAN 802.11 application.

As opposed to storing trace data, which may be averaged or restricted to peak values, I/Q data is stored as it was captured, without further processing. The data is stored as complex values in 32-bit floating-point format. Multi-channel data is not supported. The I/Q data is stored in a format with the file extension .iq.tar.

For a detailed description see "I/Q Data File Format (iq-tar)" .

For details on import and export functions see "Import/Export Functions" .


How to Perform Measurements in the WLAN Application

WLAN application (R&S FSW-K91) > How to Perform Measurements in the WLAN Application
How to Perform Measurements in the WLAN Application

The following step-by-step instructions demonstrate how to perform measurements in the R&S FSW WLAN application. The following tasks are described:

Contents
  • How to Determine Modulation Accuracy, Flatness and Tolerance Parameters for WLAN Signals
  • How to Analyze WLAN Signals in a MIMO Measurement Setup
  • How to Determine the OBW, SEM, ACLR or CCDF for WLAN Signals


How to Determine Modulation Accuracy, Flatness and Tolerance Parameters for WLAN Signals

WLAN application (R&S FSW-K91) > How to Perform Measurements in the WLAN Application > How to Determine Modulation Accuracy, Flatness and Tolerance Parameters for WLAN Signals
How to Determine Modulation Accuracy, Flatness and Tolerance Parameters for WLAN Signals

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "WLAN" item.

    The R&S FSW opens a new measurement channel for the WLAN application.

  3. Select the "Overview" softkey to display the "Overview" for a WLAN measurement.

  4. Select the "Signal Description" button to define the digital standard to be used.

  5. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's center frequency.

    The reference level is adapted automatically.

  6. Select the "Signal Capture" button to define how much and which data to capture from the input signal.

  7. To define a particular starting point for the FFT or to improve the measurement speed for signals with a low duty cycle, select the "Synchronization/OFDM-Demod." button and set the required parameters.

  8. Select the "Tracking/Channel Estimation" button to define how the data channels are to be estimated and which distortions will be compensated for.

  9. Select the "Demod" button to provide information on the modulated signal and how the PPDUs detected in the capture buffer are to be demodulated.

  10. Select the "Evaluation Range" button to define which data in the capture buffer you want to analyze.

  11. Select the "Display Config" button and select the displays that are of interest to you (up to 16).

    Arrange them on the display to suit your preferences.

  12. Exit the SmartGrid mode.

  13. Start a new sweep with the defined settings.

    • To perform a single sweep measurement, press the RUN SINGLE hardkey.
    • To perform a continuous sweep measurement, press the RUN CONT hardkey.

    Measurement results are updated once the measurement has completed.


How to Analyze WLAN Signals in a MIMO Measurement Setup

WLAN application (R&S FSW-K91) > How to Perform Measurements in the WLAN Application > How to Analyze WLAN Signals in a MIMO Measurement Setup
How to Analyze WLAN Signals in a MIMO Measurement Setup

MIMO measurements are only available for IEEE 802.11ac, n standards. They can be performed automatically or manually (see "Capturing Data from MIMO Antennas").

To perform a manual sequential measurement

  1. Press the MODE key on the front panel of the R&S FSW.

  2. Select the "WLAN" item.

    The R&S FSW opens a new measurement channel for the WLAN application.

  3. Select the "Overview" softkey to display the "Overview" for a WLAN measurement.

  4. Select the "Signal Description" button to select the digital standard IEEE 802.11ac or IEEE 802.11n.

  5. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's center frequency.

    The reference level is adapted automatically.

  6. Select the "Signal Capture" button to define how much and which data to capture from the input signal.

  7. Select the "MIMO Capture" tab to define how the data from the MIMO antennas is to be captured.

    1. For the "DUT MIMO Config." select the number of TX antennas data will be transmitted from.

    2. Under "MIMO antenna Signal Capture Setup" select "Sequential Manual".

  8. To define a particular starting point for the FFT or to improve the measurement speed for signals with a low duty cycle, select the "Synchronization/OFDM-Demod." button and set the required parameters.

  9. Select the "Tracking/Channel Estimation" button to define how the data channels are to be estimated and which distortions will be compensated for, e.g. crosstalk between the MIMO antennas at the DUT.

  10. Select the "Demod" button and then the "Demod" tab to provide information on the modulated signal and how the PPDUs detected in the capture buffer are to be demodulated.

  11. In the "Demodulation" dialog box, select the "MIMO" tab to define which spatial mapping mode is used, that is, how the space-time streams are mapped to the antennas.

    1. If necessary, include a time shift for the individual antennas.

    2. If the signal power is amplified according to the maxtrix entries so that the total transmitted power is not increased, the measured powers can be normalised to consider this effect in demodulation.

  12. Select the "Evaluation Range" button to define which data in the capture buffer you want to analyze.

  13. Select the "Display Config" button and select the displays that are of interest to you (up to 16).

    Arrange them on the display to suit your preferences.

  14. Exit the SmartGrid mode.

  15. Return to the "Signal Capture" > "MIMO Capture" dialog box tab to perform the measurement.

    1. Connect the input for the first Tx antenna to the RF input of the R&S FSW.

    2. Select the "Single" or "Cont." button for the RX 1 capture buffer to perform a single or continuous measurement for that antenna. For a continuous measurement, select the "Cont." button again to stop the measurement.

    3. Connect the input for the second Tx antenna to the RF input of the R&S FSW.

    4. Select the "Single" / "Cont." button for the RX 2 capture buffer.

    5. If necessary, repeat these steps for the third and fourth antennas.

    6. Select "Calc Results" to determine the results for each individual data stream in the selected result displays.

    Note: Instead of selecting the "Single" / "Cont." button in the "Signal Capture" dialog box for each individual antenna capture, which requires keeping the dialog box open, you can press the RUN SINGLE or RUN CONT key on the front panel to perform the measurements. The data is evaluated and the result displays are updated when the measurement is stopped.
    However, in this case the data is written to the same capture buffer for all antennas (namely the one selected for "<RUNS SINGLE> or <RUN CONT> updates" in the "MIMO Capture" tab). Thus, the assignment of the individual data streams to antennas is no longer visible in the result displays.

To perform an automated sequential measurement (with an OSP switch box)

This measurement setup requires an additional R&S OSP switch box. For details on setting up and using this instrument, see the corresponding documentation!

  1. Press the MODE key on the front panel of the R&S FSW.

  2. Select the "WLAN" item.

    The R&S FSW opens a new measurement channel for the WLAN application.

  3. Select the "Overview" softkey to display the "Overview" for a WLAN measurement.

  4. Select the "Signal Description" button to select the digital standard IEEE 802.11ac or IEEE 802.11n.

  5. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's center frequency.

    The reference level is adapted automatically.

  6. Select the "Signal Capture" button to define how much and which data to capture from the input signal.

  7. Select the "MIMO Capture" tab to define how the data from the MIMO antennas is to be captured.

    1. For the "DUT MIMO Config." select the number of TX antennas data will be transmitted from.

    2. Under "MIMO antenna Signal Capture Setup" select "Sequential using OSP switch box".

    3. Enter the IP address of the connected OSP switch box.

    4. For the "OSP Switch Bank Configuration" select the module used to connect the OSP switch box to the R&S FSW.

    5. Connect the antennas and the R&S FSW to the OSP switch box as indicated in the dialog box.

    6. Configure the OSP switch box to switch between the antenna input as required.

  8. To define a particular starting point for the FFT or to improve the measurement speed for signals with a low duty cycle, select the "Synchronization/OFDM-Demod." button and set the required parameters.

  9. Select the "Tracking/Channel Estimation" button to define how the data channels are to be estimated and which distortions will be compensated for, e.g. crosstalk between the MIMO antennas at the DUT.

  10. Select the "Demod" button to provide information on the modulated signal and how the PPDUs detected in the capture buffer are to be demodulated.

  11. Select the "MIMO" tab in the "Demodulation" dialog box to define which spatial mapping mode is used, that is, how the space-time streams are mapped to the antennas.

    1. If necessary, include a time shift for the individual antennas.

    2. If the signal power is amplified according to the maxtrix entries so that the total transmitted power is not increased, the measured powers can be normalised to consider this effect in demodulation.

  12. Select the "Evaluation Range" button to define which data in the capture buffer you want to analyze.

  13. Select the "Display Config" button and select the displays that are of interest to you (up to 16).

    Arrange them on the display to suit your preferences.

  14. Exit the SmartGrid mode.

  15. Start the measurement via the OSP switch box. The data is captured from all antennas automatically. The data is evaluated and the result displays are updated for the individual data streams when the measurement is stopped.

To perform a simultaneous measurement (with multiple R&S FSWs and an R&S FS-Z11 Trigger Unit)

This measurement setup requires as many R&S FSWs as Tx antennas are used! They must all be connected via LAN. Select one R&S FSW as a master. It is assumed the R&S FS-Z11 Trigger Unit is set up according to the following illustration:

R&S FS-Z11 Trigger Unit connections

Perform the following configuration on all R&S FSWs, except for the MIMO capture settings (step 7). These settings are only required for the master analyzer.

  1. Press the MODE key on the front panel of the R&S FSW.

  2. Select the "WLAN" item.

    The R&S FSW opens a new measurement channel for the WLAN application.

  3. Select the "Overview" softkey to display the "Overview" for a WLAN measurement.

  4. Select the "Signal Description" button to select the digital standard IEEE 802.11ac or IEEE 802.11n.

  5. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's center frequency.

    The reference level is adapted automatically.

  6. Select the "Signal Capture" button to define how much and which data to capture from the input signal.

  7. For the master analyzer only:

    Select the "MIMO Capture" tab to define how the data from the MIMO antennas is to be captured.

    1. For the "DUT MIMO Config." select the number of TX antennas data will be transmitted from.

    2. Under "MIMO antenna Signal Capture Setup" select "Simultaneous".

    3. For each connected R&S FSW, enter the IP address and assign an antenna that this analyzer slave will capture data from.

    4. Ensure that the "State" of each analyzer is "On" and the connection is established (the lights should be green in the dialog box).

    5. Connect the assigned antenna to each R&S FSW.

  8. To define a particular starting point for the FFT or to improve the measurement speed for signals with a low duty cycle, select the "Synchronization/OFDM-Demod." button and set the required parameters.

  9. Select the "Tracking/Channel Estimation" button to define how the data channels are to be estimated and which distortions will be compensated for, e.g. crosstalk between the MIMO antennas at the DUT.

  10. Select the "Demod" button to provide information on the modulated signal and how the PPDUs detected in the capture buffer are to be demodulated.

  11. Select the "MIMO" tab in the "Demodulation" dialog box to define which spatial mapping mode is used, that is, how the space-time streams are mapped to the antennas.

    1. If necessary, include a time shift for the individual antennas.

    2. If the signal power is amplified according to the maxtrix entries so that the total transmitted power is not increased, the measured powers can be normalised to consider this effect in demodulation.

  12. Select the "Evaluation Range" button to define which data in the capture buffer you want to analyze.

  13. Select the "Display Config" button and select the displays that are of interest to you (up to 16).

    Arrange them on the display to suit your preferences.

  14. Exit the SmartGrid mode.

  15. For the master analyzer only:

    Activate the NOISE SOURCE output for the connection to the R&S FS-Z11 Trigger Unit.

    For an R&S FSW as a master analyzer:

    1. Press the INPUT/OUTPUT key.

    2. Select "Output Config".

    3. Select "Noise Source": "On".

  16. Trigger a new sweep by pressing the TRIG MANUAL button on the Trigger Unit.

    The data is captured from all antennas automatically. The data is collected by the master R&S FSW, which evaluates the entire data and updates the result displays for the individual data streams when the measurement is stopped.


How to Determine the OBW, SEM, ACLR or CCDF for WLAN Signals

WLAN application (R&S FSW-K91) > How to Perform Measurements in the WLAN Application > How to Determine the OBW, SEM, ACLR or CCDF for WLAN Signals
How to Determine the OBW, SEM, ACLR or CCDF for WLAN Signals

  1. Press the MODE key on the front panel and select the "WLAN" application.

    The R&S FSW opens a new measurement channel for the WLAN application. I/Q data acquisition is performed by default.

  2. Select the "Signal Description" button to define the digital standard to be used.

  3. Select the required measurement:

    1. Press the MEAS key on the front panel.

    2. In the "Select Measurement" dialog box, select the required measurement.

    The selected measurement is activated with the default settings for WLAN immediately.

  4. For SEM measurements, select the required standard settings file:

    1. In the SEMask menu, select the "Standard Files" softkey.

    2. Select the required settings file. The subdirectory displayed in the file selection dialog box depends on the standard you selected in step step 2.

  5. If necessary, adapt the settings as described for the individual measurements in "Measurements" .

  6. Select the "Display Config" button and select the evaluation methods that are of interest to you.

    Arrange them on the display to suit your preferences.

  7. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  8. Select the "Analysis" button in the "Overview" to make use of the advanced analysis functions in the result displays.

    • Configure a trace to display the average over a series of sweeps; if necessary, increase the "Sweep Count" in the "Sweep" settings.
    • Configure markers and delta markers to determine deviations and offsets within the evaluated signal.
    • Use special marker functions to calculate noise or a peak list.
    • Configure a limit check to detect excessive deviations.

  9. Optionally, export the trace data of the graphical evaluation results to a file.

    1. In the "Traces" tab of the "Analysis" dialog box, switch to the "Trace Export" tab.

    2. Select "Export Trace to ASCII File".

    3. Define a file name and storage location and select "OK".


Optimizing and Troubleshooting the Measurement

WLAN application (R&S FSW-K91) > Optimizing and Troubleshooting the Measurement
Optimizing and Troubleshooting the Measurement
Contents
  • Optimizing the Measurement Results
  • Error Messages and Warnings


Optimizing the Measurement Results

WLAN application (R&S FSW-K91) > Optimizing and Troubleshooting the Measurement > Optimizing the Measurement Results
Optimizing the Measurement Results

If the results do not meet your expectations, try the following methods to optimize the measurement.

Contents
  • Improving Performance
  • Improving Channel Estimation and EVM Accuracy


Improving Performance

WLAN application (R&S FSW-K91) > Optimizing and Troubleshooting the Measurement > Optimizing the Measurement Results > Improving Performance
Improving Performance
Performing a coarse burst search

For signals with low duty cycle rates, enable the "Power Interval Search" for synchronization (see "Power Interval Search"). In this case, the R&S FSW WLAN application initially performs a coarse burst search on the input signal in which increases in the power vs time trace are detected. Further time-consuming processing is then only performed where bursts are assumed. This improves the measurement speed.

However, for signals in which the PPDU power levels differ significantly, this option should be disabled as otherwise some PPDUs may not be detected.


Improving Channel Estimation and EVM Accuracy

WLAN application (R&S FSW-K91) > Optimizing and Troubleshooting the Measurement > Optimizing the Measurement Results > Improving Channel Estimation and EVM Accuracy
Improving Channel Estimation and EVM Accuracy

The channels in the WLAN signal are estimated based on the expected input signal description and the information provided by the PPDUs themselves. The more accurate the channel estimation, the more accurate the EVM based on these channels can be calculated.

Increasing the basis for channel estimation

The more information that can be used to estimate the channels, the more accurate the results. For measurements that need not be performed strictly according to the WLAN 802.11 standard, set the "Channel Estimation Range" to "Payload" (see "Channel Estimation Range").

The channel estimation is performed in the preamble and the payload. The EVM results can be calculated more accurately.

Accounting for phase drift in the EVM

According to the WLAN 802.11 standards, the common phase drift must be estimated and compensated from the pilots. Thus, these deviations are not included in the EVM. To include the phase drift, disable "Phase Tracking" (see "Phase Tracking").

Analyzing time jitter

Normally, a symbol-wise timing jitter is negligible and not required by the IEEE 802.11a measurement standard [6], and thus not considered in channel estimation. However, there may be situations where the timing drift has to be taken into account.

However, to analyze the time jitter per symbol, enable "Timing Tracking" (see "Timing Error Tracking").

Compensating for non-standard-conform pilot sequences

In case the pilot generation algorithm of the device under test (DUT) has a problem, the non-standard-conform pilot sequence might affect the measurement results, or the WLAN application might not synchronize at all onto the signal generated by the DUT.

In this case, set the "Pilots for Tracking" to "Detected" (see "Pilots for Tracking"), so that the pilot sequence detected in the signal is used instead of the sequence defined by the standard.

However, if the pilot sequence generated by the DUT is correct, it is recommended that you use the "According to Standard" setting because it generates more accurate measurement results.


Error Messages and Warnings

WLAN application (R&S FSW-K91) > Optimizing and Troubleshooting the Measurement > Error Messages and Warnings
Error Messages and Warnings

The following messages are displayed in the status bar in case of errors.

Results contribute to overall results despite inconsistencies:

"Info: Comparison between HT-SIG Payload Length and Estimated Payload Length not performed due to insufficient SNR"

The R&S FSW-K91 application compares the HT-SIG length against the length estimated from the PPDU power profile. If the two values do not match, the corresponding entry is highlighted orange. If the signal quality is very bad, this comparison is suppressed and the message above is shown.

"Warning: HT-SIG of PPDU was not evaluated"

Decoding of the HT-SIG was not possible because there was to not enough data in the Capture Memory (potential PPDU truncation).

"Warning: Mismatch between HT-SIG and estimated (SNR+Power) PPDU length"

The HT-SIG length and the length estimated by the R&S FSW application (from the PPDU power profile) are different.

"Warning: Physical Channel estimation impossible / Phy Chan results not available Possible reasons: channel matrix not square or singular to working precision"

The Physical Channel results could not be calculated for one or both of the following reasons:

  • The spatial mapping can not be applied due to a rectangular mapping matrix (the number of space time streams is not equal to the number of transmit antennas).
  • The spatial mapping matrices are singular to working precision.
PPDUs are dismissed due to inconsistencies

"Hint: PPDU requires at least one payload symbol"

Currently at least one payload symbol is required in order to successfully analyze the PPDU. Null data packet (NDP) sounding PPDUs will generate this message.

"Hint: PPDU dismissed due to a mismatch with the PPDU format to be analyzed"

The properties causing the mismatches for this PPDU are highlighted.

"Hint: PPDU dismissed due to truncation"

The first or the last PPDU was truncated during the signal capture process, for example.

"Hint: PPDU dismissed due to HT-SIG inconsistencies"

One or more of the following HT-SIG decoding results are outside of specified range: MCS index, Number of additional STBC streams, Number of space time streams (derived from MCS and STBC), CRC Check failed, Non zero tail bits.

"Hint: PPDU dismissed because payload channel estimation was not possible"

The payload based channel estimation was not possible because the channel matrix is singular to working precision.

"Hint: Channel matrix singular to working precision"

Channel equalizing (for PPDU Length Detection, fully and user compensated measurement signal) is not possible because the estimated channel matrix is singular to working precision.


Remote Commands for WLAN Measurements

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements
Remote Commands for WLAN Measurements

The following commands are required to perform measurements in the R&S FSW WLAN application in a remote environment.

It is assumed that the R&S FSW has already been set up for remote control in a network as described in "How to Set Up a Network and Remote Control" .

Note that basic tasks that are also performed in the base unit in the same way are not described here.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data, see "Managing Settings and Results"
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation, see "Configuring the "
  • Using the common status registers, see "Using the Status Register"

After an introduction to SCPI commands, the following tasks specific to the WLAN application are described here:

Contents
  • Common Suffixes
  • Introduction
  • Activating WLAN Measurements
  • Selecting a Measurement
  • Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance)
  • Configuring Frequency Sweep Measurements on WLAN Signals
  • Configuring the Result Display
  • Starting a Measurement
  • Retrieving Results
  • Analysis
  • Status Registers
  • Commands for Compatibility
  • Programming Examples (R&S FSW-K91)


Common Suffixes

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Common Suffixes
Common Suffixes

For the description of the remote commands in the WLAN application, the following common suffixes are used:

Common suffixes for WLAN measurements on I/Q data
Suffix | Value range | Description
<n> | 1..16 | Window
<k> | 1..8 | Limit
<t> | 1 | Trace
<m> | 1..4 | Marker
Common suffixes for frequency sweep measurements
Suffix | Value range | Description
<n> | 1..16 | Window
<t> | 1..6 | Trace
<m> | 1..16 | Marker
<ch> | 1..18 (Tx channel) 1..11 (ALTernate or ADJacent channel) | Channel
<k> | 1..8 | Limit line


Introduction

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Activating WLAN Measurements

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Activating WLAN Measurements
Activating WLAN Measurements

WLAN measurements require a special application on the R&S FSW (R&S FSW-K91). The measurement is started immediately with the default settings.

These are basic R&S FSW commands, listed here for your convenience.

List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:CHANnel[:EXECute]


INSTrument:CREate:DUPLicate

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Activating WLAN Measurements > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect] ).

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Activating WLAN Measurements > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Activating WLAN Measurements > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Activating WLAN Measurements > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Activating WLAN Measurements > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Activating WLAN Measurements > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Activating WLAN Measurements > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType> | <ChannelName>

This command activates a new measurement channel with the defined channel type, or selects an existing measurement channel with the specified name.

See also INSTrument:​CREate[:​NEW].

For a list of available channel types see INSTrument:​LIST?.

Parameters:
<ChannelType> | Channel type of the new channel. For a list of available channel types see table "Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode". WLAN WLAN option, R&S FSW–K91
<ChannelName> | String containing the name of the channel.
Example: | INST WLAN Activates a measurement channel for the WLAN application. INST 'WLAN' Selects the measurement channel named 'WLAN' (for example before executing further commands for that channel).


SYSTem:PRESet:CHANnel[:EXECute]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Activating WLAN Measurements > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Selecting a Measurement

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement
Selecting a Measurement

The following commands are required to define the measurement type in a remote environment. The selected measurement must be started explicitely (see "Starting a Measurement")!

For details on available measurements see "Measurements and Result Displays".

The WLAN IQ measurement captures the I/Q data from the WLAN signal using a (nearly rectangular) filter with a relatively large bandwidth. This measurement is selected when the WLAN measurement channel is activated. The commands to select a different measurement or return to the WLAN IQ measurement are described here.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Contents
  • Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance)
  • Selecting a Common RF Measurement for WLAN Signals


Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance)

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance)
Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance)

Any of the following commands can be used to return to the WLAN IQ measurement. Each of these results are automatically determined when the WLAN IQ measurement is performed.

The selected measurement must be started explicitely (see "Starting a Measurement")!

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

List of Commands
CONFigure:BURSt:AM:AM[:IMMediate]
CONFigure:BURSt:AM:EVM[:IMMediate]
CONFigure:BURSt:AM:PM[:IMMediate]
CONFigure:BURSt:CONSt:CCARrier[:IMMediate]
CONFigure:BURSt:CONSt:CSYMbol[:IMMediate]
CONFigure:BURSt:EVM:ECARrier[:IMMediate]
CONFigure:BURSt:EVM:ESYMbol[:IMMediate] (IEEE 802.11b and g (DSSS))
CONFigure:BURSt:EVM:ECHip[:IMMediate]
CONFigure:BURSt:EVM:ESYMbol[:IMMediate]
CONFigure:BURSt:PREamble[:IMMediate]
CONFigure:BURSt:PREamble:SELect
CONFigure:BURSt:PVT[:IMMediate]
CONFigure:BURSt:PVT:SELect
CONFigure:BURSt:SPECtrum:FFT[:IMMediate]
CONFigure:BURSt:SPECtrum:FLATness:SELect
CONFigure:BURSt:SPECtrum:FLATness[:IMMediate]
CONFigure:BURSt:STATistics:BSTReam[:IMMediate]
CONFigure:BURSt:STATistics:SFIeld[:IMMediate]
DISPlay[:WINDow<n>]:SELect


CONFigure:BURSt:AM:AM[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:AM:AM[:IMMediate]
CONFigure:BURSt:AM:AM[:IMMediate]

This remote control command configures the result display type of window 2 to be AM vs AM. Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "AM/AM"


CONFigure:BURSt:AM:EVM[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:AM:EVM[:IMMediate]
CONFigure:BURSt:AM:EVM[:IMMediate]

This remote control command configures the result display type of window 2 to be AM vs. EVM. Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "AM/EVM"


CONFigure:BURSt:AM:PM[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:AM:PM[:IMMediate]
CONFigure:BURSt:AM:PM[:IMMediate]

This remote control command configures the result display type of window 2 to be AM vs PM. Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "AM/PM"


CONFigure:BURSt:CONSt:CCARrier[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:CONSt:CCARrier[:IMMediate]
CONFigure:BURSt:CONSt:CCARrier[:IMMediate]

This remote control command configures the result display type of window 2 to be Constellation vs Carrier. Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "Constellation vs Carrier"


CONFigure:BURSt:CONSt:CSYMbol[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:CONSt:CSYMbol[:IMMediate]
CONFigure:BURSt:CONSt:CSYMbol[:IMMediate]

This remote control command configures the result display type of window 2 to be Constellation (vs Symbol). Results are only displayed after a measurement has been executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "Constellation"


CONFigure:BURSt:EVM:ECARrier[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:EVM:ECARrier[:IMMediate]
CONFigure:BURSt:EVM:ECARrier[:IMMediate]

This remote control command configures the result display type of window 2 to be EVM vs Carrier. Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "EVM vs Carrier"


CONFigure:BURSt:EVM:ESYMbol[:IMMediate] (IEEE 802.11b and g (DSSS))

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:EVM:ESYMbol[:IMMediate] (IEEE 802.11b and g (DSSS))
CONFigure:BURSt:EVM:ESYMbol[:IMMediate] (IEEE 802.11b and g (DSSS))
CONFigure:BURSt:EVM:ECHip[:IMMediate]

Both of these commands configure the measurement type to be EVM vs Chip for IEEE 802.11b and g (DSSS) standards. For compatibility reasons, the CONFigure:BURSt:EVM:ESYMbol[:IMMediate] command is also supported for the IEEE 802.11b and g (DSSS) standards. However, for new remote control programs use the LAYout commands (see "Working with Windows in the Display").

Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Manual operation: See "EVM vs Chip"


CONFigure:BURSt:EVM:ESYMbol[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:EVM:ESYMbol[:IMMediate]
CONFigure:BURSt:EVM:ESYMbol[:IMMediate]

This remote control command configures the measurement type to be EVM vs Symbol.

For IEEE 802.11b and g (DSSS) standards, this command selects the EVM vs Chip result display.

Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "EVM vs Chip" See "EVM vs Symbol"


CONFigure:BURSt:PREamble[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:PREamble[:IMMediate]
CONFigure:BURSt:PREamble[:IMMediate]

This remote control command configures the measurement type to be Frequency Error vs Preamble or Phase Error vs Preamble. Which of the two is determined by CONFigure:​BURSt:​PREamble:​SELect.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Manual operation: See "Freq. Error vs Preamble"
See "Phase Error vs Preamble"


CONFigure:BURSt:PREamble:SELect

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:PREamble:SELect
CONFigure:BURSt:PREamble:SELect <ErrType>

This remote control command specifies whether frequency or phase results are displayed when the measurement type is set to Error Vs Preamble (CONFigure:​BURSt:​PREamble[:​IMMediate]).

Parameters:
<ErrType> | FREQuency Displays frequency error results for the preamble of the measured PPDUs only PHASe Displays phase error results for the preamble of the measured PPDUs only
Example: | CONF:BURS:PRE:SEL PHAS
Manual operation: | See "Freq. Error vs Preamble" See "Phase Error vs Preamble"


CONFigure:BURSt:PVT[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:PVT[:IMMediate]
CONFigure:BURSt:PVT[:IMMediate]

This remote control command configures the measurement type to be Power vs Time.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Manual operation: See "PvT Full PPDU"
See "PvT Rising Edge"
See "PvT Falling Edge"


CONFigure:BURSt:PVT:SELect

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:PVT:SELect
CONFigure:BURSt:PVT:SELect <Mode>

This remote command determines how to interpret the Power vs Time measurement results.

Parameters:
<Mode> | EDGE Displays rising and falling edges only FALL Displays falling edge only FULL Displays the full PPDU RISE Displays the rising edge only
Example: | CONF:BURS:PVT:SEL FULL Interprets the measurement results as full PPDU
Manual operation: | See "PvT Full PPDU" See "PvT Rising Edge" See "PvT Falling Edge"


CONFigure:BURSt:SPECtrum:FFT[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:SPECtrum:FFT[:IMMediate]
CONFigure:BURSt:SPECtrum:FFT[:IMMediate]

This remote control command configures the result display type of window 2 to be FFT Spectrum. Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "FFT Spectrum"


CONFigure:BURSt:SPECtrum:FLATness:SELect

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:SPECtrum:FLATness:SELect
CONFigure:BURSt:SPECtrum:FLATness:SELect <MeasType>

This remote control command configures result display type of window 2 to be either Spectrum Flatness or Group Delay. Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Parameters:
<MeasType> | FLATness | GRDelay
Example: | CONF:BURS:SPEC:FLAT:SEL FLAT Configures the result display of window 2 to be Spectrum Flatness. CONF:BURS:SPEC:FLAT:IMM Performs a default WLAN measurement. When the measurement is completed, the Spectrum Flatness results are displayed.
Usage: | Event
Manual operation: | See "Group Delay" See "Spectrum Flatness"


CONFigure:BURSt:SPECtrum:FLATness[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:SPECtrum:FLATness[:IMMediate]
CONFigure:BURSt:SPECtrum:FLATness[:IMMediate]

This remote control command configures the result display in window 2 to be Spectrum Flatness or Group Delay, depending on which result display was selected last using CONFigure:​BURSt:​SPECtrum:​FLATness:​SELect. Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Example: | CONF:BURS:SPEC:FLAT:SEL FLAT Configures the result display of window 2 to be Spectrum Flatness. CONF:BURS:SPEC:FLAT:IMM Performs a default WLAN measurement. When the measurement is completed, the Spectrum Flatness results are displayed.
Usage: | Event
Manual operation: | See "Group Delay" See "Spectrum Flatness"


CONFigure:BURSt:STATistics:BSTReam[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:STATistics:BSTReam[:IMMediate]
CONFigure:BURSt:STATistics:BSTReam[:IMMediate]

This remote control command configures the result display type of window 2 to be Bitstream. Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "Bitstream"


CONFigure:BURSt:STATistics:SFIeld[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > CONFigure:BURSt:STATistics:SFIeld[:IMMediate]
CONFigure:BURSt:STATistics:SFIeld[:IMMediate]

This remote control command configures the result display type of window 2 to be Signal Field. Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "PLCP Header (IEEE 802.11b, g (GSSS)" See "Signal Field"


DISPlay[:WINDow<n>]:SELect

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > DISPlay[:WINDow<n>]:SELect
DISPlay[:WINDow<n>]:SELect

This command sets the focus on the selected result display window.

This window is then the active window.

Example: | DISP:WIND1:SEL Sets the window 1 active.
Usage: | Setting only


Selecting a Common RF Measurement for WLAN Signals

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting a Common RF Measurement for WLAN Signals
Selecting a Common RF Measurement for WLAN Signals

The following commands are required to select a common RF measurement for WLAN signals in a remote environment.

For details on available measurements see "Frequency Sweep Measurements".

The selected measurement must be started explicitely (see "Starting a Measurement")!

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that.

Use the LAYout commands to change the display (see "Configuring the Result Display").

List of Commands
CONFigure:BURSt:SPECtrum:ACPR[:IMMediate]
CONFigure:BURSt:SPECtrum:MASK[:IMMediate]
CONFigure:BURSt:SPECtrum:OBWidth[:IMMediate]
CONFigure:BURSt:STATistics:CCDF[:IMMediate]


CONFigure:BURSt:SPECtrum:ACPR[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting a Common RF Measurement for WLAN Signals > CONFigure:BURSt:SPECtrum:ACPR[:IMMediate]
CONFigure:BURSt:SPECtrum:ACPR[:IMMediate]

This remote control command configures the result display in window 2 to be ACPR (adjacent channel power relative). Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "Channel Power ACLR"


CONFigure:BURSt:SPECtrum:MASK[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting a Common RF Measurement for WLAN Signals > CONFigure:BURSt:SPECtrum:MASK[:IMMediate]
CONFigure:BURSt:SPECtrum:MASK[:IMMediate]

This remote control command configures the result display in window 2 to be Spectrum Mask. Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "Spectrum Emission Mask"


CONFigure:BURSt:SPECtrum:OBWidth[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting a Common RF Measurement for WLAN Signals > CONFigure:BURSt:SPECtrum:OBWidth[:IMMediate]
CONFigure:BURSt:SPECtrum:OBWidth[:IMMediate]

This remote control command configures the result display in window 2 to be ACPR (adjacent channel power relative). Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "Occupied Bandwidth"


CONFigure:BURSt:STATistics:CCDF[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Selecting a Measurement > Selecting a Common RF Measurement for WLAN Signals > CONFigure:BURSt:STATistics:CCDF[:IMMediate]
CONFigure:BURSt:STATistics:CCDF[:IMMediate]

This remote control command configures the result display in window 2 to be CCDF (conditional cumulative distribution function). Results are only displayed after a measurement is executed, e.g. using the INITiate[:​IMMediate] command.

Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that. Any other active windows are closed.

Use the LAYout commands to change the display (see "Configuring the Result Display").

Usage: | Event
Manual operation: | See "CCDF"


Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance)

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance)
Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance)

The following commands are required to configure the WLAN IQ measurement described in "WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance)".

Contents
  • Signal Description
  • Configuring the Data Input and Output
  • Frontend Configuration
  • Signal Capturing
  • Synchronization and OFDM Demodulation
  • Tracking and Channel Estimation
  • Demodulation
  • Evaluation Range
  • Limits
  • Automatic Settings
  • Sweep Settings


Signal Description

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Description
Signal Description

The signal description provides information on the expected input signal.

Useful commands for describing the WLAN signal described elsewhere:
  • [SENSe:​]FREQuency:​CENTer
Remote commands exclusive to describing the WLAN signal:
List of Commands
CONFigure:STANdard
CALCulate:LIMit:TOLerance


CONFigure:STANdard

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Description > CONFigure:STANdard
CONFigure:STANdard <Standard>

This remote control command specifies which WLAN standard the option is configured to measure.

The availability of many commands depends on the selected standard!

Parameters:
<Standard>
0

IEEE 802.11a

1

IEEE 802.11b

4

IEEE 802.11g

6 | 7

IEEE 802.11n

8

IEEE 802.11ac

9

IEEE 802.11p

*RST: 0
Manual operation: See "Standard"


CALCulate:LIMit:TOLerance

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Description > CALCulate:LIMit:TOLerance
CALCulate:LIMit:TOLerance <Limit>

This command defines or queries the tolerance limit to be used for the measurement. The required tolerance limit depends on the used standard.

Parameters:
<Limit>
PRIOR11_2012 | STD11_2012 | P11ACD5_1
PRIOR11_2012

Tolerance limits are based on the IEEE 802.11 specification prior to 2012.

Default for OFDM standards (except 802.11ac).

STD11_2012

Tolerance limits are based on the IEEE 802.11 specification from 2012.

Required for DSSS standards. Also possible for OFDM standards (except 802.11ac).

P11ACD5_1

Tolerance limits are based on the IEEE 802.11ac specification.

Required by IEEE 802.11ac standard.

*RST: STD11_2012
Manual operation: See "Tolerance Limit"


Configuring the Data Input and Output

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output
Configuring the Data Input and Output
Contents
  • RF Input
  • Configuring Digital I/Q Input and Output
  • Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
  • Configuring the Outputs


RF Input

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IMPedance
INPut:SELect


INPut:ATTenuation:PROTection:RESet

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

The command works only if the overload condition has been eliminated first.

For details on the protection mechanism see "RF Input Protection".

Usage: Event


INPut:COUPling

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:IMPedance

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > RF Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"
See "Unit"


INPut:SELect

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Tip: The I/Q data to be analyzed for WLAN 802.11 can not only be measured by the WLAN application itself, it can also be imported to the application, provided it has the correct format. Furthermore, the analyzed I/Q data from the WLAN application can be exported for further analysis in external applications. See "Import/Export Functions" .

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Radio Frequency State"
See "Digital I/Q Input State"
See "Analog Baseband Input State"


Configuring Digital I/Q Input and Output

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output
Configuring Digital I/Q Input and Output
Useful commands for digital I/Q data described elsewhere:
  • INP:SEL DIQ (see INPut:​SELect)
  • TRIGger[:​SEQuence]:​LEVel:​BBPower
Remote commands for the R&S DigIConf software

Remote commands for the R&S DigIConf software always begin with SOURce:EBOX. Such commands are passed on from the R&S FSW to the R&S DigIConf automatically which then configures the R&S EX-IQ-BOX via the USB connection.

Be sure to connect the R&S EX-IQ-BOX to the R&S FSW via USB, not via LAN!

All remote commands available for configuration via the R&S DigIConf software are described in the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Example 1:

SOURce:EBOX:*RST

SOURce:EBOX:*IDN?

Result:

"Rohde&Schwarz,DigIConf,02.05.436 Build 47"

Example 2:

SOURce:EBOX:USER:CLOCk:REFerence:FREQuency 5MHZ

Defines the frequency value of the reference clock.

Remote commands exclusive to digital I/Q data input and output
List of Commands
INPut:DIQ:CDEVice
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO


INPut:DIQ:CDEVice

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:CDEVice
INPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q input from the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<SampleRate>

Maximum or currently used sample rate of the connected device in Hz (depends on the used connection protocol version; indicated by <SampleRateType> parameter)

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<SampleRateType>
0

Maximum sample rate is displayed

1

Current sample rate is displayed

<FullScaleLevel>

The level (in dBm) that should correspond to an I/Q sample with the magnitude "1" (if transferred from connected device);

If not available, 9.97e37 is returned

Example: INP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Connected Instrument"


INPut:DIQ:RANGe[:UPPer]:AUTO

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:AUTO <State>

If enabled, the digital input full scale level is automatically set to the value provided by the connected device (if available).

This command is only available if the optional Digital Baseband interface (option R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe:COUPling

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe:COUPling <State>

If enabled, the reference level for digital input is adjusted to the full scale level automatically if the full scale level changes.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Adjust Reference Level to Full Scale Level"


INPut:DIQ:RANGe[:UPPer]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer] <Level>

Defines or queries the "Full Scale Level", i.e. the level that corresponds to an I/Q sample with the magnitude "1".

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
<numeric value>
Range: | 1 μV to 7.071 V
*RST: | 1 V
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe[:UPPer]:UNIT

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:RANGe[:UPPer]:UNIT <Unit>

Defines the unit of the full scale level (see "Full Scale Level"). The availability of units depends on the measurement application you are using.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
VOLT | DBM | DBPW | WATT | DBMV | DBUV | DBUA | AMPere
*RST: Volt
Manual operation: See "Full Scale Level"


INPut:DIQ:SRATe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe
INPut:DIQ:SRATe <SampleRate>

This command specifies or queries the sample rate of the input signal from the Digital Baseband Interface (R&S FSW-B17, see "Input Sample Rate").

Parameters:
<SampleRate>
Range: | 1 Hz to 10 GHz
*RST: | 32 MHz
Example:

INP:DIQ:SRAT 200 MHz

Manual operation: See "Input Sample Rate"


INPut:DIQ:SRATe:AUTO

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe:AUTO
INPut:DIQ:SRATe:AUTO <State>

If enabled, the sample rate of the digital I/Q input signal is set automatically by the connected device.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Input Sample Rate"


Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

The following commands are required to control the Analog Baseband Interface (R&S FSW-B71) in a remote environment.They are only available if this option is installed.

For more information on the Analog Baseband Interface see "Processing Data From the Analog Baseband Interface" .

Useful commands for Analog Baseband data described elsewhere:
  • INP:SEL AIQ (see INPut:​SELect)
  • [SENSe:​]FREQuency:​CENTer
For calibration:
  • DIAGnostic:​SERVice:​INPut[:​SELect]
  • DIAGnostic:​SERVice:​INPut:​AIQ[:​TYPE]
Remote commands exclusive to Analog Baseband data input and output
List of Commands
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
[SENSe:]PROBe<ch>:SETup:CMOFfset
TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?


INPut:IQ:BALanced[:STATe]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:BALanced[:STATe]
INPut:IQ:BALanced[:STATe] <State>

This command defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Parameters:
<State>
ON

Differential

OFF

Simple-ended

*RST: ON
Example: INP:IQ:BAL OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Input configuration"


INPut:IQ:FULLscale:AUTO

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale:AUTO <State>

This command defines whether the full scale level (i.e. the maximum input power on the Baseband Input connector) is defined automatically according to the reference level, or manually.

Parameters:
<State>
ON

Automatic definition

OFF

Manual definition according to INPut:​IQ:​FULLscale[:​LEVel]

*RST: ON
Example: INP:IQ:FULL:AUTO OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


INPut:IQ:FULLscale[:LEVel]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale[:LEVel]
INPut:IQ:FULLscale[:LEVel] <PeakVoltage>

This command defines the peak voltage at the Baseband Input connector if the full scale level is set to manual mode (see INPut:​IQ:​FULLscale:​AUTO).

Parameters:
<PeakVoltage>
0.25 V | 0.5 V | 1 V | 2 V

Peak voltage level at the connector.

For probes, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

*RST: 1V
Example: INP:IQ:FULL 0.5V
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


INPut:IQ:TYPE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:TYPE
INPut:IQ:TYPE <DataType>

This command defines the format of the input signal.

Parameters:
<DataType>
IQ | I | Q
IQ

The input signal is filtered and resampled to the sample rate of the application.

Two input channels are required for each input signal, one for the in-phase component, and one for the quadrature component.

I

The in-phase component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0 (see [SENSe:​]FREQuency:​CENTer), the in-phase component of the input signal is down-converted first (Low IF I).

Q

The quadrature component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0, the quadrature component of the input signal is down-converted first (Low IF Q).

*RST: IQ
Example:

INP:IQ:TYPE Q

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "I/Q Mode"


CALibration:AIQ:DCOFfset:I

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:I <Offset>

This command defines a DC offset of the I input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:I 0.001


CALibration:AIQ:DCOFfset:Q

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:Q
CALibration:AIQ:DCOFfset:Q <Offset>

This command defines a DC offset of the Q input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:Q 0.001


[SENSe:]PROBe<ch>:SETup:CMOFfset

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > [SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<ch>:SETup:CMOFfset <CMOffset>

Sets the common mode offset. The setting is only available if a differential probe is connected to the R&S FSW.

If the probe is disconnected, the common mode offset of the probe is reset to 0.0 V.

For details see "Common Mode Offset" .

Suffix:
<ch>
1..4

Selects the input channel.

Parameters:
<CMOffset>
Range: | -100E+24 to 100E+24
Increment: | 1E-3
*RST: | 0
Default unit: | V


TRACe:IQ:APCon[:STATe]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon[:STATe] <State>

If enabled, the average power consumption is calculated at the end of the I/Q data measurement. This command must be set before the measurement is performed!

The conversion factors A and B for the calculation are defined using TRACe:​IQ:​APCon:​A and TRACe:​IQ:​APCon:​B.

The results can be queried using TRACe:​IQ:​APCon:​RESult?.

For details see "Average Power Consumption" .

Parameters:
<State>
ON | OFF
*RST: OFF
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:A

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:A
TRACe:IQ:APCon:A <ConvFact>

Defines the conversion factor A for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 1.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:B

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:B
TRACe:IQ:APCon:B <ConvFact>

Defines the conversion factor B for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 0.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:RESult?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon:RESult?

Queries the average power consumption for an analog baseband input. This value is only calculated at the end of the I/Q data measurement if the TRACe:​IQ:​APCon[:​STATe] command is set to ON before the measurement is performed!

For details see "Average Power Consumption" .

Parameters:
<Average>
numeric value
Default unit: W
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?
Usage: Query only


Configuring the Outputs

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring the Outputs
Configuring the Outputs

Configuring trigger input/output is described in "Configuring the Trigger Output".

List of Commands
DIAGnostic:SERVice:NSOurce
OUTPut:IF:IFFRequency


DIAGnostic:SERVice:NSOurce

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring the Outputs > DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:NSOurce <State>

This command turns the 28 V supply of the BNC connector labeled NOISE SOURCE CONTROL on the front panel on and off.

For details see "Input from Noise Sources".

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DIAG:SERV:NSO ON
Manual operation: See "Noise Source"


OUTPut:IF:IFFRequency

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Configuring the Data Input and Output > Configuring the Outputs > OUTPut:IF:IFFRequency
OUTPut:IF:IFFRequency <Frequency>

This command defines the frequency for the IF output. The IF frequency of the signal is converted accordingly.

This command is available in the time domain and if the IF/VIDEO/DEMOD output is configured for IF.

Parameters:
<Frequency>
*RST: 50.0 MHz


Frontend Configuration

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration
Frontend Configuration

The following commands configure frequency, amplitude and y-axis scaling settings, which represent the "frontend" of the measurement setup.

Contents
  • Frequency
  • Amplitude Settings


Frequency

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Frequency
Frequency
List of Commands
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet


[SENSe:]FREQuency:CENTer

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Frequency"
See "Center Frequency"
See "Center frequency"


[SENSe:]FREQuency:CENTer:STEP

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

You can increase or decrease the center frequency quickly in fixed steps using the SENS:FREQ UP AND SENS:FREQ DOWN commands, see [SENSe:​]FREQuency:​CENTer.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:AUTO

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:AUTO <State>

This command couples or decouples the center frequency step size to the span.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: FREQ:CENT:STEP:AUTO ON

Activates the coupling of the step size to the span.


[SENSe:]FREQuency:OFFSet

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Frequency > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

See also "Frequency Offset".

Note: In MSRA mode, the setting command is only available for the MSRA Master. For MSRA applications, only the query command is available.

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed
Manual operation: See "Frequency Offset"


Amplitude Settings

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Amplitude Settings
Amplitude Settings

The following commands are required to configure the amplitude settings in a remote environment.

Useful commands for amplitude settings described elsewhere:
  • INPut:​COUPling
  • INPut:​IMPedance
  • [SENSe:​]ADJust:​LEVel
Remote commands exclusive to amplitude settings:
List of Commands
CALCulate<n>:UNIT:POWer
CONFigure:POWer:AUTO
CONFigure:POWer:EXPected:RF
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:GAIN[:VALue]
INPut:GAIN:STATe


CALCulate<n>:UNIT:POWer

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Amplitude Settings > CALCulate<n>:UNIT:POWer
CALCulate<n>:UNIT:POWer <Unit>

This command selects the unit of the y-axis.

The unit applies to all measurement windows.

Parameters:
<Unit>
DBM | V | A | W | DBPW | WATT | DBUV | DBMV | VOLT | DBUA | AMPere
*RST: dBm
Example: CALC:UNIT:POW DBM

Sets the power unit to dBm.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Unit"


CONFigure:POWer:AUTO

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Amplitude Settings > CONFigure:POWer:AUTO
CONFigure:POWer:AUTO <Mode>

This command is used to switch on or off automatic power level detection. When switched on, power level detection is performed at the start of each measurement sweep.

Parameters:
<Mode>
ON | OFF | ONCE
*RST: ON
Manual operation: See "Setting the Reference Level Automatically (Auto Level)"


CONFigure:POWer:EXPected:RF

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Amplitude Settings > CONFigure:POWer:EXPected:RF
CONFigure:POWer:EXPected:RF <Value>

This command specifies the mean power level of the source signal as supplied to the instrument's RF input. This value is overwritten if "Auto Level" mode is turned on.

Parameters:
<Value>
Default unit: DBM
Manual operation: See "Signal Level (RMS)"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Shifting the Display (Offset)"


INPut:ATTenuation

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Amplitude Settings > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If an electronic attenuator is available and active, the command defines a mechanical attenuation (see INPut:​EATT:​STATe).

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Amplitude Settings > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Amplitude Settings > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This command is only available with option R&S FSW-B25.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Amplitude Settings > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

This command is only available with option R&S FSW-B25.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Amplitude Settings > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

This command is only available with option R&S FSW-B25.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:GAIN[:VALue]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Amplitude Settings > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN:STATe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Frontend Configuration > Amplitude Settings > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


Signal Capturing

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing
Signal Capturing

The following commands are required to configure how much and how data is captured from the input signal.

Contents
  • General Capture Settings
  • Configuring Triggered Measurements
  • MIMO Capture Settings


General Capture Settings

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > General Capture Settings
General Capture Settings
List of Commands
[SENSe:]BANDwidth[:RESolution]:FILTer[:STATe]
[SENSe:]SWAPiq
[SENSe:]SWEep:TIME
TRACe:IQ:SRATe


[SENSe:]BANDwidth[:RESolution]:FILTer[:STATe]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > General Capture Settings > [SENSe:]BANDwidth[:RESolution]:FILTer[:STATe]
[SENSe:]BANDwidth[:RESolution]:FILTer[:STATe] <State>

This remote control command enables or disables use of the adjacent channel filter.

If activated, only the useful signal is analyzed, all signal data in adjacent channels is removed by the filter. This setting improves the signal to noise ratio and thus the EVM results for signals with strong or a large number of adjacent channels. However, for some measurements information on the effects of adjacent channels on the measured signal may be of interest.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Manual operation: See "Suppressing (Filter out) Adjacent Channels (IEEE 802.11a, g (OFDM), ac, n, p)"


[SENSe:]SWAPiq

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > General Capture Settings > [SENSe:]SWAPiq
[SENSe:]SWAPiq <State>

This command defines whether or not the recorded IQ pairs should be swapped (I<->Q) before being processed. Swapping I and Q inverts the sideband.

This is useful if the DUT interchanged the I and Q parts of the signal; then the R&S FSW can do the same to compensate for it.

For GSM measurements: Try this function if the TSC can not be found.

Parameters:
<State>
ON

I and Q signals are interchanged

Inverted sideband, Q+j*I

OFF

I and Q signals are not interchanged

Normal sideband, I+j*Q

*RST: OFF
Manual operation: See "Swap I/Q"


[SENSe:]SWEep:TIME

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > General Capture Settings > [SENSe:]SWEep:TIME
[SENSe:]SWEep:TIME <Time>

This command defines the sweep (or: data capture) time.

Parameters:
<Time>
refer to data sheet
*RST: depends on current settings (determined automatically)
Example: SWE:TIME 10s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Capture Time"


TRACe:IQ:SRATe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > General Capture Settings > TRACe:IQ:SRATe
TRACe:IQ:SRATe <SampleRate>

This command sets the final user sample rate for the acquired I/Q data. Thus, the user sample rate can be modified without affecting the actual data capturing settings on the R&S FSW.

Note: The smaller the user sample rate, the smaller the usable I/Q bandwidth, see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

Parameters:
<SampleRate>

The valid sample rates are described in "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

Range: | 100 Hz to 10 GHz continuously adjustable;
*RST: | 32 MHz
Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Input Sample Rate"


Configuring Triggered Measurements

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements
Configuring Triggered Measurements

The following commands are required to configure a triggered measurement in a remote environment. The tasks for manual operation are described in "Trigger Settings".

The *OPC command should be used after commands that retrieve data so that subsequent commands to change the selected trigger source are held off until after the sweep is completed and the data has been returned.

Contents
  • Configuring the Triggering Conditions
  • Configuring the Trigger Output


Configuring the Triggering Conditions

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions
Configuring the Triggering Conditions
List of Commands
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger:SEQuence:LEVel:POWer:AUTO
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval


TRIGger[:SEQuence]:BBPower:HOLDoff

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:BBPower:HOLDoff <Period>

This command defines the holding time before the baseband power trigger event.

The command requires the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​IFPower:​HOLDoff command for new remote control programs.

Parameters:
<Period>
Range: | 150 ns to 1000 s
*RST: | 150 ns
Example: TRIG:SOUR BBP

Sets the baseband power trigger source.

TRIG:BBP:HOLD 200 ns

Sets the holding time to 200 ns.


TRIGger[:SEQuence]:DTIMe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:DTIMe <DropoutTime>

Defines the time the input signal must stay below the trigger level before a trigger is detected again.

Parameters:
<DropoutTime>

Dropout time of the trigger.

Range: | 0 s to 10.0 s
*RST: | 0 s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Drop-Out Time"


TRIGger[:SEQuence]:HOLDoff[:TIME]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

Parameters:
<Offset>
*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:IFPower:HOLDoff

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HOLDoff <Period>

This command defines the holding time before the next trigger event.

Note that this command can be used for any trigger source, not just IF Power (despite the legacy keyword).

Parameters:
<Period>
Range: | 0 s to 10 s
*RST: | 0 s
Example: TRIG:SOUR EXT

Sets an external trigger source.

TRIG:IFP:HOLD 200 ns

Sets the holding time to 200 ns.

Manual operation: See "Trigger Holdoff"


TRIGger[:SEQuence]:IFPower:HYSTeresis

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:IFPower:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis, which is only available for "IF Power" trigger sources.

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
*RST: | 3 dB
Example: TRIG:SOUR IFP

Sets the IF power trigger source.

TRIG:IFP:HYST 10DB

Sets the hysteresis limit value.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Hysteresis"


TRIGger[:SEQuence]:LEVel:BBPower

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:BBPower <Level>

This command sets the level of the baseband power trigger.

This command is available for the Digital Baseband Interface (R&S FSW-B17) and the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<Level>
Range: | -50 dBm to +20 dBm
*RST: | -20 dBm
Example: TRIG:LEV:BB -30DBM
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

Note that the variable INPUT/OUTPUT connectors (ports 2+3) must be set for use as input using the OUTPut:​TRIGger<port>:​DIRection command.

For details on the trigger source see "Trigger Source Settings".

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V
Manual operation: See "Trigger Level (Repetition interval)"


TRIGger[:SEQuence]:LEVel:IFPower

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IFPower <TriggerLevel>

This command defines the power level at the third intermediate frequency that must be exceeded to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

For details on the trigger settings see "Trigger Source Settings".

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -10 dBm
Example: TRIG:LEV:IFP -30DBM
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Level (Repetition interval)"


TRIGger[:SEQuence]:LEVel:IQPower

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:IQPower <TriggerLevel>

This command defines the magnitude the I/Q data must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

For details on the trigger source see "Trigger Source Settings".

Parameters:
<TriggerLevel>
Range: | -130 dBm to 30 dBm
*RST: | -20 dBm
Example: TRIG:LEV:IQP -30DBM
Example:

See "Basic I/Q Analysis with Improved Performance" .

Manual operation: See "Trigger Level (Repetition interval)"


TRIGger:SEQuence:LEVel:POWer:AUTO

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger:SEQuence:LEVel:POWer:AUTO
TRIGger:SEQuence:LEVel:POWer:AUTO <State>

By default, the optimum trigger level for power triggers is automatically measured and determined at the start of each sweep (for Modulation Accuracy, Flatness, Tolerance... measurements).

This function is only considered for TRIG:SEQ:SOUR IFP and TRIG:SEQ:SOUR RFP, see TRIGger[:​SEQuence]:​SOURce

In order to define the trigger level manually, switch this function off and define the level using TRIGger[:​SEQuence]:​LEVel:​IFPower or TRIGger[:​SEQuence]:​LEVel:​RFPower.

Parameters for setting and query:
<State>
OFF

Switches the auto level detection function off

ON

Switches the auto level detection function on

*RST: ON
Manual operation: See "Trigger Level Mode"


TRIGger[:SEQuence]:LEVel:RFPower

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:RFPower <TriggerLevel>

This command defines the power level the RF input must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

The input signal must be between 500 MHz and 8 GHz.

For details on the trigger source see "Trigger Source Settings".

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -20 dBm
Example: TRIG:LEV:RFP -30dBm


TRIGger[:SEQuence]:SLOPe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

For details on the available trigger sources see "Trigger Source Settings".

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

Not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

IFPower

Second intermediate frequency

Not available for input from the Digital Baseband Interface (R&S FSW-B17). For input from the Analog Baseband Interface (R&S FSW-B71), this parameter is interpreted as BBPower for compatibility reasons.

IQPower

Magnitude of sampled I/Q data

For applications that process I/Q data, such as the I/Q Analyzer or optional applications.

Not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

TIME

Time interval

BBPower

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17)

Baseband power (for digital input via the Digital Baseband Interface R&S FSW-B17 or the Analog Baseband interface R&S FSW-B71)

PSEN

External power sensor

GP0 | GP1 | GP2 | GP3 | GP4 | GP5

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available.

Defines triggering of the measurement directly via the LVDS connector. The parameter specifies which general purpose bit (0 to 5) will provide the trigger data.

The assignment of the general purpose bits used by the Digital IQ trigger to the LVDS connector pins is provided in "Digital I/Q".

TUNit

If activated, the measurement is triggered by a connected R&S FS-Z11 trigger unit, simultaneously for all connected analyzers.

For details see "Trigger Synchronization Using an R&S FS-Z11 Trigger Unit".

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example" .

Manual operation: See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "I/Q Power"
See "RF Power"
See "Time"
See "Power Sensor"
See "IF Power/BB Power"
See "Digital I/Q"
See "FS-Z11 Trigger"


TRIGger[:SEQuence]:TIME:RINTerval

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:TIME:RINTerval
TRIGger[:SEQuence]:TIME:RINTerval <Interval>

This command defines the repetition interval for the time trigger.

Parameters:
<Interval>
2.0 ms to 5000
Range: | 2 ms to 5000 s
*RST: | 1.0 s
Example: TRIG:SOUR TIME

Selects the time trigger input for triggering.

TRIG:TIME:RINT 50

The sweep starts every 50 s.


Configuring the Trigger Output

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Trigger Output
Configuring the Trigger Output

The following commands are required to send the trigger signal to one of the variable TRIGGER INPUT/OUTPUT connectors. The tasks for manual operation are described in "Trigger 2/3".

List of Commands
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth


OUTPut:TRIGger<port>:DIRection

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:DIRection <Direction>

This command selects the trigger direction.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Direction>
INPut

Port works as an input.

OUTPut

Port works as an output.

*RST: INPut
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"


OUTPut:TRIGger<port>:LEVel

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:LEVel <Level>

This command defines the level of the signal generated at the trigger output.

This command works only if you have selected a user defined output with OUTPut:​TRIGger<port>:​OTYPe.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Level>
HIGH

TTL signal.

LOW

0 V

*RST: LOW
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"
See "Level"


OUTPut:TRIGger<port>:OTYPe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:OTYPe <OutputType>

This command selects the type of signal generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<OutputType>
DEVice

Sends a trigger signal when the R&S FSW has triggered internally.

TARMed

Sends a trigger signal when the trigger is armed and ready for an external trigger event.

UDEFined

Sends a user defined trigger signal. For more information see OUTPut:​TRIGger<port>:​LEVel.

*RST: DEVice
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Output Type"


OUTPut:TRIGger<port>:PULSe:IMMediate

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:IMMediate

This command generates a pulse at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: Event
Manual operation: See "Send Trigger"


OUTPut:TRIGger<port>:PULSe:LENGth

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:TRIGger<port>:PULSe:LENGth <Length>

This command defines the length of the pulse generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Length>

Pulse length in seconds.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Pulse Length"


MIMO Capture Settings

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > MIMO Capture Settings
MIMO Capture Settings

The following commands are only available for IEEE 802.11ac, n standards.

Useful commands for defining MIMO capture settings described elsewhere:
  • CALCulate<n>:​BURSt[:​IMMediate]
Remote commands exclusive to defining MIMO capture settings:
List of Commands
CONFigure:WLAN:ANTMatrix:ADDRess<add>
CONFigure:WLAN:ANTMatrix:ANTenna<Analyzer>
CONFigure:WLAN:ANTMatrix:STATe<state>
CONFigure:WLAN:DUTConfig
CONFigure:WLAN:MIMO:CAPTure
CONFigure:WLAN:MIMO:CAPTure:BUFFer
CONFigure:WLAN:MIMO:CAPTure:TYPE
CONFigure:WLAN:MIMO:OSP:ADDRess
CONFigure:WLAN:MIMO:OSP:MODule
CONFigure:WLAN:RSYNc:JOINed


CONFigure:WLAN:ANTMatrix:ADDRess<add>

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > MIMO Capture Settings > CONFigure:WLAN:ANTMatrix:ADDRess<add>
CONFigure:WLAN:ANTMatrix:ADDRess<add> <Address>

This remote control command specifies the TCP/IP address for each receiver path in IPV4 format. Note, it is not possible to set the IP address of ANTMatrix1 (Master)

Parameters:
<Address> | TCP/IP address in IPV4 format
Manual operation: | See "Analyzer IP Address"


CONFigure:WLAN:ANTMatrix:ANTenna<Analyzer>

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > MIMO Capture Settings > CONFigure:WLAN:ANTMatrix:ANTenna<Analyzer>
CONFigure:WLAN:ANTMatrix:ANTenna<Analyzer> <Antenna>

This remote control command specifies the antenna assignment of the receive path.

Parameters:
<Antenna> | ANTenna1 | ANTenna2 | ANTenna3 | ANTenna4 Antenna assignment of the receiver path
Example: | CONF:WLAN:ANTM:ANT2 ANT1 Analyzer number 2 measures antenna no. 1 CONF:WLAN:ANTM;ANT4 ANT2 Analyzer number 42 measures antenna no. 2
Manual operation: | See "Assignment"


CONFigure:WLAN:ANTMatrix:STATe<state>

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > MIMO Capture Settings > CONFigure:WLAN:ANTMatrix:STATe<state>
CONFigure:WLAN:ANTMatrix:STATe<state> <State>

This remote control command specifies the state of the receive path. Note, it is not possible to set the state of ANTMatrix1 (Master).

Parameters:
<State> | ON | OFF State of the receive path
Manual operation: | See "State"


CONFigure:WLAN:DUTConfig

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > MIMO Capture Settings > CONFigure:WLAN:DUTConfig
CONFigure:WLAN:DUTConfig <NoOfAnt>

This remote control command specifies the number of antennas used for MIMO measurement.

Parameters:
<NoOfAnt>
TX1 | TX2 | TX3 | TX4 | TX5 | TX6 | TX7 | TX8

TX1: one antenna,

TX2: two antennas etc.

*RST: TX1
Example: CONF:WLAN:DUTC TX1
Manual operation: See "DUT MIMO Configuration"


CONFigure:WLAN:MIMO:CAPTure

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > MIMO Capture Settings > CONFigure:WLAN:MIMO:CAPTure
CONFigure:WLAN:MIMO:CAPTure <SignalPath>

Specifies the signal path to be captured in MIMO sequential manual measurements. Subsequently, use the INITiate[:​IMMediate] command to start capturing data.

Parameters:
<SignalPath>
RX1 | RX2 | RX3 | RX4 | RX5 | RX6 | RX7 | RX8

For details see "Manual Sequential MIMO Data Capture".

*RST: RX1
Example: CONFigure:WLAN:MIMO:CAPTure RX2
INIT:IMM

Starts capturing data from the receive antenna number 2.

Manual operation: See "Single / Cont."


CONFigure:WLAN:MIMO:CAPTure:BUFFer

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > MIMO Capture Settings > CONFigure:WLAN:MIMO:CAPTure:BUFFer
CONFigure:WLAN:MIMO:CAPTure:BUFFer <SignalPath>

Specifies the signal path to be captured in MIMO sequential manual measurements and immediately starts capturing data.

Parameters:
<SignalPath>
RX1 | RX2 | RX3 | RX4 | RX5 | RX6 | RX7 | RX8

For details see "Manual Sequential MIMO Data Capture".

*RST: RX1
Example: CONFigure:WLAN:MIMO:CAPTure:BUFFer RX2

Starts capturing data from the receive antenna number 2.


CONFigure:WLAN:MIMO:CAPTure:TYPE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > MIMO Capture Settings > CONFigure:WLAN:MIMO:CAPTure:TYPE
CONFigure:WLAN:MIMO:CAPTure:TYPE <Method>

Specifies the method used to analyze MIMO signals.

Parameters:
<Method>
SIMultaneous | OSP | MANual
SIMultaneous

Simultaneous normal MIMO operation

OSP

Sequential using open switch platform

MANual

Sequential using manual operation

*RST: SIM
Manual operation: See "MIMO Antenna Signal Capture Setup"
See "Manual Sequential MIMO Data Capture"


CONFigure:WLAN:MIMO:OSP:ADDRess

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > MIMO Capture Settings > CONFigure:WLAN:MIMO:OSP:ADDRess
CONFigure:WLAN:MIMO:OSP:ADDRess <Address>

Specifies the TCP/IP address of the switch unit to be used for automated sequential MIMO measurements. The supported unit is Rohde & Schwarz OSP 1505.3009.03 with module option 1505.5101.02

Parameters:
<Address> |
Manual operation: | See "OSP IP Address"


CONFigure:WLAN:MIMO:OSP:MODule

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > MIMO Capture Settings > CONFigure:WLAN:MIMO:OSP:MODule
CONFigure:WLAN:MIMO:OSP:MODule <ID>

Specifies the module of the switch unit to be used for automated sequential MIMO measurements. The supported unit is Rohde & Schwarz OSP 1505.3009.03 with module option 1505.5101.02

Parameters:
<ID> | A11 | A12 | A13
Manual operation: | See "OSP Switch Bank Configuration"


CONFigure:WLAN:RSYNc:JOINed

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Signal Capturing > MIMO Capture Settings > CONFigure:WLAN:RSYNc:JOINed
CONFigure:WLAN:RSYNc:JOINed <State>

This command configures how PPDU synchronization and tracking is performed for multiple antennas.

Parameters:
<State>
ON | OFF
ON

RX antennas are synchronized and tracked together.

OFF

RX antennas are synchronized and tracked separately.

*RST: OFF
Manual operation: See "Joined RX Sync and Tracking"


Synchronization and OFDM Demodulation

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Synchronization and OFDM Demodulation
Synchronization and OFDM Demodulation
List of Commands
[SENSe:]DEMod:FFT:OFFSet
[SENSe:]DEMod:TXARea


[SENSe:]DEMod:FFT:OFFSet

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Synchronization and OFDM Demodulation > [SENSe:]DEMod:FFT:OFFSet
[SENSe:]DEMod:FFT:OFFSet <Mode>

This command specifies the start offset of the FFT for OFDM demodulation (not for the FFT Spectrum display).

Parameters:
<Mode>
AUTO | GICenter | PEAK
AUTO

The FFT start offset is automatically chosen to minimize the intersymbol interference.

GICenter

Guard Interval Center: The FFT start offset is placed to the center of the guard interval.

PEAK

The peak of the fine timing metric is used to determine the FFT start offset.

*RST: AUTO
Manual operation: See "FFT Start Offset"


[SENSe:]DEMod:TXARea

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Synchronization and OFDM Demodulation > [SENSe:]DEMod:TXARea
[SENSe:]DEMod:TXARea <State>

If enabled, the R&S FSW WLAN application initially performs a coarse burst search on the input signal in which increases in the power vs time trace are detected. Further time-consuming processing is then only performed where bursts are assumed. This improves the measurement speed for signals with low duty cycle rates.

However, for signals in which the PPDU power levels differ significantly, this option should be disabled as otherwise some PPDUs may not be detected.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

A coarse burst search is performed based on the power levels of the input signal.

OFF | 0

No pre-evaluation is performed, the entire signal is processed.

*RST: 1
Manual operation: See "Power Interval Search"


Tracking and Channel Estimation

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Tracking and Channel Estimation
Tracking and Channel Estimation
List of Commands
[SENSe:]DEMod:CESTimation
[SENSe:]TRACking:IQMComp
[SENSe:]TRACking:LEVel
[SENSe:]TRACking:PHASe
[SENSe:]TRACking:PILots
[SENSe:]TRACking:TIME


[SENSe:]DEMod:CESTimation

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Tracking and Channel Estimation > [SENSe:]DEMod:CESTimation
[SENSe:]DEMod:CESTimation <State>

This command defines whether channel estimation will be done in preamble and payload or only in preamble. The effect of this is most noticeable for the EVM measurement results, where the results will be improved when this feature is enabled.

However, this functionality is not supported by the IEEE 802.11 standard and must be disabled if the results are to be measured strictly according to the standard.

Parameters:
<State>
ON | OFF
ON

The channel estimation is performed in the preamble and the payload. The EVM results can be calculated more accurately.

OFF

The channel estimation is performed in the preamble as required in the standard.

*RST: OFF
Manual operation: See "Channel Estimation Range"


[SENSe:]TRACking:IQMComp

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Tracking and Channel Estimation > [SENSe:]TRACking:IQMComp
[SENSe:]TRACking:IQMComp <State>

Activates or deactivates the compensation for I/Q mismatch (gain imbalance, quadrature offset, I/Q skew, see "I/Q Mismatch").

This setting is not available for standards IEEE 802.11b and g (DSSS).

Parameters:
<State>
ON | OFF
ON

Compensation for gain imbalance, quadrature offset, and I/Q skew impairments is applied.

OFF

Compensation is not applied; this setting is required for measurements strictly according to the IEEE 802.11-2012, IEEE P802.11ac/D5.0 WLAN standard

*RST: OFF
Manual operation: See "I/Q Mismatch Compensation"


[SENSe:]TRACking:LEVel

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Tracking and Channel Estimation > [SENSe:]TRACking:LEVel
[SENSe:]TRACking:LEVel <State>

Activates or deactivates the compensation for level variations within a single PPDU. If activated, the measurement results are compensated for level error on a per-symbol basis.

For details see "Tracking the phase drift, timing jitter and gain".

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Level Error (Gain) Tracking"


[SENSe:]TRACking:PHASe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Tracking and Channel Estimation > [SENSe:]TRACking:PHASe
[SENSe:]TRACking:PHASe <State>

Activates or deactivates the compensation for phase drifts. If activated, the measurement results are compensated for phase drifts on a per-symbol basis.

For details see "Tracking the phase drift, timing jitter and gain".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Manual operation: See "Phase Tracking"


[SENSe:]TRACking:PILots

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Tracking and Channel Estimation > [SENSe:]TRACking:PILots
[SENSe:]TRACking:PILots <Mode>

In case tracking is used, the used pilot sequence has an effect on the measurement results.

For details see "Tracking the phase drift, timing jitter and gain".

Parameters:
<Mode>
STANdard | DETected
STANdard

The pilot sequence is determined according to the corresponding WLAN standard. In case the pilot generation algorithm of the device under test (DUT) has a problem, the non-standard-conform pilot sequence might affect the measurement results, or the WLAN application might not synchronize at all onto the signal generated by the DUT.

DETected

The pilot sequence detected in the WLAN signal to be analyzed is used by the WLAN application. In case the pilot generation algorithm of the device under test (DUT) has a problem, the non-standard-conform pilot sequence will not affect the measurement results. In case the pilot sequence generated by the DUT is correct, it is recommended that you use the "According to Standard" setting because it generates more accurate measurement results.

*RST: STANdard
Manual operation: See "Pilots for Tracking"


[SENSe:]TRACking:TIME

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Tracking and Channel Estimation > [SENSe:]TRACking:TIME
[SENSe:]TRACking:TIME <State>

Activates or deactivates the compensation for timing drift. If activated, the measurement results are compensated for timing error on a per-symbol basis.

For details see "Tracking the phase drift, timing jitter and gain".

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Timing Error Tracking"


Demodulation

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation
Demodulation

The demodulation settings define which PPDUs are to be analyzed, thus they define a logical filter.

The available demodulation settings vary depending on the selected digital standard (see CONFigure:​STANdard).

Manual configuration is described in "Demodulation".

List of Commands
CONFigure:WLAN:EXTension:AUTO:TYPE
CONFigure:WLAN:GTIMe:AUTO
CONFigure:WLAN:GTIMe:AUTO:TYPE
CONFigure:WLAN:GTIMe:SELect
CONFigure:WLAN:SMAPping:MODE
CONFigure:WLAN:SMAPping:NORMalise
CONFigure:WLAN:SMAPping:TX<ch>
CONFigure:WLAN:SMAPping:TX<ch>:STReam<stream>
CONFigure:WLAN:SMAPping:TX<ch>:TIMeshift
CONFigure:WLAN:STBC:AUTO:TYPE
[SENSe:]BANDwidth:CHANnel:AUTO:TYPE
[SENSe:]DEMod:FORMat:BANalyze
[SENSe:]DEMod:FORMat:BANalyze:BTYPe:AUTO:TYPE
[SENSe:]DEMod:FORMat[:BCONtent]:AUTO
[SENSe:]DEMod:FORMat:MCSindex
[SENSe:]DEMod:FORMat:MCSindex:MODE
[SENSe:]DEMod:FORMat:NSTSindex
[SENSe:]DEMod:FORMat:NSTSindex:MODE
[SENSe<n>:]DEMod:FORMat:SIGSymbol


CONFigure:WLAN:EXTension:AUTO:TYPE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > CONFigure:WLAN:EXTension:AUTO:TYPE
CONFigure:WLAN:EXTension:AUTO:TYPE <PPDUType>

Defines the PPDUs taking part in the analysis according to the Ness (Extension Spatial Streams) field content (for IEEE 802.11n standard only).

Parameters:
<PPDUType>
FBURst | ALL | M0 | M1 | M2 | M3 | D0 | D1 | D2 | D3

The first PPDU is analyzed and subsequent PPDUs are analyzed only if they match

FBURst

The Ness field contents of the first PPDU is detected and subsequent PPDUs are analyzed only if they have the same Ness field contents (corresponds to "Auto, same type as first PPDU")

ALL

All recognized PPDUs are analyzed according to their individual Ness field contents (corresponds to "Auto, individually for each PPDU")

M0 | M1 | M2 | M3

Only PPDUs with the specified Ness value are analyzed.

D0 | D1 | D2| D3

All PPDUs are analyzed assuming the specified Ness value.

*RST: FBURst
Example: CONF:WLAN:EXT:AUTO:TYPE M0
Manual operation: See "Extension Spatial Streams (sounding)"


CONFigure:WLAN:GTIMe:AUTO

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > CONFigure:WLAN:GTIMe:AUTO
CONFigure:WLAN:GTIMe:AUTO <State>

This remote control command specifies whether the guard time of the input signal is automatically detected or specified manually (IEEE 802.11n or ac only).

Parameters:
<State>
ON

The guard time is detected automatically according to CONFigure:​WLAN:​GTIMe:​AUTO:​TYPE.

OFF

The guard time is defined by the CONFigure:​WLAN:​GTIMe:​SELect command.

*RST: ON
Manual operation: See "Guard Interval Length"


CONFigure:WLAN:GTIMe:AUTO:TYPE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > CONFigure:WLAN:GTIMe:AUTO:TYPE
CONFigure:WLAN:GTIMe:AUTO:TYPE <Type>

This remote control command specifies which PPDUs are analyzed depending on their guard length if automatic detection is used (CONF:WLAN:GTIM:AUTO ON, see CONFigure:​WLAN:​GTIMe:​AUTO).

This command is available for IEEE 802.11 n, ac standards only.

Note: On previous R&S Signal and Spectrum analyzers, this command configured both the guard interval type and the channel bandwidth. On the R&S FSW, this command only configures the guard type. The channel bandwidth of the PPDU to be measured must be configured separately using the [SENSe:​]BANDwidth:​CHANnel:​AUTO:​TYPE command.

Parameters:
<Type>
FBURst

The Gurad interval length of the first PPDU is detected and subsequent PPDUs are analyzed only if they have the same length (corresponds to "Auto, same type as first PPDU")

ALL

All PPDUs are analyzed regardless of their guard length (corresponds to "Auto, individually for each PPDU").

MS

Only PPDUs with short guard interval length are analyzed.

(corresponds to "Meas only Short" in manual operation; MN8 | MN16 parameters in previous R&S Signal and Spectrum Analyzers)

ML

Only PPDUs with long guard interval length are analyzed.

(corresponds to "Meas only Long" in manual operation; ML16 | ML32 parameters in previous R&S Signal and Spectrum Analyzers)

DS

All PPDUs are demodulated assuming short guard interval length.

(corresponds to "Demod all as short" in manual operation; DN8 | DN16 parameters in previous R&S Signal and Spectrum Analyzers)

DL

All PPDUs are demodulated assuming long guard interval length.

(corresponds to "Demod all as long" in manual operation; DL16 | DL32 parameters in previous R&S Signal and Spectrum Analyzers)

*RST: 'ALL'
Example: CONF:WLAN:GTIM:AUTO:TYPE DL
Manual operation: See "Guard Interval Length"


CONFigure:WLAN:GTIMe:SELect

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > CONFigure:WLAN:GTIMe:SELect
CONFigure:WLAN:GTIMe:SELect <GuardTime>

This remote control command specifies the guard time the PPDUs in the IEEE 802.11n or ac input signal should have. If the guard time is specified to be detected from the input signal using the CONFigure:​WLAN:​GTIMe:​AUTO command then this command is query only and allows the detected guard time to be obtained.

Parameters:
<GuardTime>
SHORt | NORMal
SHORt

Only the PPDUs with short guard interval are analyzed.

NORMal

Only the PPDUs with long guard interval are analyzed.

("Long" in manual operation)

*RST: NORMal
Example: CONF:WLAN:GTIM:SEL SHOR
Manual operation: See "Guard Interval Length"


CONFigure:WLAN:SMAPping:MODE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > CONFigure:WLAN:SMAPping:MODE
CONFigure:WLAN:SMAPping:MODE <Mode>

This remote control command specifies the special mapping mode.

Parameters:
<Mode> | DIRect | SEXPansion | USER DIRect direct SEXPansion expansion USER user defined
Manual operation: | See "Spatial Mapping Mode"


CONFigure:WLAN:SMAPping:NORMalise

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > CONFigure:WLAN:SMAPping:NORMalise
CONFigure:WLAN:SMAPping:NORMalise <State>

This remote control command specifies whether an amplification of the signal power due to the spatial mapping is performed according to the matrix entries. If this command it set to ON then the spatial mapping matrix is scaled by a constant factor to obtain a passive spatial mapping matrix which does not increase the total transmitted power. If this command is set to OFF the normalization step is omitted.

Parameters:
<State> |
Manual operation: | See "Power Normalise"


CONFigure:WLAN:SMAPping:TX<ch>

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > CONFigure:WLAN:SMAPping:TX<ch>
CONFigure:WLAN:SMAPping:TX<ch> <STS I>, <STS Q>{<STS I>,<STS Q>},<TimeShift>

This remote control command specifies the mapping for all streams (real & imaginary data pairs) and timeshift for a specified antenna.

Parameters:
<STS I>

Imag part of the complex element of the STS-Stream

<STS Q>

Real part of the complex element of the STS-Stream

<TimeShift>

Time shift for specification of user defined CSD (cyclic delay diversity) for the Spatial Mapping.

Range: | -32 ns to 32 ns
Default unit: | ns
Example: CONF:WLAN:SMAP:TX 1.0,1.0,2.0,2.0,3.0,3.0,4.0,4.0,1e-9
Manual operation: See "User Defined Spatial Mapping"


CONFigure:WLAN:SMAPping:TX<ch>:STReam<stream>

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > CONFigure:WLAN:SMAPping:TX<ch>:STReam<stream>
CONFigure:WLAN:SMAPping:TX<ch>:STReam<stream> <STS I>, <STS Q>

This remote control command specifies the mapping for a specific stream and antenna.

Parameters:
<STS I> | Imag part of the complex element of the STS-Stream
<STS Q> | Real part of the complex element of the STS-Stream
Example: | CONF:WLAN:SMAP:TX4:STR1 1.0,1.0
Manual operation: | See "User Defined Spatial Mapping"


CONFigure:WLAN:SMAPping:TX<ch>:TIMeshift

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > CONFigure:WLAN:SMAPping:TX<ch>:TIMeshift
CONFigure:WLAN:SMAPping:TX<ch>:TIMeshift <TimeShift>

This remote control command specifies the timeshift for a specific antenna.

Parameters:
<TimeShift>

Time shift (in s) for specification of user defined CSD (cyclic delay diversity) for the Spatial Mapping.

Range: -32 ns to 32 ns
Manual operation: See "User Defined Spatial Mapping"


CONFigure:WLAN:STBC:AUTO:TYPE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > CONFigure:WLAN:STBC:AUTO:TYPE
CONFigure:WLAN:STBC:AUTO:TYPE <PPDUType>

This remote control command specifies which PPDUs are analyzed according to STBC streams (for IEEE 802.11n, ac standards only).

Parameters:
<PPDUType>
FBURst | ALL | M0 | M1 | M2 | D0 | D1 | D2
FBURst

The STBC of the first PPDU is detected and subsequent PPDUs are analyzed only if they have the same STBC (corresponds to "Auto, same type as first PPDU")

ALL

All recognized PPDUs are analyzed according to their individual STBC (corresponds to "Auto, individually for each PPDU")

M0 | M1 | M2

Measure only if STBC field = 0 | 1 | 2

For details see "STBC Field"

D0 | D1 | D2

Demod all as STBC field = 0 | 1 | 2

For details see "STBC Field"

Example: CONF:WLAN:STBC:AUTO:TYPE M0
Manual operation: See "STBC Field"


[SENSe:]BANDwidth:CHANnel:AUTO:TYPE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > [SENSe:]BANDwidth:CHANnel:AUTO:TYPE
[SENSe:]BANDwidth:CHANnel:AUTO:TYPE <Bandwidth>

This remote control command specifies the bandwidth in which the PPDUs are analyzed.

This command is only available for standards IEEE 802.11a, ac, n.

Note that channel bandwidths larger than 10 MHz require a R&S FSW bandwidth extension option, see "Sample Rate and Maximum Usable I/Q Bandwidth for RF Input".

Parameters:
<Bandwidth>
FBURst | ALL | MB5 | MB10 | MB20 | MB40 | MB80 | MB160 | DB5 | DB10 | DB20 | DB40 | DB80 | DB160
FBURSt

The channel bandwidth of the first valid PPDU is detected and subsequent PPDUs are analyzed only if they have the same channel bandwidth (corresponds to "Auto, same type as first PPDU")

ALL

All PPDUs are analyzed regardless of the channel bandwidth (corresponds to "Auto, individually for each PPDU")

MB5

Only PPDUs within a channel bandwidth of 5MHz are analyzed

(IEEE 802.11 a, p only)

MB10

Only PPDUs within a channel bandwidth of 10MHz are analyzed

(IEEE 802.11 a,p only)

MB20

Only PPDUs within a channel bandwidth of 20MHz are analyzed

MB40

Only PPDUs within a channel bandwidth of 40MHz are analyzed

(IEEE 802.11 n, ac only)

MB80

Only PPDUs within a channel bandwidth of 80MHz are analyzed

(IEEE 802.11 ac only)

MB160

Only PPDUs within a channel bandwidth of 160MHz are analyzed

(IEEE 802.11 ac only)

DB5

All PPDUs are analyzed within a channel bandwidth of 5MHz

(IEEE 802.11 a, p only)

DB10

All PPDUs are analyzed within a channel bandwidth of 10MHz

(IEEE 802.11 a,p only)

DB20

All PPDUs are analyzed within a channel bandwidth of 20MHz

DB40

All PPDUs are analyzed within a channel bandwidth of 40MHz

(IEEE 802.11 n, ac only)

DB80

All PPDUs are analyzed within a channel bandwidth of 80MHz

(IEEE 802.11 n, ac only)

DB160

All PPDUs are analyzed within a channel bandwidth of 160MHz

(IEEE 802.11 n, ac only)

*RST: FBURst
Example: SENS:BAND:CHAN:AUTO:TYPE MB20
Manual operation: See "Channel Bandwidth to measure (CBW)"


[SENSe:]DEMod:FORMat:BANalyze

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > [SENSe:]DEMod:FORMat:BANalyze
[SENSe:]DEMod:FORMat:BANalyze <Format>

Specifies which PSDUs are to be analyzed depending on their modulation. Only PSDUs using the selected modulation are considered in result analysis.

Note: to analyze all PPDUs that are identical to the first detected PPDU (corresponds to "Auto, same type as first PPDU"), use the command: SENS:DEMO:FORM:BANA:BTYP:AUTO:TYPE FBUR.

To analyze all PPDUs regardless of their format and modulation (corresponds to "Auto, individually for each PPDU") , use the command: SENS:DEMO:FORM:BANA:BTYP:AUTO:TYPE ALL.

See [SENSe:​]DEMod:​FORMat:​BANalyze:​BTYPe:​AUTO:​TYPE.

Parameters:
<Format>
*RST: QAM64
Example: SENS:DEMO:FORM:BAN 'BPSK6'
Manual operation: See "PPDU Format to measure"
See "PSDU Modulation to use"
See "PSDU Modulation"
See "PPDU Format to measure / PSDU Modulation to use"
See "PPDU Format"
Modulation format parameters for IEEE 802.11a, g (OFDM), or p standard
SCPI parameter | Dialog parameter
BPSK6 | BPSK 1/2
BPSK9 | BPSK 3/4
QPSK12 | QPSK 1/2
QPSK18 | QPSK 3/4
QAM1624 | 16-QAM 1/2
QAM1636 | 16-QAM 3/4
QAM6448 | 64-QAM 2/3
QAM6454 | 64-QAM 3/4
Modulation format parameters for IEEE 802.11b or g (DSSS) standard
SCPI parameter | Dialog parameter
CCK11 | Complementary Code Keying at 11 Mbps
CCK55 | Complementary Code Keying at 5.5 Mbps
DBPSK1 | Differential BI-Phase shift keying
DQPSK2 | Differential Quadrature phase shift keying
PBCC11 | PBCC at 11 Mbps
PBCC22 | PBCC at 11 Mbps
PBCC55 | PBCC at 5.5 Mbps


[SENSe:]DEMod:FORMat:BANalyze:BTYPe:AUTO:TYPE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > [SENSe:]DEMod:FORMat:BANalyze:BTYPe:AUTO:TYPE
[SENSe:]DEMod:FORMat:BANalyze:BTYPe:AUTO:TYPE <Analysis>

This remote control command specifies how signals are analyzed.

Parameters:
<Analysis>
FBURst | ALL | MMIX | MGRF | DMIX | DGRF | MVHT | DVHT | MNHT | DNHT
FBURst

The format of the first valid PPDU is detected and subsequent PPDUs are analyzed only if they have the same format (corresponds to "Auto, same type as first PPDU")

ALL

All PPDUs are analyzed regardless of their format (corresponds to "Auto, individually for each PPDU")

MNHT

Only PPDUs with format "Non-HT" are analyzed

(IEEE 802.11 a, g(OFDM), p)

DNHT

All PPDUs are assumed to have the PPDU format "Non-HT"

(IEEE 802.11 a, g(OFDM), p)

MMIX

Only PPDUs with format "HT-MF" (Mixed) are analyzed

(IEEE 802.11 n)

MGRF

Only PPDUs with format "HT-GF" (Greenfield) are analyzed

(IEEE 802.11 n)

DMIX

All PPDUs are assumed to have the PPDU format "HT-MF"

(IEEE 802.11 n)

DGRF

All PPDUs are assumed to have the PPDU format "HT-GF"

(IEEE 802.11 n)

MVHT

Only PPDUs with format "VHT" are analyzed

(IEEE 802.11 ac)

DVHT

All PPDUs are assumed to have the PPDU format "VHT"

(IEEE 802.11 ac)

FMMM

Only PPDUs with specified format are analyzed (see [SENSe:​]DEMod:​FORMat:​BANalyze)

(IEEE 802.11 b, g (DSSS))

FMMD

All PPDUs are assumed to have the specified PPDU format (see [SENSe:​]DEMod:​FORMat:​BANalyze)

(IEEE 802.11 b, g (DSSS))

*RST: FBURst
Example:

SENS:DEM:FORM:BAN:BTYP:AUTO:TYPE FBUR

Manual operation: See "PPDU Format to measure"
See "PSDU Modulation to use"
See "PPDU Format to measure / PSDU Modulation to use"


[SENSe:]DEMod:FORMat[:BCONtent]:AUTO

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > [SENSe:]DEMod:FORMat[:BCONtent]:AUTO
[SENSe:]DEMod:FORMat[:BCONtent]:AUTO <State>

This command determines whether the PPDUs to be analyzed are determined automatically or by the user.

Parameters:
<State>
ON

The signal field, i.e. the PLCP header field, of the first recognized PPDU is analyzed to determine the details of the PPDU. All PPDUs identical to the first recognized PPDU are analyzed.

OFF

Only PPDUs that match the user-defined PPDU type and modulation are considered in results analysis (see [SENSe:​]DEMod:​FORMat:​BANalyze:​BTYPe:​AUTO:​TYPE and [SENSe:​]DEMod:​FORMat:​BANalyze).

Manual operation: See "PPDU Analysis Mode"


[SENSe:]DEMod:FORMat:MCSindex

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > [SENSe:]DEMod:FORMat:MCSindex
[SENSe:]DEMod:FORMat:MCSindex <Index>

This command specifies the MCS index which controls the data rate, modulation and streams (for IEEE 802.11n, ac standards only, see document: IEEE 802.11n/D11.0 June 2009).

This command is required if [SENSe:​]DEMod:​FORMat:​MCSindex:​MODE is set to MEAS or DEM.

Parameters:
<Index>
*RST: 1
Example: SENS:DEM:FORM:MCS:MODE MEAS
SENS:DEM:FORM:MCS 1
Manual operation: See "MCS Index"


[SENSe:]DEMod:FORMat:MCSindex:MODE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > [SENSe:]DEMod:FORMat:MCSindex:MODE
[SENSe:]DEMod:FORMat:MCSindex:MODE <Mode>

This command defines the PPDUs taking part in the analysis depending on their Modulation and Coding Scheme (MCS) index (for IEEE 802.11n, ac standards only).

Parameters:
<Mode>
FBURst | ALL | MEASure | DEMod
FBURst

The MCS index of the first PPDU is detected and subsequent PPDUs are analyzed only if they have the same MCS index (corresponds to "Auto, same type as first PPDU")

ALL

All recognized PPDUs are analyzed according to their individual MCS indexes (corresponds to "Auto, individually for each PPDU")

MEASure

Only PPDUs with an MCS index which matches that specified by [SENSe:​]DEMod:​FORMat:​MCSindex are analyzed

DEMod

All PPDUs will be analyzed according to the MCS index specified by [SENSe:​]DEMod:​FORMat:​MCSindex.

*RST: FBURst
Example: SENS:DEM:FORM:MCS:MODE MEAS
SENS:DEM:FORM:MCS 1
Manual operation: See "MCS Index to use"


[SENSe:]DEMod:FORMat:NSTSindex

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > [SENSe:]DEMod:FORMat:NSTSindex
[SENSe:]DEMod:FORMat:NSTSindex <Index>

Defines the the PPDUs taking part in the analysis depending on their Nsts.

This command is only available for the IEEE 802.11 ac standard.

This command is available for DEM:FORM:NSTS:MODE MEAS or DEM:FORM:NSTS:MODE DEM (see [SENSe:​]DEMod:​FORMat:​NSTSindex:​MODE).

Parameters:
<Index> |
Example: | SENS:DEM:FORM:NSTS:MODE MEAS SENS:DEM:FORM:NSTS 1
Manual operation: | See "Nsts"


[SENSe:]DEMod:FORMat:NSTSindex:MODE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > [SENSe:]DEMod:FORMat:NSTSindex:MODE
[SENSe:]DEMod:FORMat:NSTSindex:MODE <Mode>

Defines the the PPDUs taking part in the analysis depending on their Nsts.

This command is only available for the IEEE 802.11 ac standard.

Parameters:
<Mode>
FBURst | ALL | MEASure | DEMod
FBURst

The Nsts of the first PPDU is detected and subsequent PPDUs are analyzed only if they have the same Nsts (corresponds to "Auto, same type as first PPDU")

ALL

All recognized PPDUs are analyzed according to their individual Nsts (corresponds to "Auto, individually for each PPDU")

MEASure

Only PPDUs with the Nsts specified by [SENSe:​]DEMod:​FORMat:​NSTSindex are analyzed

DEMod

The "Nsts" index specified by [SENSe:​]DEMod:​FORMat:​NSTSindexis used for all PPDUs.

*RST: FBURst
Example: SENS:DEM:FORM:NSTS:MODE MEAS
SENS:DEM:FORM:NSTS 1
Manual operation: See "Nsts to use"


[SENSe<n>:]DEMod:FORMat:SIGSymbol

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Demodulation > [SENSe<n>:]DEMod:FORMat:SIGSymbol
[SENSe<n>:]DEMod:FORMat:SIGSymbol <State>

Activates and deactivates signal symbol field decoding.

For IEEE 802.11b this command can only be queried as the decoding of the signal field is always performed for this standard.

Parameters for setting and query:
<State>
OFF

Deactivates signal symbol field decoding. All PPDUs are assumed to have the specified PPDU format / PSDU modulation, regardless of the actual format or modulation.

ON

If activated, the signal symbol field of the PPDU is analyzed to determine the details of the PPDU. Only PPDUs which match the PPDU type/ PSDU modulation defined by [SENSe:​]DEMod:​FORMat:​BANalyze and [SENSe:​]DEMod:​FORMat:​BANalyze:​BTYPe are considered in results analysis.

*RST: OFF
Manual operation: See "PPDU Format to measure / PSDU Modulation to use"


Evaluation Range

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range
Evaluation Range

The evaluation range defines which data is evaluated in the result display.

Note that, as opposed to manual operation, the PPDUs to be analyzed can be defined either by the number of data symbols, the number of data bytes, or the measurement duration.

List of Commands
CONFigure:BURSt:PVT:AVERage
CONFigure:BURSt:PVT:RPOWer
CONFigure:WLAN:PAYLoad:LENGth:SRC
CONFigure:WLAN:PVERror:MRANge?
[SENSe:]BURSt:COUNt
[SENSe:]BURSt:COUNt:STATe
[SENSe:]DEMod:FORMat:BANalyze:DBYTes:EQUal
[SENSe:]DEMod:FORMat:BANalyze:DBYTes:MAX
[SENSe:]DEMod:FORMat:BANalyze:DBYTes:MIN
[SENSe:]DEMod:FORMat:BANalyze:DURation:EQUal
[SENSe:]DEMod:FORMat:BANalyze:DURation:MAX
[SENSe:]DEMod:FORMat:BANalyze:DURation:MIN
[SENSe:]DEMod:FORMat:BANalyze:SYMBols:EQUal
[SENSe:]DEMod:FORMat:BANalyze:SYMBols:MAX
[SENSe:]DEMod:FORMat:BANalyze:SYMBols:MIN


CONFigure:BURSt:PVT:AVERage

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > CONFigure:BURSt:PVT:AVERage
CONFigure:BURSt:PVT:AVERage <Value>

Defines the number of samples used to adjust the length of the smoothing filter for PVT measurement.

This command is only available for IEEE 802.11b, g (DSSS) standards.

Parameters:
<Value> |
Manual operation: | See "PVT : Average Length (IEEE 802.11b, g (DSSS))"


CONFigure:BURSt:PVT:RPOWer

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > CONFigure:BURSt:PVT:RPOWer
CONFigure:BURSt:PVT:RPOWer <Mode>

This remote control command configures the use of either mean or maximum PPDU power as a reference power for the 802.11b, g (DSSS) PVT measurement.

Parameters:
<Mode> | MEAN | MAXimum
Manual operation: | See "PVT : Reference Power (IEEE 802.11b, g (DSSS))"


CONFigure:WLAN:PAYLoad:LENGth:SRC

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > CONFigure:WLAN:PAYLoad:LENGth:SRC
CONFigure:WLAN:PAYLoad:LENGth:SRC <Source>

Defines which payload length is used to determine the minimum or maximum number of required data symbols (IEEE 802.11n, ac).

Parameters:
<Source> | ESTimate | HTSignal ESTimate Uses a length estimated from the input signal HTSignal (IEEE811.02 n) Determines the length of the HT signal (from the signal field) LSIGnal (IEEE811.02 ac) Determines the length of the L signal (from the signal field)
Manual operation: | See "Source of Payload Length (IEEE 802.11 ac, n)"


CONFigure:WLAN:PVERror:MRANge?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > CONFigure:WLAN:PVERror:MRANge?
CONFigure:WLAN:PVERror:MRANge? <Range>

This remote control command queries whether the Peak Vector Error results are calculated over the complete PPDU or just over the PSDU.

This command is supported for 802.11b and 802.11g (DSSS) only.

Return values:
<Range> | ALL | PSDU ALL Peak Vector Error results are calculated over the complete PPDU PSDU Peak Vector Error results are calculated over the PSDU only
Usage: | Query only
Manual operation: | See "Peak Vector Error : Meas Range (IEEE 802.11b, g (DSSS))"


[SENSe:]BURSt:COUNt

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > [SENSe:]BURSt:COUNt
[SENSe:]BURSt:COUNt <Value>

If the statistic count is enabled (see [SENSe:​]BURSt:​COUNt:​STATe), the specified number of PPDUs is taken into consideration for the statistical evaluation (maximally the number of PPDUs detected in the current capture buffer).

If disabled, all detected PPDUs in the current capture buffer are considered.

Parameters:
<Value>
*RST: 1
Example: SENS:BURS:COUN:STAT ON
SENS:BURS:COUN 10
Manual operation: See "PPDU Statistic Count / No of PPDUs to Analyze"


[SENSe:]BURSt:COUNt:STATe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > [SENSe:]BURSt:COUNt:STATe
[SENSe:]BURSt:COUNt:STATe <State>

If the statistic count is enabled, the specified number of PPDUs is taken into consideration for the statistical evaluation (maximally the number of PPDUs detected in the current capture buffer).

If disabled, all detected PPDUs in the current capture buffer are considered.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SENS:BURS:COUN:STAT ON
SENS:BURS:COUN 10
Manual operation: See "PPDU Statistic Count / No of PPDUs to Analyze"


[SENSe:]DEMod:FORMat:BANalyze:DBYTes:EQUal

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > [SENSe:]DEMod:FORMat:BANalyze:DBYTes:EQUal
[SENSe:]DEMod:FORMat:BANalyze:DBYTes:EQUal <State>

For IEEE 802.11b and g (DSSS) signals only:

If enabled, only PPDUs with a specific payload length are considered for measurement analysis.

If disabled, only PPDUs whose length is within a specified range are considered.

The payload length is specified by the [SENSe:​]DEMod:​FORMat:​BANalyze:​DBYTes:​MIN command.

A payload length range is defined as a minimum and maximum number of symbols the payload may contain (see [SENSe:​]DEMod:​FORMat:​BANalyze:​DBYTes:​MAX and [SENSe:​]DEMod:​FORMat:​BANalyze:​DBYTes:​MIN).

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Equal PPDU Length"


[SENSe:]DEMod:FORMat:BANalyze:DBYTes:MAX

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > [SENSe:]DEMod:FORMat:BANalyze:DBYTes:MAX
[SENSe:]DEMod:FORMat:BANalyze:DBYTes:MAX <NumDataBytes>

If the [SENSe:​]DEMod:​FORMat:​BANalyze:​DBYTes:​EQUal command is set to false, this command specifies the maximum number of data bytes allowed for a PPDU to take part in measurement analysis.

If the [SENSe:​]DEMod:​FORMat:​BANalyze:​DBYTes:​EQUal command is set to true, then this command has no effect.

Parameters:
<NumDataBytes>
*RST: | 64
Default unit: | bytes
Manual operation: See "(Min./Max.) Payload Length (IEEE 802.11b, g (DSSS))"


[SENSe:]DEMod:FORMat:BANalyze:DBYTes:MIN

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > [SENSe:]DEMod:FORMat:BANalyze:DBYTes:MIN
[SENSe:]DEMod:FORMat:BANalyze:DBYTes:MIN <NumDataBytes>

For IEEE 802.11b and g (DSSS) signals only:

If the [SENSe:​]DEMod:​FORMat:​BANalyze:​DBYTes:​EQUal command is set to true, then this command specifies the exact number of data bytes a PPDU must have to take part in measurement analysis.

If the [SENSe:​]DEMod:​FORMat:​BANalyze:​DBYTes:​EQUal command is set to false, this command specifies the minimum number of data bytes required for a PPDU to take part in measurement analysis.

Parameters:
<NumDataBytes>
*RST: | 1
Default unit: | bytes
Manual operation: See "(Min./Max.) Payload Length (IEEE 802.11b, g (DSSS))"


[SENSe:]DEMod:FORMat:BANalyze:DURation:EQUal

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > [SENSe:]DEMod:FORMat:BANalyze:DURation:EQUal
[SENSe:]DEMod:FORMat:BANalyze:DURation:EQUal <State>

For IEEE 802.11b and g (DSSS) signals only:

If enabled, only PPDUs with a specific duration are considered for measurement analysis.

If disabled, only PPDUs whose duration is within a specified range are considered.

The duration is specified by the [SENSe:​]DEMod:​FORMat:​BANalyze:​DURation:​MIN command.

A duration range is defined as a minimum and maximum duration the PPDU may have (see [SENSe:​]DEMod:​FORMat:​BANalyze:​DURation:​MAX and [SENSe:​]DEMod:​FORMat:​BANalyze:​DURation:​MIN).

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Equal PPDU Length"


[SENSe:]DEMod:FORMat:BANalyze:DURation:MAX

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > [SENSe:]DEMod:FORMat:BANalyze:DURation:MAX
[SENSe:]DEMod:FORMat:BANalyze:DURation:MAX <Duration>

For IEEE 802.11b and g (DSSS) signals only:

If the [SENSe:​]DEMod:​FORMat:​BANalyze:​DURation:​EQUal command is set to false, this command specifies the maximum number of symbols allowed for a PPDU to take part in measurement analysis.

If the [SENSe:​]DEMod:​FORMat:​BANalyze:​DURation:​EQUal command is set to true, then this command has no effect.

Parameters:
<Duration>
*RST: | 5464
Default unit: | us
Manual operation: See "(Min./Max.) Payload Length (IEEE 802.11b, g (DSSS))"


[SENSe:]DEMod:FORMat:BANalyze:DURation:MIN

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > [SENSe:]DEMod:FORMat:BANalyze:DURation:MIN
[SENSe:]DEMod:FORMat:BANalyze:DURation:MIN <Duration>

For IEEE 802.11b and g (DSSS) signals only:

If the [SENSe:​]DEMod:​FORMat:​BANalyze:​DURation:​EQUal command is set to true then this command specifies the exact duration required for a PPDU to take part in measurement analysis.

If the [SENSe:​]DEMod:​FORMat:​BANalyze:​DURation:​EQUal command is set to false this command specifies the minimum duration required for a PPDU to take part in measurement analysis.

Parameters:
<Duration>
*RST: | 1
Default unit: | us
Manual operation: See "(Min./Max.) Payload Length (IEEE 802.11b, g (DSSS))"


[SENSe:]DEMod:FORMat:BANalyze:SYMBols:EQUal

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > [SENSe:]DEMod:FORMat:BANalyze:SYMBols:EQUal
[SENSe:]DEMod:FORMat:BANalyze:SYMBols:EQUal <State>

For IEEE 802.11a, g (OFDM), ac, n, p signals only:

If enabled, only PPDUs with a specific number of symbols are considered for measurement analysis.

If disabled, only PPDUs whose length is within a specified range are considered.

The number of symbols is specified by the [SENSe:​]DEMod:​FORMat:​BANalyze:​SYMBols:​MIN command.

A range of data symbols is defined as a minimum and maximum number of symbols the payload may contain (see [SENSe:​]DEMod:​FORMat:​BANalyze:​SYMBols:​MAX and [SENSe:​]DEMod:​FORMat:​BANalyze:​SYMBols:​MIN).

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Equal PPDU Length"


[SENSe:]DEMod:FORMat:BANalyze:SYMBols:MAX

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > [SENSe:]DEMod:FORMat:BANalyze:SYMBols:MAX
[SENSe:]DEMod:FORMat:BANalyze:SYMBols:MAX <NumDataSymbols>

For IEEE 802.11a, g (OFDM), ac, n, p signals only:

If the [SENSe:​]DEMod:​FORMat:​BANalyze:​SYMBols:​EQUal command is set to false, this command specifies the maximum number of payload symbols allowed for a PPDU to take part in measurement analysis.

The number of payload symbols is defined as the uncoded bits including service and tail bits.

If the [SENSe:​]DEMod:​FORMat:​BANalyze:​SYMBols:​EQUal command has been set to true, then this command has no effect.

Parameters:
<NumDataSymbols>
*RST: 64
Manual operation: See "(Min./Max.) No. of Data Symbols (IEEE 802.11a, g (OFDM), ac, n, p)"


[SENSe:]DEMod:FORMat:BANalyze:SYMBols:MIN

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Evaluation Range > [SENSe:]DEMod:FORMat:BANalyze:SYMBols:MIN
[SENSe:]DEMod:FORMat:BANalyze:SYMBols:MIN <NumDataSymbols>

For IEEE 802.11a, g (OFDM), ac, n, p signals only:

If the [SENSe:​]DEMod:​FORMat:​BANalyze:​SYMBols:​EQUal command has been set to true, then this command specifies the exact number of payload symbols a PPDU must have to take part in measurement analysis.

If the [SENSe:​]DEMod:​FORMat:​BANalyze:​SYMBols:​EQUal command is set to false, this command specifies the minimum number of payload symbols required for a PPDU to take part in measurement analysis.

The number of payload symbols is defined as the uncoded bits including service and tail bits.

Parameters:
<NumDataSymbols>
*RST: 1
Example: SENS:DEM:FORM:BAN:SYMB:EQU ON
SENS:DEMO:FORM:BANA:SYMB:MIN
Manual operation: See "(Min./Max.) No. of Data Symbols (IEEE 802.11a, g (OFDM), ac, n, p)"


Limits

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Limits
Limits

The following commands are required to define the limits against which the individual parameter results are checked. Principally, the limits are defined in the WLAN 802.11 standards. However, you can change the limits for your own test cases and reset the limits to the standard values later. Note that changing limits is currently only possible via remote control, not manually via the user interface.

The commands required to retrieve the limit check results are described in "Limit Check Results".

Useful commands for defining limits described elsewhere:
  • UNIT:​EVM
  • UNIT:​GIMBalance
Remote commands exclusive to defining limits:
List of Commands
CALCulate:LIMit:BURSt:ALL
CALCulate:LIMit:BURSt:EVM:ALL[:AVERage]
CALCulate:LIMit:BURSt:EVM:ALL:MAXimum
CALCulate:LIMit:BURSt:EVM:DATA[:AVERage]
CALCulate:LIMit:BURSt:EVM:DATA:MAXimum
CALCulate:LIMit:BURSt:EVM:PILot[:AVERage]
CALCulate:LIMit:BURSt:EVM:PILot:MAXimum
CALCulate:LIMit:BURSt:FERRor[:AVERage]
CALCulate:LIMit:BURSt:FERRor:MAXimum
CALCulate:LIMit:BURSt:IQOFfset[:AVERage]
CALCulate:LIMit:BURSt:IQOFfset:MAXimum
CALCulate:LIMit:BURSt:SYMBolerror[:AVERage]
CALCulate:LIMit:BURSt:SYMBolerror:MAXimum


CALCulate:LIMit:BURSt:ALL

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Limits > CALCulate:LIMit:BURSt:ALL
CALCulate:LIMit:BURSt:ALL <Limits>

This command sets or returns the limit values for the parameters determined by the default WLAN measurement (see "Modulation Accuracy, Flatness and Tolerance Parameters") all in one step.

To define individual limit values use the individual CALCulate<n>:LIMit<k>:BURSt... commands.

Note that the units for the EVM and gain imbalance parameters must be defined in advance using the following commands:

  • UNIT:​EVM
  • UNIT:​GIMBalance
Parameters:
<Limits>

The parameters are input or output as a list of (ASCII) values separated by ',' in the following order:

<average CF error>, <max CF error>, <average symbol clock error>, <max symbol clock error>, <average I/Q offset>, <maximum I/Q offset>, <average EVM all carriers>, <max EVM all carriers>, <average EVM data carriers>, <max EVM data carriers> <average EVM pilots>, <max EVM pilots>


CALCulate:LIMit:BURSt:EVM:ALL[:AVERage]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Limits > CALCulate:LIMit:BURSt:EVM:ALL[:AVERage]
CALCulate:LIMit:BURSt:EVM:ALL[:AVERage] <Limit>
CALCulate:LIMit:BURSt:EVM:ALL:MAXimum <Limit>

This command sets or queries the average or maximum error vector magnitude limit for all carriers as determined by the default WLAN measurement.

For details on the EVM results and the default WLAN measurement see "Modulation Accuracy, Flatness and Tolerance Parameters".

Parameters:
<Limit>

numeric value in dB

The unit for the EVM parameters can be changed in advance using UNIT:​EVM.

Default unit: DB


CALCulate:LIMit:BURSt:EVM:DATA[:AVERage]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Limits > CALCulate:LIMit:BURSt:EVM:DATA[:AVERage]
CALCulate:LIMit:BURSt:EVM:DATA[:AVERage] <Limit>
CALCulate:LIMit:BURSt:EVM:DATA:MAXimum <Limit>

This command sets or queries the average or maximum error vector magnitude limit for the data carrier determined by the default WLAN measurement.

For details on the EVM results and the default WLAN measurement see "Modulation Accuracy, Flatness and Tolerance Parameters".

Parameters:
<Limit>

numeric value in dB

The unit for the EVM parameters can be changed in advance using UNIT:​EVM.

Default unit: DB


CALCulate:LIMit:BURSt:EVM:PILot[:AVERage]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Limits > CALCulate:LIMit:BURSt:EVM:PILot[:AVERage]
CALCulate:LIMit:BURSt:EVM:PILot[:AVERage] <Limit>
CALCulate:LIMit:BURSt:EVM:PILot:MAXimum <Limit>

This command sets or queries the maximum error vector magnitude limit for the pilot carriers determined by the default WLAN measurement.

For details on the EVM results and the default WLAN measurement see "Modulation Accuracy, Flatness and Tolerance Parameters".

Parameters:
<Limit>

numeric value in dB

The unit for the EVM parameters can be changed in advance using UNIT:​EVM.

Default unit: DB


CALCulate:LIMit:BURSt:FERRor[:AVERage]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Limits > CALCulate:LIMit:BURSt:FERRor[:AVERage]
CALCulate:LIMit:BURSt:FERRor[:AVERage] <Limit>
CALCulate:LIMit:BURSt:FERRor:MAXimum <Limit>

This command sets or queries the average or maximum center frequency error limit determined by the default WLAN measurement.

For details on the center frequency error results and the default WLAN measurement see "Modulation Accuracy, Flatness and Tolerance Parameters".

Parameters:
<Limit>

numeric value in Hertz

Default unit: HZ


CALCulate:LIMit:BURSt:IQOFfset[:AVERage]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Limits > CALCulate:LIMit:BURSt:IQOFfset[:AVERage]
CALCulate:LIMit:BURSt:IQOFfset[:AVERage] <Limit>
CALCulate:LIMit:BURSt:IQOFfset:MAXimum <Limit>

This command sets or queries the average or maximum I/Q offset error limit determined by the default WLAN measurement..

For details on the I/Q offset and the default WLAN measurement see "Modulation Accuracy, Flatness and Tolerance Parameters".

Parameters:
<Limit>
Range: | -1000000 to 1000000
Default unit: | DB


CALCulate:LIMit:BURSt:SYMBolerror[:AVERage]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Limits > CALCulate:LIMit:BURSt:SYMBolerror[:AVERage]
CALCulate:LIMit:BURSt:SYMBolerror[:AVERage] <Limit>
CALCulate:LIMit:BURSt:SYMBolerror:MAXimum <Limit>

This command sets or queries the average or maximum symbol clock error limit determined by the default WLAN measurement.

For details on the symbol clock error and the default WLAN measurement see "Modulation Accuracy, Flatness and Tolerance Parameters".

Parameters:
<Limit>

numeric value in parts per million

Default unit: PPM


Automatic Settings

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Automatic Settings
Automatic Settings
List of Commands
CONFigure:POWer:AUTO
CONFigure:POWer:AUTO:SWEep:TIME
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel


CONFigure:POWer:AUTO

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Automatic Settings > CONFigure:POWer:AUTO
CONFigure:POWer:AUTO <State>

This command is used to switch on or off automatic level detection. When switched on, level detection is performed prior to each I/Q data capture or measurement sweep. The length of the sweep performed to determine the ideal reference level is defined by CONFigure:​POWer:​AUTO:​SWEep:​TIME.

Parameters for setting and query:
<State>
OFF

Switches the auto level detection function off

ON

Switches the auto level detection function on

ONCE

Performs an auto level measurement once immediately

*RST: ON
Manual operation: See "Reference Level Mode"


CONFigure:POWer:AUTO:SWEep:TIME

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Automatic Settings > CONFigure:POWer:AUTO:SWEep:TIME
CONFigure:POWer:AUTO:SWEep:TIME <Value>

This command is used to specify the auto track time, i.e. the sweep time for auto level detection.

This setting can currently only be defined in remote control, not in manual operation.

Parameters for setting and query:
<Value>
numeric value

Auto level measurement sweep time

Range: | 0.01 to 1
*RST: | 0.1 s
Default unit: | S
Example: CONF:POW:AUTO:SWE:TIME 0.01 MS


[SENSe:]ADJust:CONFigure:DURation

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Automatic Settings > [SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation <Duration>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command defines the length of the measurement if [SENSe:​]ADJust:​CONFigure:​DURation:​MODE is set to MANual.

Parameters:
<Duration>
Numeric value in seconds
Range: | 0.001 to 16000.0
*RST: | 0.001
Default unit: | s
Example: ADJ:CONF:DUR:MODE MAN

Selects manual definition of the measurement length.

ADJ:CONF:LEV:DUR 5ms

Length of the measurement is 5 ms.

Manual operation: See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:DURation:MODE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Automatic Settings > [SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:DURation:MODE <Mode>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command selects the way the R&S FSW determines the length of the measurement .

Parameters:
<Mode>
AUTO

The R&S FSW determines the measurement length automatically according to the current input data.

MANual

The R&S FSW uses the measurement length defined by [SENSe:​]ADJust:​CONFigure:​DURation.

*RST: AUTO
Manual operation: See "Resetting the Automatic Measurement Time (Meastime Auto)"
See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Automatic Settings > [SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:LOW 2

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level falls below 18 dBm.

Manual operation: See "Lower Level Hysteresis"


[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Automatic Settings > [SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:UPP 2
Example:

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level rises above 22 dBm.

Manual operation: See "Upper Level Hysteresis"


[SENSe:]ADJust:LEVel

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Automatic Settings > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel

This command initiates a single (internal) measurement that evaluates and sets the ideal reference level for the current input data and measurement settings. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Example: | ADJ:LEV
Usage: | Event
Manual operation: | See "Setting the Reference Level Automatically (Auto Level)"


Sweep Settings

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Sweep Settings
Sweep Settings
List of Commands
[SENSe:]SWEep:COUNt


[SENSe:]SWEep:COUNt

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the WLAN IQ Measurement (Modulation Accuracy, Flatness and Tolerance) > Sweep Settings > [SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt <SweepCount>

This command defines the number of sweeps that the application uses to average traces.

(For Pulse measurements, see also "Trace Statistics" ).

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweeps, the application stops the measurement and calculates the average after the average count has been reached.

Example: SWE:COUN 64

Sets the number of sweeps to 64.

INIT:CONT OFF

Switches to single sweep mode.

INIT;*WAI

Starts a sweep and waits for its end.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


Configuring Frequency Sweep Measurements on WLAN Signals

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring Frequency Sweep Measurements on WLAN Signals
Configuring Frequency Sweep Measurements on WLAN Signals

The R&S FSW WLAN application uses the functionality of the R&S FSW base system (Spectrum application, see "Configuring and Performing Measurements" ) to perform the WLAN frequency sweep measurements. The R&S FSW WLAN application automatically sets the parameters to predefined settings as described in "Frequency Sweep Measurements".

The WLAN RF measurements must be activated for a measurement channel in the WLAN application, see "Activating WLAN Measurements".

For details on configuring these RF measurements in a remote environment, see "Configuring and Performing Measurements" .

Remote commands exclusive to SEM measurements in the WLAN application:
List of Commands
[SENSe<n>:]POWer:SEM
[SENSe:]POWer:SEM:CLASs


[SENSe<n>:]POWer:SEM

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring Frequency Sweep Measurements on WLAN Signals > [SENSe<n>:]POWer:SEM
[SENSe<n>:]POWer:SEM <Type>

This command sets the Spectrum Emission Mask (SEM) measurement type.

Parameters:
<Type>
IEEE | ETSI | User
User

Settings and limits are configured via a user-defined XML file. Load the file using MMEMory:​LOAD:​SEM:​STATe.

IEEE

Settings and limits are as specified in the IEEE Std 802.11n™-2009 Figure 20-17—Transmit spectral mask for 20 MHz transmission. For other IEEE standards see the parameter values in the table below.

After a query, IEEE is returned for all IEEE standards.

ETSI

Settings and limits are as specified in the ETSI standard.

*RST: IEEE
Supported IEEE standards
Manual operation | The spectrum emission mask measurement is performed according to the standard | Parameter value
IEEE 802.11n-2009 20M@2.4G | IEEE Std 802.11n™-2009 Figure 20-17—Transmit spectral mask for 20 MHz transmission | IEEE or 'IEEE_2009_20_2_4'
IEEE 802.11n-2009 40M@2.4G | IEEE Std 802.11n™-2009 Figure 20-18—Transmit spectral mask for a 40 MHz channel | 'IEEE_2009_40_2_4'
IEEE 802.11n-2009 20M@5G | IEEE Std 802.11n™-2009 Figure 20-17—Transmit spectral mask for 20 MHz transmission | 'IEEE_2009_20_5'
IEEE 802.11n-2009 40M@5G | IEEE Std 802.11n™-2009 Figure 20-18—Transmit spectral mask for a 40 MHz channel | 'IEEE_2009_40_5'
IEEE 802.11mb/D08 20M@2.4G | IEEE Std 802.11n™-2009 Figure 20-17—Transmit spectral mask for 20 MHz transmission IEEE Draft P802.11-REVmb™/D8.0, March 2011 Figure 19-17—Transmit spectral mask for 20 MHz transmission in the 2.4 GHz band | 'IEEE_D08_20_2_4'
IEEE 802.11mb/D08 40M@2.4G | IEEE Std 802.11n™-2009 Figure 20-18—Transmit spectral mask for a 40 MHz channel IEEE Draft P802.11-REVmb™/D8.0, March 2011 Figure 19-18—Transmit spectral mask for a 40 MHz channel in the 2.4 GHz band | 'IEEE_D08_40_2_4'
IEEE 802.11mb/D08 20M@5G | IEEE Draft P802.11-REVmb™/D8.0, March 2011 Figure 19-19—Transmit spectral mask for 20 MHz transmission in the 5 GHz band | 'IEEE_D08_20_5'
IEEE 802.11mb/D08 40M@5G | IEEE Draft P802.11-REVmb™/D8.0, March 2011 Figure 19-20—Transmit spectral mask for a 40 MHz channel in the 5 GHz band | 'IEEE_D08_40_5'
IEEE 802.11ac/D1.1 20M@5G | IEEE P802.11ac™/D1.1, August 2011 Figure 22-17—Transmit spectral mask for a 20 MHz channel | 'IEEE_AC_D1_1_20_5'
IEEE 802.11ac/D1.1 40M@5G | IEEE P802.11ac™/D1.1, August 2011 Figure 22-18—Transmit spectral mask for a 40 MHz channel | 'IEEE_AC_D1_1_40_5'
IEEE 802.11ac/D1.1 80M@5G | IEEE P802.11ac™/D1.1, August 2011 Figure 22-19—Transmit spectral mask for a 80 MHz channel | 'IEEE_AC_D1_1_80_5'


[SENSe:]POWer:SEM:CLASs

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring Frequency Sweep Measurements on WLAN Signals > [SENSe:]POWer:SEM:CLASs
[SENSe:]POWer:SEM:CLASs <Index>

This command sets the Spectrum Emission Mask (SEM) power class index. The index represents the power classes to be applied. The index is directly related to the entries displayed in the power class drop down combo box, within the SEM settings configuration page.

Parameters:
<Index>
*RST: 0


Configuring the Result Display

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display
Configuring the Result Display

The following commands are required to configure the screen display in a remote environment. The corresponding tasks for manual operation are described in "Display Configuration".

The suffix <n> in the following remote commands represents the window (1..16) in the currently selected measurement channel.

Contents
  • General Window Commands
  • Working with Windows in the Display
  • Selecting Items to Display in Result Summary
  • Configuring the Spectrum Flatness and Group Delay Result Displays
  • Configuring the AM/AM Result Display


General Window Commands

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE


DISPlay:FORMat

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView" ).

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


Working with Windows in the Display

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


LAYout:ADD[:WINDow]?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
Manual operation: See "AM/AM"
See "AM/PM"
See "AM/EVM"
See "Bitstream"
See "Constellation"
See "Constellation vs Carrier"
See "EVM vs Carrier"
See "EVM vs Chip"
See "EVM vs Symbol"
See "FFT Spectrum"
See "Freq. Error vs Preamble"
See "Group Delay"
See "Magnitude Capture"
See "Phase Error vs Preamble"
See "PLCP Header (IEEE 802.11b, g (GSSS)"
See "PvT Full PPDU"
See "PvT Rising Edge"
See "PvT Falling Edge"
See "Result Summary Detailed"
See "Result Summary Global"
See "Signal Field"
See "Spectrum Flatness"
See "Diagram"
See "Result Summary"
See "Marker Table"
See "Marker Peak List"
<WindowType> parameter values for WLAN application
Parameter value | Window type
Window types for I/Q data
AMAM | AM/AM (IEEE 802.11a, g (OFDM), ac, n, p only)
AMEV | AM/EVM (IEEE 802.11a, g (OFDM), ac, n, p only)
AMPM | AM/PM (IEEE 802.11a, g (OFDM), ac, n, p only)
BITStream | Bitstream
CMEMory | Magnitude Capture
CONStellation | Constellation
CVCarrier | Constellation vs Carrier (IEEE 802.11a, g (OFDM), ac, n, p only)
EVCarrier | EVM vs Carrier (IEEE 802.11a, g (OFDM), ac, n, p only)
EVCHip | EVM vs Chip (IEEE 802.11b and g (DSSS) only)
EVSYmbol | EVM vs Symbol (IEEE 802.11a, g (OFDM), ac, n, p only)
FEVPreamble | Frequency Error vs. Preamble
FSPectrum | FFT Spectrum
GDELay | Group Delay (IEEE 802.11a, g (OFDM), ac, n, p only)
PEVPreamble | Phase Error vs. Preamble
PFALling | PvT Falling Edge
PFPPdu | PvT Full PPDU
PRISing | PvT Rising Edge
RSDetailed | Result Summary Detailed (IEEE 802.11a, g (OFDM), ac, n, p only)
RSGLobal | Result Summary Global
SFIeld | Signal Field (IEEE 802.11a, g (OFDM), ac, n, p) PLCP Header (IEEE 802.11b and g (DSSS)
SFLatness | Spectrum Flatness (IEEE 802.11a, g (OFDM), ac, n, p only)
Window types for RF data
DIAGram | Diagram (SEM, ACLR)
MTABle | Marker table (SEM, ACLR)
PEAKlist | Marker peak list (SEM, ACLR)
RSUMmary | Result summary (SEM, ACLR)


LAYout:CATalog[:WINDow]?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Selecting Items to Display in Result Summary

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Selecting Items to Display in Result Summary
Selecting Items to Display in Result Summary

The following command defines which items are displayed in the Result Summary.

List of Commands
DISPlay[:WINDow<n>]:TABLe:ITEM


DISPlay[:WINDow<n>]:TABLe:ITEM

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Selecting Items to Display in Result Summary > DISPlay[:WINDow<n>]:TABLe:ITEM
DISPlay[:WINDow<n>]:TABLe:ITEM <Item>,<State>

Defines which items are displayed in the Result Summary (see "Result Summary Detailed" and "Result Summary Global"). Note that the results are always calculated, regardless of their visibility in the Result Summary.

Parameters:
<Item>

Item to be included in Result Summary. For an overview of possible results and the required parameters see the tables below.

<State>
ON | OFF
ON

Item is displayed in Result Summary.

OFF

Item is not displayed in Result Summary.

*RST: ON
Parameters for the items of the "Result Summary Detailed"
Result in table | SCPI parameter
TX channel ("Tx All") | TALL
I/Q offset | IOFSset
Gain imbalance | GIMBalance
Quadrature offset | QOFFset
I/Q skew | IQSKew
PPDU power | TPPower
Crest factor | TCFactor
Receive channel ("Rx All") | RALL
PPDU power | RPPower
Crest factor | RCFactor
Bitstream ("Stream All") | SALL
Pilot bit error rate | BPILot
EVM all carriers | SEACarriers
EVM data carriers | SEDCarriers
EVM pilot carriers | SEPCarriers
Parameters for the items of the "Result Summary Global"
Result in table | SCPI parameter
Pilot bit error rate | PBERate
EVM all carriers | EACarriers
EVM data carriers | EDCarriers
EVM pilot carriers | EPCarriers
Center frequency error | CFERror
Symbol clock error | SCERror


Configuring the Spectrum Flatness and Group Delay Result Displays

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Configuring the Spectrum Flatness and Group Delay Result Displays
Configuring the Spectrum Flatness and Group Delay Result Displays

The following command is only relevant for the Spectrum Flatness and Group Delay result displays.

List of Commands
CONFigure:BURSt:SPECtrum:FLATness:CSELect


CONFigure:BURSt:SPECtrum:FLATness:CSELect

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Configuring the Spectrum Flatness and Group Delay Result Displays > CONFigure:BURSt:SPECtrum:FLATness:CSELect
CONFigure:BURSt:SPECtrum:FLATness:CSELect <ChannelType>

This remote control command configures the Spectrum Flatness and Group Delay results to be based on either effective or physical channels. This command is only valid for IEEE 802.11n and IEEE 802.11ac standards.

While the physical channels cannot always be determined, the effective channel can always be estimated from the known training fields. Thus, for some PPDUs or measurement scenarios, only the results based on the mapping of the space-time stream to the Rx antenna (effective channel) are available, as the mapping of the Rx antennas to the Tx antennas (physical channel) could not be determined.

For more information see "Physical vs Effective Channels".

Parameters:
<ChannelType>
EFFective | PHYSical
*RST: EFF
Example: CONF:BURS:SPEC:FLAT:CSEL PHYS

Configures the Spectrum Flatness and Group Delay result displays to calculate the results based on the physical channel.

Usage: Event


Configuring the AM/AM Result Display

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Configuring the AM/AM Result Display
Configuring the AM/AM Result Display

The following commands are only relevant for the AM/AM result display.

List of Commands
CONFigure:BURSt:AM:AM:POLYnomial
CONFigure:BURSt:AM:AM:COEFficients?


CONFigure:BURSt:AM:AM:POLYnomial

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Configuring the AM/AM Result Display > CONFigure:BURSt:AM:AM:POLYnomial
CONFigure:BURSt:AM:AM:POLYnomial <Degree>

This remote control command specifies the degree of the polynomial regression model used to determine the AM/AM result display.

The resulting coefficients of the regression polynomial can be queried using the CONFigure:​BURSt:​AM:​AM:​COEFficients? command.

Parameters:
<Degree>
integer
Range: | 1 to 20
*RST: | 4
Example:

CONF:BURS:AM:AM:POLY 3

Manual operation: See "AM/AM"


CONFigure:BURSt:AM:AM:COEFficients?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Configuring the Result Display > Configuring the AM/AM Result Display > CONFigure:BURSt:AM:AM:COEFficients?
CONFigure:BURSt:AM:AM:COEFficients?

This remote control returns the coefficients of the polynomial regression model used to determine the AM/AM result display.

Return values:
<Coefficients> | comma-separated list of numeric values The coefficients are listed in ascending order of degree (as displayed in the result display title bar).
Example: | CONF:BURS:AM:AM:COEF?
Usage: | Query only


Starting a Measurement

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Starting a Measurement
Starting a Measurement

When a WLAN measurement channel is activated on the R&S FSW, a WLAN IQ measurement (Modulation Accuracy, Flatness and Tolerance, see "WLAN I/Q Measurement (Modulation Accuracy, Flatness and Tolerance)"), is started immediately. However, you can stop and start a new measurement any time.

Furthermore, you can perform a sequence of measurements using the Sequencer (see "Multiple Measurement Channels and Sequencer Function").

List of Commands
ABORt
CALCulate<n>:BURSt[:IMMediate]
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
SYSTem:SEQuencer


ABORt

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Starting a Measurement > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


CALCulate<n>:BURSt[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Starting a Measurement > CALCulate<n>:BURSt[:IMMediate]
CALCulate<n>:BURSt[:IMMediate]

This command forces the IQ measurement results to be recalculated according to the current settings.

Manual operation: See "Calc Results"


INITiate:CONTinuous

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Starting a Measurement > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the sweep mode.

Note that in single sweep mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous sweep mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous sweep mode in remote control, as results like trace data or markers are only valid after a single sweep end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the sweep mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous sweep

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the sweep mode to single sweep.

INIT:CONT ON

Switches the sweep mode to continuous sweep.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Starting a Measurement > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single / Cont."
See "Single Sweep/ RUN SINGLE"


INITiate:SEQuencer:ABORt

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Starting a Measurement > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: | Event
Manual operation: | See "Sequencer State"


INITiate:SEQuencer:IMMediate

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Starting a Measurement > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event
Manual operation: See "Sequencer State"


INITiate:SEQuencer:MODE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Starting a Measurement > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Manual operation: See "Sequencer Mode"


SYSTem:SEQuencer

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Starting a Measurement > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .

Manual operation: See "Sequencer State"


Retrieving Results

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results
Retrieving Results

The following commands are required to retrieve the results from a WLAN measurement in a remote environment.

Before retrieving measurement results, check if PPDU synchronization was successful or not by checking the status register (see "The STATus:QUEStionable:SYNC Register"). If no PPDUs were found, STAT:QUES:SYNC:COND? returns 0 (see STATus:​QUEStionable:​SYNC:​CONDition?).

The *OPC command should be used after commands that retrieve data so that subsequent commands to change the trigger or data capturing settings are held off until after the data capture is completed and the data has been returned.

Useful commands described elsewhere:
  • "Storing Measurement Results"
Contents
  • Numeric Modulation Accuracy, Flatness and Tolerance Results
  • Numeric Results for Frequency Sweep Measurements
  • Retrieving Trace Results
  • Measurement Results for TRACe<n>[:DATA]? TRACE<n>
  • Importing and Exporting I/Q Data and Results


Numeric Modulation Accuracy, Flatness and Tolerance Results

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results
Numeric Modulation Accuracy, Flatness and Tolerance Results

The following commands describe how to retrieve the numeric results from the standard WLAN measurements.

The commands to retrieve results from frequency sweep measurements for WLAN signals are described in "Numeric Results for Frequency Sweep Measurements".

Contents
  • PPDU and Symbol Count Results
  • Error Parameter Results
  • Limit Check Results


PPDU and Symbol Count Results

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > PPDU and Symbol Count Results
PPDU and Symbol Count Results

The following commands are required to retrieve PPDU and symbol count results from the WLAN IQ measurement on the captured I/Q data (see "Modulation Accuracy, Flatness and Tolerance Parameters").

List of Commands
FETCh:BURSt:COUNt?
FETCh:BURSt:COUNt:ALL?
FETCh:SYMBol:COUNt?
FETCh:BURSt:LENGths?
FETCh:BURSt:STARts?
UNIT:BURSt


FETCh:BURSt:COUNt?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > PPDU and Symbol Count Results > FETCh:BURSt:COUNt?
FETCh:BURSt:COUNt?

This command returns the number of analyzed PPDUs from the current capture buffer. If multiple measurements are required because the number of PPDUs to analyze is greater than the number of PPDUs that can be captured in one buffer, this command only returns the number of captured PPDUs in the current capture buffer (as opposed to FETCh:​BURSt:​COUNt:​ALL?).

Usage: Query only


FETCh:BURSt:COUNt:ALL?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > PPDU and Symbol Count Results > FETCh:BURSt:COUNt:ALL?
FETCh:BURSt:COUNt:ALL?

This command returns the number of analyzed PPDUs for the entire measurement. If multiple measurements are required because the number of PPDUs to analyze is greater than the number of PPDUs that can be captured in one buffer, this command returns the number of analyzed PPDUs in all measurements (as opposed to FETCh:​BURSt:​COUNt?.

Usage: Query only


FETCh:SYMBol:COUNt?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > PPDU and Symbol Count Results > FETCh:SYMBol:COUNt?
FETCh:SYMBol:COUNt?

This command returns the number of symbols in each analyzed PPDU as a comma separated list. The length of the list corresponds to the number of PPDUs, i.e. the result of FETCh:​BURSt:​COUNt:​ALL?.

Usage: Query only


FETCh:BURSt:LENGths?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > PPDU and Symbol Count Results > FETCh:BURSt:LENGths?
FETCh:BURSt:LENGths?

This command returns the length of the analyzed PPDUs from the current measurement. If the number of PPDUs to analyze is greater than the number of PPDUs that can be captured in one buffer, this command only returns the lengths of the PPDUs in the current capture buffer.

The result is a comma-separated list of lengths, one for each PPDU.

Return values:
<PPDULength> | Length of the PPDU in the unit specified by the UNIT:​BURSt command.
Usage: | Query only


FETCh:BURSt:STARts?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > PPDU and Symbol Count Results > FETCh:BURSt:STARts?
FETCh:BURSt:STARts?

This command returns the start position of each analyzed PPDU in the current capture buffer.

Return values:
<Position> | Comma-separated list of samples or symbols (depending on the UNIT:​BURSt command) indicating the start position of each PPDU.
Usage: | Query only


UNIT:BURSt

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > PPDU and Symbol Count Results > UNIT:BURSt
UNIT:BURSt <Unit>

This command specifies the units for PPDU length results (see FETCh:​BURSt:​LENGths?).

Parameters:
<Unit>
SYMBol | SAMPle
*RST: SYMBol


Error Parameter Results

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results
Error Parameter Results

The following commands are required to retrieve individual results from the WLAN IQ measurement on the captured I/Q data (see "Modulation Accuracy, Flatness and Tolerance Parameters").

List of Commands
FETCh:BURSt:ALL
FETCh:BURSt:CRESt[:AVERage]?
FETCh:BURSt:CRESt:MAXimum?
FETCh:BURSt:CRESt:MINimum?
FETCh:BURSt:EVM:ALL:AVERage?
FETCh:BURSt:EVM:ALL:MAXimum?
FETCh:BURSt:EVM:ALL:MINimum?
FETCh:BURSt:EVM:DATA:AVERage?
FETCh:BURSt:EVM:DATA:MAXimum?
FETCh:BURSt:EVM:DATA:MINimum?
FETCh:BURSt:EVM:PILot:AVERage?
FETCh:BURSt:EVM:PILot:MAXimum?
FETCh:BURSt:EVM:PILot:MINimum?
FETCh:BURSt:FERRor:AVERage?
FETCh:BURSt:FERRor:MAXimum?
FETCh:BURSt:FERRor:MINimum?
FETCh:BURSt:GIMBalance:AVERage?
FETCh:BURSt:GIMBalance:MAXimum?
FETCh:BURSt:GIMBalance:MINimum?
FETCh:BURSt:IQOFfset:AVERage?
FETCh:BURSt:IQOFfset:MAXimum?
FETCh:BURSt:IQOFfset:MINimum?
FETCh:BURSt:EVM:ALL:AVERage?
FETCh:BURSt:EVM:ALL:MAXimum?
FETCh:BURSt:EVM:ALL:MINimum?
FETCh:BURSt:PAYLoad[:AVERage]?
FETCh:BURSt:PAYLoad:MINimum?
FETCh:BURSt:PAYLoad:MAXimum?
FETCh:BURSt:PEAK[:AVERage]?
FETCh:BURSt:PEAK:MINimum?
FETCh:BURSt:PEAK:MAXimum?
FETCh:BURSt:PREamble[:AVERage]?
FETCh:BURSt:PREamble:MINimum?
FETCh:BURSt:PREamble:MAXimum?
FETCh:BURSt:QUADoffset:AVERage?
FETCh:BURSt:QUADoffset:MAXimum?
FETCh:BURSt:QUADoffset:MINimum?
FETCh:BURSt:RMS[:AVERage]?
FETCh:BURSt:RMS:MAXimum?
FETCh:BURSt:RMS:MINimum?
FETCh:BURSt:SYMBolerror:AVERage?
FETCh:BURSt:SYMBolerror:MAXimum?
FETCh:BURSt:SYMBolerror:MINimum?
UNIT:EVM
UNIT:GIMBalance


FETCh:BURSt:ALL

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:ALL
FETCh:BURSt:ALL

This command returns all results from the default WLAN measurement (Modulation Accuracy, Flatness and Tolerance, see "Modulation Accuracy, Flatness and Tolerance Parameters"). The results are output as a list of result strings separated by commas in ASCII format. The results are output in the following order:

Return values:
<Results>

<preamble power>, <payload power>, <min rms power>,

<average rms power>, <max rms power>, <peak power>,

<min crest factor>,<average crest factor>,<max crest factor>,

<min frequency error>,<average frequency error>,

<max frequency error>, <min symbol error>,

<average symbol error>, <max symbol error>,

<min IQ offset>, <average IQ offset>, <maximum IQ offset>,

<min gain imbalance>, <average gain imbalance>,

<max gain imbalance>, <min quadrature offset>,

<average quadrature offset>, <max quadrature offset>,

<min EVM all bursts>, <average EVM all bursts>,

<max EVM all bursts>, <min EVM data carriers>,

<average EVM data carriers >, <max EVM data carriers>

<min EVM pilots>, <average EVM pilots >, <max EVM pilots>

<min IQ skew>, <average IQ skew>, <max IQ skew>


FETCh:BURSt:CRESt[:AVERage]?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:CRESt[:AVERage]?
FETCh:BURSt:CRESt[:AVERage]?
FETCh:BURSt:CRESt:MAXimum?
FETCh:BURSt:CRESt:MINimum?

This command returns the average, maximum or minimum determined CREST factor (= ratio of peak power to average power) in dB.

For details see "Modulation Accuracy, Flatness and Tolerance Parameters"

Usage: Query only


FETCh:BURSt:EVM:ALL:AVERage?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:EVM:ALL:AVERage?
FETCh:BURSt:EVM:ALL:AVERage?
FETCh:BURSt:EVM:ALL:MAXimum?
FETCh:BURSt:EVM:ALL:MINimum?

This command returns the average, maximum or minimum EVM in dB. This is a combined figure that represents the pilot, data and the free carrier.

For details see "Modulation Accuracy, Flatness and Tolerance Parameters"

Usage: Query only


FETCh:BURSt:EVM:DATA:AVERage?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:EVM:DATA:AVERage?
FETCh:BURSt:EVM:DATA:AVERage?
FETCh:BURSt:EVM:DATA:MAXimum?
FETCh:BURSt:EVM:DATA:MINimum?

This command returns the average, maximum or minimum EVM for the data carrier in dB.

For details see "Modulation Accuracy, Flatness and Tolerance Parameters"

Usage: Query only


FETCh:BURSt:EVM:PILot:AVERage?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:EVM:PILot:AVERage?
FETCh:BURSt:EVM:PILot:AVERage?
FETCh:BURSt:EVM:PILot:MAXimum?
FETCh:BURSt:EVM:PILot:MINimum?

This command returns the average, maximum or minimum EVM in dB for the pilot carrier.

For details see "Modulation Accuracy, Flatness and Tolerance Parameters"

Usage: Query only


FETCh:BURSt:FERRor:AVERage?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:FERRor:AVERage?
FETCh:BURSt:FERRor:AVERage?
FETCh:BURSt:FERRor:MAXimum?
FETCh:BURSt:FERRor:MINimum?

This command returns the average, maximum or minimum center frequency errors in Hertz.

For details see "Modulation Accuracy, Flatness and Tolerance Parameters"

Usage: Query only


FETCh:BURSt:GIMBalance:AVERage?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:GIMBalance:AVERage?
FETCh:BURSt:GIMBalance:AVERage?
FETCh:BURSt:GIMBalance:MAXimum?
FETCh:BURSt:GIMBalance:MINimum?

This command returns the average, maximum or minimum I/Q imbalance in dB.

For details see "Modulation Accuracy, Flatness and Tolerance Parameters"

Usage: Query only


FETCh:BURSt:IQOFfset:AVERage?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:IQOFfset:AVERage?
FETCh:BURSt:IQOFfset:AVERage?
FETCh:BURSt:IQOFfset:MAXimum?
FETCh:BURSt:IQOFfset:MINimum?

This command returns the average, maximum or minimum I/Q offset in dB.

For details see "Modulation Accuracy, Flatness and Tolerance Parameters"

Usage: Query only


FETCh:BURSt:EVM:ALL:AVERage?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:EVM:ALL:AVERage?
FETCh:BURSt:EVM:ALL:AVERage?
FETCh:BURSt:EVM:ALL:MAXimum?
FETCh:BURSt:EVM:ALL:MINimum?

This command returns the average, maximum or minimum I/Q skew in picoseconds.

For details see "I/Q Skew".

Usage: Query only


FETCh:BURSt:PAYLoad[:AVERage]?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:PAYLoad[:AVERage]?
FETCh:BURSt:PAYLoad[:AVERage]?
FETCh:BURSt:PAYLoad:MINimum?
FETCh:BURSt:PAYLoad:MAXimum?

This command returns the average, maximum or minimum of the "Payload Power per PPDU" (in dBm). All analyzed PPDUs, up to the statistic length, take part in the statistical evaluation.

Usage: Query only


FETCh:BURSt:PEAK[:AVERage]?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:PEAK[:AVERage]?
FETCh:BURSt:PEAK[:AVERage]?
FETCh:BURSt:PEAK:MINimum?
FETCh:BURSt:PEAK:MAXimum?

This command returns the average, maximum or minimum of the "Peak Power per PPDU" (in dBm). All analyzed PPDUs, up to the statistic length, take part in the statistical evaluation.

Usage: Query only


FETCh:BURSt:PREamble[:AVERage]?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:PREamble[:AVERage]?
FETCh:BURSt:PREamble[:AVERage]?
FETCh:BURSt:PREamble:MINimum?
FETCh:BURSt:PREamble:MAXimum?

This command returns the average, maximum or minimum of the "Preamble Power per PPDU" (in dBm). All analyzed PPDUs, up to the statistic length, take part in the statistical evaluation.

Usage: Query only


FETCh:BURSt:QUADoffset:AVERage?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:QUADoffset:AVERage?
FETCh:BURSt:QUADoffset:AVERage?
FETCh:BURSt:QUADoffset:MAXimum?
FETCh:BURSt:QUADoffset:MINimum?

This command returns the average, maximum or minimum quadrature offset of symbols within a PPDU. This value indicates the phase accuracy.

For details see "Modulation Accuracy, Flatness and Tolerance Parameters".

Usage: Query only


FETCh:BURSt:RMS[:AVERage]?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:RMS[:AVERage]?
FETCh:BURSt:RMS[:AVERage]?
FETCh:BURSt:RMS:MAXimum?
FETCh:BURSt:RMS:MINimum?

This command returns the average, maximum or minimum RMS power in dBm for all analyzed PPDUs.

For details see "Modulation Accuracy, Flatness and Tolerance Parameters".

Usage: Query only


FETCh:BURSt:SYMBolerror:AVERage?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > FETCh:BURSt:SYMBolerror:AVERage?
FETCh:BURSt:SYMBolerror:AVERage?
FETCh:BURSt:SYMBolerror:MAXimum?
FETCh:BURSt:SYMBolerror:MINimum?

This command returns the average, maximum or minimum percentage of symbols that were outside the allowed demodulation range within a PPDU.

For details see "Modulation Accuracy, Flatness and Tolerance Parameters".

Usage: Query only


UNIT:EVM

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > UNIT:EVM
UNIT:EVM <Unit>

This command specifies the units for EVM limits and results (see "Modulation Accuracy, Flatness and Tolerance Parameters").

Parameters:
<Unit>
DB | PCT
*RST: DB


UNIT:GIMBalance

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Error Parameter Results > UNIT:GIMBalance
UNIT:GIMBalance <Unit>

This command specifies the units for gain imbalance results (see "Modulation Accuracy, Flatness and Tolerance Parameters").

Parameters:
<Unit>
DB | PCT
*RST: DB


Limit Check Results

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Limit Check Results
Limit Check Results

The following commands are required to query the results of the limit checks.

Useful commands for retrieving results described elsewhere:
  • UNIT:​EVM
  • UNIT:​GIMBalance
Remote commands exclusive to retrieving limit check results
List of Commands
CALCulate:LIMit:BURSt:ALL:RESult?
CALCulate:LIMit:BURSt:EVM:ALL[:AVERage]:RESult?
CALCulate:LIMit:BURSt:EVM:ALL:MAXimum:RESult?
CALCulate:LIMit:BURSt:EVM:DATA[:AVERage]:RESult?
CALCulate:LIMit:BURSt:EVM:DATA:MAXimum:RESult?
CALCulate:LIMit:BURSt:EVM:PILot[:AVERage]:RESult?
CALCulate:LIMit:BURSt:EVM:PILot:MAXimum:RESult?
CALCulate:LIMit:BURSt:FERRor[:AVERage]:RESult?
CALCulate:LIMit:BURSt:FERRor:MAXimum:RESult?
CALCulate:LIMit:BURSt:IQOFfset[:AVERage]:RESult?
CALCulate:LIMit:BURSt:IQOFfset:MAXimum:RESult?
CALCulate:LIMit:BURSt:SYMBolerror[:AVERage]:RESult?
CALCulate:LIMit:BURSt:SYMBolerror:MAXimum:RESult?


CALCulate:LIMit:BURSt:ALL:RESult?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Limit Check Results > CALCulate:LIMit:BURSt:ALL:RESult?
CALCulate:LIMit:BURSt:ALL:RESult?

This command returns the result of the EVM limit check for all carriers. The limit value is defined by the standard or the user (see CALCulate:​LIMit:​BURSt:​ALL).

Return values:
<LimitCheck> | PASS The defined limit for the parameter was not exceeded. FAILED The defined limit for the parameter was exceeded.
Usage: | Query only


CALCulate:LIMit:BURSt:EVM:ALL[:AVERage]:RESult?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Limit Check Results > CALCulate:LIMit:BURSt:EVM:ALL[:AVERage]:RESult?
CALCulate:LIMit:BURSt:EVM:ALL[:AVERage]:RESult?
CALCulate:LIMit:BURSt:EVM:ALL:MAXimum:RESult?

This command returns the result of the average or maximum EVM limit check. The limit value is defined by the standard or the user (see CALCulate:​LIMit:​BURSt:​EVM:​ALL:​MAXimum).

Return values:
<LimitCheck> | PASS The defined limit for the parameter was not exceeded. FAILED The defined limit for the parameter was exceeded.
Usage: | Query only


CALCulate:LIMit:BURSt:EVM:DATA[:AVERage]:RESult?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Limit Check Results > CALCulate:LIMit:BURSt:EVM:DATA[:AVERage]:RESult?
CALCulate:LIMit:BURSt:EVM:DATA[:AVERage]:RESult?
CALCulate:LIMit:BURSt:EVM:DATA:MAXimum:RESult?

This command returns the result of the average or maximum EVM limit check for data carriers. The limit value is defined by the standard or the user (see CALCulate:​LIMit:​BURSt:​EVM:​DATA:​MAXimum).

Return values:
<LimitCheck> | PASS The defined limit for the parameter was not exceeded. FAILED The defined limit for the parameter was exceeded.
Usage: | Query only


CALCulate:LIMit:BURSt:EVM:PILot[:AVERage]:RESult?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Limit Check Results > CALCulate:LIMit:BURSt:EVM:PILot[:AVERage]:RESult?
CALCulate:LIMit:BURSt:EVM:PILot[:AVERage]:RESult?
CALCulate:LIMit:BURSt:EVM:PILot:MAXimum:RESult?

This command returns the result of the average or maximum EVM limit check for pilot carriers. The limit value is defined by the standard or the user (see CALCulate:​LIMit:​BURSt:​EVM:​PILot:​MAXimum).

Return values:
<LimitCheck> | PASS The defined limit for the parameter was not exceeded. FAILED The defined limit for the parameter was exceeded.
Usage: | Query only


CALCulate:LIMit:BURSt:FERRor[:AVERage]:RESult?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Limit Check Results > CALCulate:LIMit:BURSt:FERRor[:AVERage]:RESult?
CALCulate:LIMit:BURSt:FERRor[:AVERage]:RESult?
CALCulate:LIMit:BURSt:FERRor:MAXimum:RESult?

This command returns the result of the average or maximum center frequency error limit check. The limit value is defined by the standard or the user (see CALCulate:​LIMit:​BURSt:​FERRor:​MAXimum).

Return values:
<LimitCheck> | PASS The defined limit for the parameter was not exceeded. FAILED The defined limit for the parameter was exceeded.
Usage: | Query only


CALCulate:LIMit:BURSt:IQOFfset[:AVERage]:RESult?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Limit Check Results > CALCulate:LIMit:BURSt:IQOFfset[:AVERage]:RESult?
CALCulate:LIMit:BURSt:IQOFfset[:AVERage]:RESult?
CALCulate:LIMit:BURSt:IQOFfset:MAXimum:RESult?

This command returns the result of the average or maximum I/Q offset limit check. The limit value is defined by the standard or the user (see CALCulate:​LIMit:​BURSt:​IQOFfset:​MAXimum).

Return values:
<LimitCheck> | PASS The defined limit for the parameter was not exceeded. FAILED The defined limit for the parameter was exceeded.
Usage: | Query only


CALCulate:LIMit:BURSt:SYMBolerror[:AVERage]:RESult?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Modulation Accuracy, Flatness and Tolerance Results > Limit Check Results > CALCulate:LIMit:BURSt:SYMBolerror[:AVERage]:RESult?
CALCulate:LIMit:BURSt:SYMBolerror[:AVERage]:RESult?
CALCulate:LIMit:BURSt:SYMBolerror:MAXimum:RESult?

This command returns the result of the average or maximum symbol clock error limit check. The limit value is defined by the standard or the user (see CALCulate:​LIMit:​BURSt:​SYMBolerror:​MAXimum).

Return values:
<LimitCheck> | PASS The defined limit for the parameter was not exceeded. FAILED The defined limit for the parameter was exceeded.
Usage: | Query only


Numeric Results for Frequency Sweep Measurements

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Results for Frequency Sweep Measurements
Numeric Results for Frequency Sweep Measurements

The following commands are required to retrieve the numeric results of the WLAN frequency sweep measurements (see "Frequency Sweep Measurements".

In the following commands used to retrieve the numeric results for RF data, the suffixes <n> for CALCulate and <k> for LIMit are irrelevant.

List of Commands
CALCulate:LIMit:ACPower:ACHannel:RESult?
CALCulate:LIMit:ACPower:ALTernate<ch>:RESult?
CALCulate:LIMit<k>:FAIL?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate<n>:MARKer<m>:X
CALCulate:STATistics:RESult<t>?


CALCulate:LIMit:ACPower:ACHannel:RESult?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Results for Frequency Sweep Measurements > CALCulate:LIMit:ACPower:ACHannel:RESult?
CALCulate:LIMit:ACPower:ACHannel:RESult?
CALCulate:LIMit:ACPower:ALTernate<ch>:RESult?

This command queries the state of the limit check for the adjacent or alternate channels in an ACLR measurement.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<LowerChan>, <UpperChan>
text value

The command returns two results. The first is the result for the lower, the second for the upper adjacent or alternate channel.

PASSED

Limit check has passed.

FAIL

Limit check has failed.

Example: INIT:IMM;*WAI;
CALC:LIM:ACP:ACH:RES?
PASSED,PASSED
Example:

See "Example: Configuring and Performing an ACLR Measurement" .

Usage: Query only


CALCulate:LIMit<k>:FAIL?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Results for Frequency Sweep Measurements > CALCulate:LIMit<k>:FAIL?
CALCulate:LIMit<k>:FAIL?

This command queries the result of a limit check.

For measurements in the R&S FSW WLAN application, the numeric suffix <k> specifies the limit line according to table "Limit line suffix <k> for WLAN application".

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result>
0

PASS

1

FAIL

Example: INIT;*WAI

Starts a new sweep and waits for its end.

CALC:LIM3:FAIL?

Queries the result of the check for limit line 3.

Example:

See "Example: SEM Measurement" .

Usage: Query only
SCPI confirmed
Manual operation: See "Spectrum Emission Mask"
Limit line suffix <k> for WLAN application
Suffix | Limit
1 to 2 | These indexes are not used
3 | Limit line for Spectrum Emission Mask as defined by ETSI
4 | Spectrum Flatness (Upper) limit line
5 | Spectrum Flatness (Lower) limit line
6 | Limit line for Spectrum Emission Mask as defined by IEEE
7 | PVT Rising Edge max limit
8 | PVT Rising Edge mean limit
9 | PVT Falling Edge max limit
10 | PVT Falling Edge mean limit


CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Results for Frequency Sweep Measurements > CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult? <Measurement>

This command queries the results of power measurements.

This command is only available for measurements on RF data (see "Frequency Sweep Measurements").

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement; for all other measurements: irrelevant

Query parameters:
<Measurement>
ACPower | MCACpower

ACLR measurements (also known as adjacent channel power or multicarrier adjacent channel measurements).

Returns the power for every active transmission and adjacent channel. The order is:

• power of the transmission channels

• power of adjacent channel (lower,upper)

• power of alternate channels (lower,upper)

MSR ACLR results:

For MSR ACLR measurements, the order of the returned results is slightly different:

• power of the transmission channels

• total power of the transmission channels for each sub block

• power of adjacent channels (lower, upper)

• power of alternate channels (lower, upper)

• power of gap channels (lower1, upper1, lower2, upper2)

The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

CN

Carrier-to-noise measurements.

Returns the C/N ratio in dB.

CN0

Carrier-to-noise measurements.

Returns the C/N ratio referenced to a 1 Hz bandwidth in dBm/Hz.

CPOWer

Channel power measurements.

Returns the channel power. The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

For SEM measurements, the return value is the channel power of the reference range (in the specified sub block).

PPOWer

Peak power measurements.

Returns the peak power. The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

For SEM measurements, the return value is the peak power of the reference range (in the specified sub block).

OBANdwidth | OBWidth

Occupied bandwidth.

Returns the occupied bandwidth in Hz.

Example:

See "Example: Configuring and Performing an ACLR Measurement" .

Example:

See "Example: Configuring and Performing an MSR ACLR Measurement" .

Example:

See "Programming example" .

Example:

See "Programming Example: OBW Measurement" .

Example:

See "Programming Examples (-K73)" .

Example:

See "Programming Examples ( BTS)"

Usage: Query only
Manual operation: See "Channel Power ACLR"
See "Occupied Bandwidth"


CALCulate<n>:MARKer<m>:X

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Results for Frequency Sweep Measurements > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker Table"
See "Marker Peak List"


CALCulate:STATistics:RESult<t>?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Numeric Results for Frequency Sweep Measurements > CALCulate:STATistics:RESult<t>?
CALCulate:STATistics:RESult<t>? <ResultType>

This command queries the results of a CCDF or ADP measurement for a specific trace.

Parameters:
<ResultType>
MEAN

Average (=RMS) power in dBm measured during the measurement time.

PEAK

Peak power in dBm measured during the measurement time.

CFACtor

Determined crest factor (= ratio of peak power to average power) in dB.

ALL

Results of all three measurements mentioned before, separated by commas: <mean power>,<peak power>,<crest factor>

Example: CALC:STAT:RES2? ALL

Reads out the three measurement results of trace 2. Example of answer string: 5.56,19.25,13.69 i.e. mean power: 5.56 dBm, peak power 19.25 dBm, crest factor 13.69 dB

Example:

See "Programming Example: Measuring Statistics" .

Usage: Query only
Manual operation: See "CCDF"


Retrieving Trace Results

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Retrieving Trace Results
Retrieving Trace Results

The following commands describe how to retrieve the trace data from the WLAN IQ measurement (Modulation Accuracy, Flatness and Tolerance). Note that for these measurements, only 1 trace per window can be configured.

The traces for frequency sweep measurements are identical to those in the Spectrum application.

Useful commands for retrieving results described elsewhere:
  • DISPlay[:​WINDow<n>]:​SELect
Remote commands exclusive to retrieving trace results:
List of Commands
FORMat[:DATA]
[SENSe:]BURSt:SELect
[SENSe:]BURSt:SELect:STATe
TRACe<n>[:DATA]
TRACe<n>[:DATA]:X?
TRACe:IQ:DATA:MEMory


FORMat[:DATA]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Retrieving Trace Results > FORMat[:DATA]
FORMat[:DATA] <Format>

This command selects the data format that is used for transmission of trace data from the R&S FSW to the controlling computer.

Note that the command has no effect for data that you send to the R&S FSW. The R&S FSW automatically recognizes the data it receives, regardless of the format.

Parameters:
<Format>
ASCii

ASCii format, separated by commas.

This format is almost always suitable, regardless of the actual data format. However, the data is not as compact as other formats may be.

REAL,32

32-bit IEEE 754 floating-point numbers in the "definite length block format".

In the Spectrum application, the format setting REAL is used for the binary transmission of trace data.

For I/Q data, 8 bytes per sample are returned for this format setting.

UINT

In the R&S FSW WLAN application, bitstream data can be sent as unsigned integers format to improve the data transfer speed (compared to ASCII format).

*RST: ASCII
Example: FORM REAL,32
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Usage: SCPI confirmed


[SENSe:]BURSt:SELect

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Retrieving Trace Results > [SENSe:]BURSt:SELect
[SENSe:]BURSt:SELect <Value>

This command selects the PPDU for which the trace data is queried (using TRACe<n>[:​DATA]) for the "EVM vs Symbol" and "EVM vs Carrier" result displays if [SENSe:​]BURSt:​SELect:​STATe is ON.

The selected PPDU does not affect the corresponding graphical trace displays.

Parameters:
<Value>
Range: | 1 to <statistic count>
*RST: | 1
Example: LAY:WIND2:REPL EVSY
SENS:BURS:SEL:STAT ON
SENS:BURS:SEL 10
TRAC2:DATA? TRACE1

Returns the trace results for the PPDU number 10 in window 2 ("EVM vs Symbol").


[SENSe:]BURSt:SELect:STATe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Retrieving Trace Results > [SENSe:]BURSt:SELect:STATe
[SENSe:]BURSt:SELect:STATe <State>

Determines whether a selected PPDU (using [SENSe:​]BURSt:​SELect) is considered or ignored.

Parameters:
<State>
ON | OFF
ON

Only the results for the selected PPDU are considered by a subsequent TRACe<n>[:​DATA] query for "EVM vs Symbol" and "EVM vs Carrier" result displays.

OFF

"EVM vs Symbol" result display: query returns all detected PPDUs in the current capture buffer

"EVM vs Carrier" result display: query returns the statistical results for all analyzed PPDUs

*RST: OFF
Example: LAY:WIND2:REPL EVSY
SENS:BURS:SEL:STAT ON
SENS:BURS:SEL 10
TRAC2:DATA? TRACE1

Returns the trace results for the PPDU number 10 in window 2 ("EVM vs Symbol").


TRACe<n>[:DATA]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]
TRACe<n>[:DATA] <ResultType>

This command queries current trace data and measurement results from the window previously selected using DISPlay[:​WINDow<n>]:​SELect.

As opposed to the R&S FSW base unit, the window suffix <n> is not considered in the R&S FSW WLAN application! Use the DISPlay[:​WINDow<n>]:​SELect to select the window before you query trace results!

For details see "Measurement Results for TRACe<n>[:DATA]? TRACE<n>".

Suffix: |
<n> | irrelevant
Parameters:
<ResultType> | Selects the type of result to be returned. TRACE1 | ... | TRACE6 Returns the trace data for the corresponding trace. Note that for the default WLAN I/Q measurement (Modulation Accuracy, Flatness and Tolerance), only 1 trace per window (TRACE1) is available. LIST Returns the results of the peak list evaluation for Spectrum Emission Mask measurements.
Return values:
<TraceData> | For more information see tables below.
Example: | DISP:WIND2:SEL TRAC? TRACE3 Queries the data of trace 3 in window 2.
Manual operation: | See "Spectrum Emission Mask"
Return values for TRACE1 to TRACE6 parameter

For I/Q data traces, the results depend on the evaluation method (window type) selected for the current window (see LAYout:​ADD[:​WINDow]?. The results for the various window types are described in "Measurement Results for TRACe<n>[:DATA]? TRACE<n>".

For RF data traces, the trace data consists of a list of 1001 power levels that have been measured. The unit depends on the measurement and on the unit you have currently set.

For SEM measurements, the x-values should be queried as well, as they are not equi-distant (see TRACe<n>[:​DATA]:​X?).

Return values for LIST parameter

This parameter is only available for SEM measurements.

For each sweep list range you have defined (range 1...n), the command returns eight values in the following order.

<No>,<StartFreq>,<StopFreq>,<RBW>,<PeakFreq>,<PowerAbs>,<PowerRel>,<PowerDelta>,<LimitCheck>,<Unused1>,<Unused2>

  • <No>: range number
  • <StartFreq>,<StopFreq>: start and stop frequency of the range
  • <RBW>: resolution bandwidth
  • <PeakFreq>: frequency of the peak in a range
  • <PowerAbs>: absolute power of the peak in dBm
  • <PowerRel>: power of the peak in relation to the channel power in dBc
  • <PowerDelta>: distance from the peak to the limit line in dB, positive values indicate a failed limit check
  • <LimitCheck>: state of the limit check (0 = PASS, 1 = FAIL)
  • <Unused1>,<Unused2>: reserved (0.0)


TRACe<n>[:DATA]:X?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]:X? <TraceNumber>

This command queries the horizontal trace data for each sweep point in the specified window, for example the frequency in frequency domain or the time in time domain measurements.

This is especially useful for traces with non-equidistant x-values, e.g. for SEM or Spurious Emissions measurements.

Query parameters:
<TraceNumber> | Trace number. TRACE1 | ... | TRACE6
Example: | TRAC3:X? TRACE1 Returns the x-values for trace 1 in window 3.
Usage: | Query only


TRACe:IQ:DATA:MEMory

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Retrieving Trace Results > TRACe:IQ:DATA:MEMory
TRACe:IQ:DATA:MEMory <OffsetSamp>, <NumSamples>

Returns all the I/Q trace data in the capture buffer. The result values are scaled in Volts. The command returns a comma-separated list of the measured voltage values in floating point format (Comma Separated Values = CSV). The number of values returned is 2 * the number of complex samples, the first half being the I values, the second half the Q values.

The total number of complex samples is displayed in the channel bar in manual operation and can be calculated as:

<SampleRate> * <CaptureTime>

(See TRACe:​IQ:​SRATe and [SENSe:​]SWEep:​TIME)

Parameters:
<OffsetSamp>

Offset of the values to be read related to the start of the capture buffer.

Range: 0 to (<NumSamples>-1)
<NumSamples>

Number of measurement values to be read.

Range: | 1 to (<NumSamples>-<OffsetSa>)
*RST: | RST value


Measurement Results for TRACe<n>[:DATA]? TRACE<n>

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n>
Measurement Results for TRACe<n>[:DATA]? TRACE<n>

The evaluation method selected by the LAY:ADD:WIND command also affects the results of the trace data query (see TRACe<n>[:DATA]? TRACE<n>).

Details on the returned trace data depending on the evaluation method are provided here.

No trace data is available for the following evaluation methods:

  • Magnitude Capture
  • Result Summary (Global/Detailed)

As opposed to the R&S FSW base unit, the window suffix <n> is not considered in the R&S FSW WLAN application! Use the DISPlay[:​WINDow<n>]:​SELect to select the window before you query trace results!

For details on the graphical results of these evaluation methods, see "Evaluation Methods for WLAN IQ Measurements".

The following table provides an overview of the main characteristics of the WLAN OFDM symbol structure in the frequency domain for various standards. The description of the TRACe results refers to these values to simplify the description.

WLAN OFDM symbol structure in the frequency domain
Stan dard | CBW /MHz | NFFT | NSD No. of data sc | NSP No. of pilot sc | Pilot subcarrier (sc) | NST No. of sc total :=NSD +NSP | NNull No. of DC/Null sc | DC / Null subcarrier | Nused No. of used sc := NST + NNull | Nguard :=NFFT -Nused | Comment
11a, p | 5 | 64 | 48 | 4 | {-21,-7,7,21} | 52 | 1 | {0} | 53 | 11 | IEEE Std 802.11-2012 Tab Table 18-5—Timing-related parameters
 | 10 | 64 | 48 | 4 | {-21,-7,7,21} | 52 | 1 | {0} | 53 | 11 | IEEE Std 802.11-2012 Tab Table 18-5—Timing-related parameters
 | 20 | 64 | 48 | 4 | {-21,-7,7,21} | 52 | 1 | {0} | 53 | 11 | IEEE Std 802.11-2012 Tab Table 18-5—Timing-related parameters
11n | 20 | 64 | 52 | 4 | {-21,-7,7,21}1) | 56 | 1 | {0} | 57 | 7 | IEEE Std 802.11-2012 Tab Table 20-6—Timing-related constants
 | 40 | 128 | 108 | 6 | {-53, -25, -11, 11, 25, 53}1) | 114 | 3 | {-1,0,1}3) | 117 | 11 | IEEE Std 802.11-2012 Tab Table 20-6—Timing-related constants
11ac | 20 | 64 | 52 | 4 | {-21,-7,7,21}2 | 56 | 1 | {0} | 57 | 7 | IEEE P802.11ac/D2.1, March 2012 Table 22-5—Timing-related constants
 | 40 | 128 | 108 | 6 | {-53, -25, -11, 11, 25, 53}2) | 114 | 3 | {-1,0,1}4) | 117 | 11 | IEEE P802.11ac/D2.1, March 2012 Table 22-5—Timing-related constants
 | 80 | 256 | 234 | 8 | {–103, –75, –39, –11, 11, 39, 75,103}2) | 242 | 3 | {-1,0,1}5) | 245 | 11 | IEEE P802.11ac/D2.1, March 2012 Table 22-5—Timing-related constants
 | 160 | 512 | 468 | 16 | { -231, -203, -167, -139, - 117, -89, -53, -25, 25, 53, 89, 117, 139, 167, 203, 231}2) | 484 | 17 | {-129, -128, -127, -5:1:5, 127, 128, 129}6) | 501 | 11 | IEEE P802.11ac/D2.1, March 2012 Table 22-5—Timing-related constants
1) IEEE Std 802.11-2012 Section 20.3.11.10 Pilot subcarriers 2) IEEE P802.11ac/D2.1, March 2012 Section 22.3.10.10 Pilot subcarriers 3) IEEE Std 802.11-2012 equation (20-59) 4) IEEE P802.11ac/D2.1, March 2012 equation (22-94) 5) IEEE P802.11ac/D2.1, March 2012 equation (22-95) 6) IEEE P802.11ac/D2.1, March 2012 equation (22-96)
Contents
  • AM/AM
  • AM/PM
  • AM/EVM
  • Bitstream
  • CCDF – Complementary Cumulative Distribution Function
  • Constellation
  • Constellation vs Carrier
  • EVM vs Carrier
  • Error vs Preamble
  • FFT Spectrum
  • Group Delay
  • Power vs Time - Full Burst and Rising/Falling Data
  • Signal Field
  • Spectrum Flatness


AM/AM

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > AM/AM
AM/AM

For each sample, the x-axis value represents the amplitude of the reference-signal and the y-axis value represents the amplitude of the measured-signal.

Note: The measured signal and reference signal are complex signals.


AM/PM

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > AM/PM
AM/PM

For each sample, the x-axis value represents the amplitude of the reference signal. The y-axis value represents the angle difference of the measured signal minus the reference signal.

Note: The measured signal and reference signal are complex signals.


AM/EVM

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > AM/EVM
AM/EVM

For each sample, the x-axis value represents the amplitude of the reference-signal. The y-axis value represents the length of the error vector between the measured signal and the reference signal.

Note: The measured signal and reference signal are complex signals.


Bitstream

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Bitstream
Bitstream

Data is returned depending on the selected standard for which the measurement was executed (see CONFigure:​STANdard):

IEEE 802.11a, p, n and ac standard (OFDM physical layers)

For a given OFDM symbol and a given subcarrier, the bitstream result is derived from the corresponding complex constellation point according to Std IEEE802.11-2012 "Figure 18-10—BPSK, QPSK, 16-QAM, and 64-QAM constellation bit encoding". The bit pattern (binary representation) is converted to its equivalent integer value as the final measurement result. The number of values returend for each analyzed OFDM symbol corresponds to the number of data subcarriers plus the number of pilot subcariers (NSD+NSP) in remote mode.

As opposed to the graphical Bitstream results, the DC and NULL carriers are not available in remote mode.

Standard | CBW in MHz | NSD (Number of data subcarriers) | NSP (Number of pilot subcarriers) | NST (Total number of subcarriers: NSD+NSP)
IEEE 802.11a, p | 5 | 48 | 4 | 52
IEEE 802.11a, p | 10 | 48 | 4 | 52
IEEE 802.11a, p | 20 | 48 | 4 | 52
IEEE 802.11n | 20 | 52 | 4 | 56
IEEE 802.11n | 40 | 108 | 6 | 114
IEEE 802.11ac | 20 | 52 | 4 | 56
IEEE 802.11ac | 40 | 108 | 6 | 114
IEEE 802.11ac | 80 | 234 | 8 | 242
IEEE 802.11ac | 160 | 468 | 16 | 484
IEEE 802.11b and g (DSSS) standard (DSSS physical layers)

For the IEEE 802.11b and g (DSSS) standard, the data is returned in PPDU order. Each PPDU is represented as a series of bytes. For each PPDU, the first 9 or 18 bytes represent the PLCP preamble for short and long PPDU types, respectively. The next 6 bytes represent the PLCP header. The remaining bytes represent the PSDU. Data is returned in ASCII printable hexadecimal character format.

TRACE1 is used for these measurement results.


CCDF – Complementary Cumulative Distribution Function

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > CCDF – Complementary Cumulative Distribution Function
CCDF – Complementary Cumulative Distribution Function

The length of the results varies; up to a maximum of 201 data points is returned, following a data count value. The first value in the return data represents the quantity of probability values that follow. Each of the potential 201 data points is returned as a probability value and represents the total number of samples that are equal to or exceed the current mean power level.

Probability data is returned up to the power level that contains at least one sample. It is highly unlikely that the full 201 data values will ever be returned.

Each probability value is returned as a floating point number, with a value between 0 and 1.

The syntax of the result is thus:

N, CCDF(0), CCDF(1/10), CCDF(2/10), …, CCDF((N-1)/10)


Constellation

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Constellation
Constellation

This measurement represents the complex constellation points as I and Q data. See for example IEEE Std. 802.11-2012 'Fig. 18-10 BPSK, QPSK, 16-QAM and 64-QAM constellation bit encoding'. Each I and Q point is returned in floating point format.

Data is returned as a repeating array of interleaved I and Q data in groups of selected carriers per OFDM-Symbol, until all the I and Q data for the analyzed OFDM-Symbols is exhausted.

The following carrier selections are possible:

  • "All Carriers": CONFigure:BURSt:CONStellation:CARRier:SELect ALL
    NST pairs of I and Q data per OFDM-Symbol
    OFDM-Symbol 1: (I1,1, Q1,1), (I1,2,Q1,2), …,( I1,Nst, Q1,Nst)
    OFDM-Symbol 2: (I2,1, Q2,1), (I2,2,Q2,2),…,( I2,Nst, Q2,Nst)
    …
    OFDM-Symbol N:
    (IN,1, QN,1), (IN,2,QN,2),…,( IN,Nst, QN,Nst)
  • "Pilots Only": CONFigure:BURSt:CONStellation:CARRier:SELect PILOTS
    NSP pairs of I and Q data per OFDM-Symbol in the natural number order.
    OFDM-Symbol 1: (I1,1, Q1,1), (I1,2,Q1,2), …,( I1,Nsp, Q1,Nsp)
    OFDM-Symbol 2: (I2,1, Q2,1), (I2,2,Q2,2),…,( I2,Nsp, Q2,Nsp)
    …
    OFDM-Symbol N:
    (IN,1, QN,1), (IN,2,QN,2),…,( IN,Nsp, QN,Nsp)
  • Single carrier:
    1 pair of I and Q data per OFDM-Symbol for the selected carrier
    CONFigure:BURSt:CONStellation:CARRier:SELect k
    with

    OFDM-Symbol 1: (I1,1, Q1,1)
    OFDM-Symbol 2: (I2,1, Q2,1)
    …
    OFDM-Symbol N: (IN,1, QN,1)


Constellation vs Carrier

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Constellation vs Carrier
Constellation vs Carrier

This measurement represents the complex constellation points as I and Q data. See for example IEEE Std. 802.11-2012 'Fig. 18-10 BPSK, QPSK, 16-QAM and 64-QAM constellation bit encoding'. Each I and Q point is returned in floating point format. Data is returned as a repeating array of interleaved I and Q data in groups of Nused subcarriers per OFDM-Symbol, until all the I and Q data for the analyzed OFDM-Symbols is exhausted.

Note that as opposed to the Constellation results, the DC/null subcarriers are included as NaNs.

Nused pairs of I and Q data per OFDM-Symbol

OFDM-Symbol 1: (I1,1, Q1,1), (I1,2,Q1,2), …,( I1,Nused, Q1,Nused)

OFDM-Symbol 2: (I2,1, Q2,1), (I2,2,Q2,2),…,( I2,Nused, Q2,Nused)

…

OFDM-Symbol N:

(IN,1, QN,1), (IN,2,QN,2),…,( IN,Nused, QN,Nused)


EVM vs Carrier

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > EVM vs Carrier
EVM vs Carrier

Three trace types are provided for this evaluation:

Query parameter and results for EVM vs Carrier
TRACE1 | The minimum EVM value - over the analyzed PPDUs - for each of the Nused subcarriers
TRACE2 | The average EVM value - over the analyzed PPDUs - for each of the Nused subcarriers
TRACE3 | The maximum EVM value - over the analyzed PPDUs - for each of the Nused subcarriers

Each EVM value is returned as a floating point number, expressed in units of dB.

Supported data formats (see FORMat[:​DATA]): ASCii|UINT

Example:

For EVMm,n: the EVM of the m-th analyzed PPDU for the subcarrier n = {1,2,…, Nused }

TRACE1: Minimum EVM value per subcarrier

Minimum(EVM1,1, EVM2,1,…. EVMStatistic Length,1),

//Minimum EVM value for subcarrier –(Nused-1)/2

Minimum(EVM1,2, EVM2,2,…. EVMStatistic Length,2),

// Minimum EVM value for subcarrier –(Nused-1)/2 + 1

…,

Minimum(EVM1,Nused ,EVM2,Nused ,…. EVMStatistic Length,Nused)

// Minimum EVM value for subcarrier +(Nused-1)/2


Error vs Preamble

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Error vs Preamble
Error vs Preamble

Three traces types are available with this measurement. The basic trace types show either the minimum, mean or maximum frequency or phase value as measured over the preamble part of the PPDU.

Supported data formats (see FORMat[:​DATA]): ASCii|REAL


FFT Spectrum

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > FFT Spectrum
FFT Spectrum

Returns the power vs frequency values obtained from the FFT. This is an exhaustive call, due to the fact that there are nearly always more FFT points than I/Q samples. The number of FFT points is a power of 2 that is higher than the total number of I/Q samples, i.e.; number of FFT points := round number of I/Q-samples to next power of 2.

E.g. if there were 20000 samples, then 32768 FFT points are returned.

Data is returned in floating point format in dBm.


Group Delay

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Group Delay
Group Delay

Currently the following trace types are provided with this measurement:

  • TRACE1
    A repeating list of group delay values for each subcarrier. The number of repeating lists corresponds to the number of fully analyzed PPDUs as displayed in the current Magnitude Capture. Each group delay value is returned as a floating point number, expressed in units of seconds.
  • TRACE
    All group delay values per subcarrier for each analyzed PPDU of the capture period
Example:

For GDm,n: the group delay of the m-th analyzed PPDU for the subcarrier corresponding to n = {1,2,…, Nused };

TRACE:DATA? TRACE2

Analyzed PPDU 1:

GD1,1, GD1,2, …,

Analyzed PPDU 2:

GD2,1, GD2,2, …,

…

Analyzed PPDU N :

GDN,1, GDN,2, …,


Power vs Time - Full Burst and Rising/Falling Data

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Power vs Time - Full Burst and Rising/Falling Data
Power vs Time - Full Burst and Rising/Falling Data

All complete PPDUs within the capture time are analyzed in three master PPDUs. The three master PPDUs relate to the minimum, maximum and average values across all complete PPDUs. This data is returned in dBm values on a per sample basis. Each sample relates to an analysis of each corresponding sample within each processed PPDU.

For PVT Rising and PVT Falling displays, the results are restricted to the rising or falling edge of the analyzed PPDUs.

The type of PVT data returned is determined by the TRACE number passed as an argument to the SCPI command:

TRACE1 | minimum PPDU data values
TRACE2 | mean PPDU data values
TRACE3 | maximum PPDU data values

Supported data formats (see FORMat[:​DATA]): ASCii|REAL


Signal Field

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Signal Field
Signal Field

The bits are returned as read from the corresponding signal field parts in transmit order. I.e. the first transmitted bit has the highest significance and the last transmitted bit has the lowest significance. See also "Signal Field".

The TRAC:DATA? command returns the information as read from the signal field for each analyzed PPDU. The signal field bit sequence is converted to an equivalent sequence of hexadecimal digits for each analyzed PPDU in transmit order.


Spectrum Flatness

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Spectrum Flatness
Spectrum Flatness

The spectrum flatness evaluation returns absolute power values per carrier.

Two trace types are provided for this evaluation:

Query parameter and results for Spectrum Flatness
TRACE1 | All spectrum flatness values per channel
TRACE2 | An average spectrum flatness value for each of the 53 (or 57/117 within the IEEE 802.11 n standard) carriers

Absolute power results are returned in dB.

Supported data formats (FORMat:DATA): ASCii|REAL


Importing and Exporting I/Q Data and Results

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Importing and Exporting I/Q Data and Results
Importing and Exporting I/Q Data and Results

The I/Q data to be evaluated in the WLAN application can not only be measured by the WLAN application itself, it can also be imported to the application, provided it has the correct format. Furthermore, the evaluated I/Q data from the WLAN application can be exported for further analysis in external applications.

For details on importing and exporting I/Q data see "I/Q Data Import and Export".

List of Commands
MMEMory:LOAD:IQ:STATe
MMEMory:STORe:IQ:STATe


MMEMory:LOAD:IQ:STATe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Importing and Exporting I/Q Data and Results > MMEMory:LOAD:IQ:STATe
MMEMory:LOAD:IQ:STATe 1,<FileName>

This command restores I/Q data from a file.

The file extension is *.iqw.

Parameters:
<FileName> | String containing the path and name of the source file.
Example: | MMEM:LOAD:IQ:STAT 1, 'C:\R_S\Instr\user\data.iqw' Loads IQ data from the specified file.
Usage: | Setting only


MMEMory:STORe:IQ:STATe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Retrieving Results > Importing and Exporting I/Q Data and Results > MMEMory:STORe:IQ:STATe
MMEMory:STORe:IQ:STATe 1, <FileName>

This command writes the captured I/Q data to a file.

The file extension is *.iq.tar. By default, the contents of the file are in 32-bit floating point format.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
1 |
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar' Stores the captured I/Q data to the specified file.


Analysis

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Analysis
Analysis

The following commands define general result analysis settings concerning the traces and markers in standard WLAN measurements. Currently, only one (Clear/Write) trace and one marker are available for standard WLAN measurements.

Analysis for RF measurements

General result analysis settings concerning the trace, markers, lines etc. for RF measurements are identical to the analysis functions in the Spectrum application except for some special marker functions and spectrograms, which are not available in the WLAN application.

See
  • "Zooming into the Display"
  • "Configuring the Trace Display and Retrieving Trace Data"
  • "Working with Markers"
Contents
  • Markers
  • Zooming into the Display


Markers

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Analysis > Markers
Markers

Markers help you analyze your measurement results by determining particular values in the diagram. Currently, only 1 marker per window can be configured for standard WLAN measurements.

List of Commands
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:Y?


CALCulate<n>:MARKer<m>[:STATe]

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Analysis > Markers > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.


CALCulate<n>:MARKer<m>:Y?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Analysis > Markers > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | Result at the marker position.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only
Manual operation: | See "CCDF" See "Marker Table" See "Marker Peak List"


Zooming into the Display

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Analysis > Zooming into the Display
Zooming into the Display
Contents
  • Using the Single Zoom
  • Using the Multiple Zoom


Using the Single Zoom

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Analysis > Zooming into the Display > Using the Single Zoom
Using the Single Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:STATe


DISPlay[:WINDow<n>]:ZOOM:AREA

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Analysis > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT


DISPlay[:WINDow<n>]:ZOOM:STATe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Analysis > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe <State>

This command turns the zoom on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:ZOOM ON

Activates the zoom mode.


Using the Multiple Zoom

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Analysis > Zooming into the Display > Using the Multiple Zoom
Using the Multiple Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Analysis > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area for a multiple zoom.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Suffix:
<zoom>
1...4

Selects the zoom window.

Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Analysis > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe <State>

This command turns the mutliple zoom on and off.

Suffix:
<zoom>
1...4

Selects the zoom window.

If you turn off one of the zoom windows, all subsequent zoom windows move up one position.

Parameters:
<State>
ON | OFF
*RST: OFF


Status Registers

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers
Status Registers

The WLAN application uses the standard status registers of the R&S FSW (depending on the measurement type). However, some registers are used differently. Only those differences are described in the following sections.

For details and a description of the common R&S FSW status registers see "Status Reporting System" .

*RST does not influence the status registers.

Contents
  • The STATus:QUEStionable:SYNC Register
  • STATus:QUEStionable:DIQ Register
  • Querying the Status Registers


The STATus:QUEStionable:SYNC Register

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > The STATus:QUEStionable:SYNC Register
The STATus:QUEStionable:SYNC Register

The STATus:QUEStionable:SYNC register contains application-specific information about synchronization errors or errors during pilot symbol detection. If any errors occur in this register, the status bit #11 in the STATus:QUEStionable register is set to 1.

Each active channel uses a separate STATus:QUEStionable:SYNC register. Thus, if the status bit #11 in the STATus:QUEStionable register indicates an error, the error may have occurred in any of the channel-specific STATus:QUEStionable:SYNC registers. In this case, you must check the register of each channel to determine which channel caused the error. By default, querying the status of a register always returns the result for the currently selected channel. However, you can specify any other channel name as a query parameter.

Meaning of the bits used in the STATus:QUEStionable:SYNC register
Bit No. | Meaning
0 | PPDU not found This bit is set if an IQ measurement is performed and no PPDUs are detected
1 | This bit is not used
2 | No PPDUs of REQuired type This bit is set if an IQ measurement is performed and no PPDUs of the specified type are detected
3 | GATE length too small This bit is set if gating is used in a measurement and the gate length is not set sufficiently large enough
4 | PPDU count too small This bit is set if a PVT measurement is performed with gating active and there is not at least 1 PPDU within the gate lines
5 | Auto level OVERload This bit is set if a signal overload is detected when an auto-level measurement is performed
6 | Auto level NoSIGnal This bit is set if no signal is detected by the auto-level measurement
7 - 14 | These bits are not used.
15 | This bit is always 0.


STATus:QUEStionable:DIQ Register

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > STATus:QUEStionable:DIQ Register
STATus:QUEStionable:DIQ Register

This register contains information about the state of the digital I/Q input and output. This register is available with option Digital Baseband Interface (R&S FSW-B17)Digital Baseband Interface (R&S FSW-B17).

The status of the STATus:QUESTionable:DIQ register is indicated in bit 14 of the STATus:QUESTionable register.

You can read out the state of the register with STATus:​QUEStionable:​DIQ:​CONDition? and STATus:​QUEStionable:​DIQ[:​EVENt]?.

Bit No.

Meaning

0

Digital I/Q Input Device connected

This bit is set if a device is recognized and connected to the Digital Baseband Interface of the analyzer.

1

Digital I/Q Input Connection Protocol in progress

This bit is set while the connection between analyzer and digital baseband data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

2

Digital I/Q Input Connection Protocol error

This bit is set if an error occurred during establishing of the connect between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

3

Digital I/Q Input PLL unlocked

This bit is set if the PLL of the Digital I/Q input is out of lock due to missing or unstable clock provided by the connected Digital I/Q TX device. To solve the problem the Digital I/Q connection has to be newly initialized after the clock has been restored.

4

Digital I/Q Input DATA Error

This bit is set if the data from the Digital I/Q input module is erroneous. Possible reasons:

  • Bit errors in the data transmission. The bit will only be set if an error occurred at the current measurement.
  • Protocol or data header errors. May occurred at data synchronization problems or vast transmission errors. The bit will be set constantly and all data will be erroneous. To solve the problem the Digital I/Q connection has to be newly initialized.

NOTE: If this error is indicated repeatedly either the Digital I/Q LVDS connection cable or the receiving or transmitting device might be defect.

5

not used

6

Digital I/Q Input FIFO Overload

This bit is set if the sample rate on the connected instrument is higher than the input sample rate setting on the R&S FSW. Possible solution:

  • Reduce the sample rate on the connected instrument
  • Increase the input sample rate setting on the R&S FSW

7

not used

8

Digital I/Q Output Device connected

This bit is set if a device is recognized and connected to the Digital I/Q Output.

9

Digital I/Q Output Connection Protocol in progress

This bit is set while the connection between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

10

Digital I/Q Output Connection Protocol error

This bit is set if an error occurred while the connection between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

11

Digital I/Q Output FIFO Overload

This bit is set if an overload of the Digital I/Q Output FIFO occurred. This happens if the output data rate is higher than the maximal data rate of the connected instrument. Reduce the sample rate to solve the problem.

12-14

not used

15

This bit is always set to 0.

List of Commands
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ[:EVENt]?


STATus:QUEStionable:DIQ:CONDition?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:CONDition? <ChannelName>

This command reads out the CONDition section of the STATus:QUEStionable:DIQ:CONDition status register.

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Example: | STAT:QUES:DIQ:COND?
Usage: | Query only


STATus:QUEStionable:DIQ:ENABle

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:ENABle <BitDefinition>, <ChannelName>

This command controls the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to be reported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<SumBit>
Range: 0 to 65535
Usage: SCPI confirmed


STATus:QUEStionable:DIQ:NTRansition

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:NTRansition <BitDefinition>,<ChannelName>

This command controls the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<BitDefinition>
Range: 0 to 65535


STATus:QUEStionable:DIQ:PTRansition

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ:PTRansition <BitDefinition>,<ChannelName>

This command controls the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<BitDefinition>
Range: 0 to 65535


STATus:QUEStionable:DIQ[:EVENt]?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:DIQ[:EVENt]? <ChannelName>

This command queries the contents of the "EVENt" section of the STATus:QUEStionable:DIQ register for IQ measurements.

Readout deletes the contents of the "EVENt" section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Example: | STAT:QUES:DIQ?
Usage: | Query only


Querying the Status Registers

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers
Querying the Status Registers

The following commands are required to query the status of the R&S FSW and the WLAN application.

For information on the contents of the WLAN-specific status register see "The STATus:QUEStionable:SYNC Register".

For details and a description of the common R&S FSW status registers see "Status Reporting System" .

Contents
  • General Status Register Commands
  • Reading Out the EVENt Part
  • Reading Out the CONDition Part
  • Controlling the ENABle Part
  • Controlling the Negative Transition Part
  • Controlling the Positive Transition Part


General Status Register Commands

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers > General Status Register Commands
General Status Register Commands
List of Commands
STATus:PRESet
STATus:QUEue[:NEXT]?


STATus:PRESet

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers > General Status Register Commands > STATus:PRESet
STATus:PRESet

This command resets the edge detectors and ENABle parts of all registers to a defined value. All PTRansition parts are set to FFFFh, i.e. all transitions from 0 to 1 are detected. All NTRansition parts are set to 0, i.e. a transition from 1 to 0 in a CONDition bit is not detected. The ENABle part of the STATus:OPERation and STATus:QUEStionable registers are set to 0, i.e. all events in these registers are not passed on.

Usage: Event


STATus:QUEue[:NEXT]?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers > General Status Register Commands > STATus:QUEue[:NEXT]?
STATus:QUEue[:NEXT]?

This command queries the most recent error queue entry and deletes it.

Positive error numbers indicate device-specific errors, negative error numbers are error messages defined by SCPI. If the error queue is empty, the error number 0, "No error", is returned.

Usage: Query only


Reading Out the EVENt Part

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers > Reading Out the EVENt Part
Reading Out the EVENt Part
List of Commands
STATus:OPERation[:EVENt]?
STATus:QUEStionable[:EVENt]?
STATus:QUEStionable:ACPLimit[:EVENt]?
STATus:QUEStionable:LIMit<n>[:EVENt]?
STATus:QUEStionable:SYNC[:EVENt]?


STATus:OPERation[:EVENt]?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers > Reading Out the EVENt Part > STATus:OPERation[:EVENt]?
STATus:OPERation[:EVENt]?
STATus:QUEStionable[:EVENt]?
STATus:QUEStionable:ACPLimit[:EVENt]? <ChannelName>
STATus:QUEStionable:LIMit<n>[:EVENt]? <ChannelName>
STATus:QUEStionable:SYNC[:EVENt]? <ChannelName>

This command reads out the EVENt section of the status register.

The command also deletes the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


Reading Out the CONDition Part

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers > Reading Out the CONDition Part
Reading Out the CONDition Part
List of Commands
STATus:OPERation:CONDition?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:ACPLimit:CONDition?
STATus:QUEStionable:LIMit<n>:CONDition?
STATus:QUEStionable:SYNC:CONDition?


STATus:OPERation:CONDition?

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers > Reading Out the CONDition Part > STATus:OPERation:CONDition?
STATus:OPERation:CONDition?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:ACPLimit:CONDition? <ChannelName>
STATus:QUEStionable:LIMit<n>:CONDition? <ChannelName>
STATus:QUEStionable:SYNC:CONDition? <ChannelName>

This command reads out the CONDition section of the status register.

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


Controlling the ENABle Part

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers > Controlling the ENABle Part
Controlling the ENABle Part
List of Commands
STATus:OPERation:ENABle
STATus:QUEStionable:ENABle
STATus:QUEStionable:ACPLimit:ENABle
STATus:QUEStionable:LIMit<n>:ENABle
STATus:QUEStionable:SYNC:ENABle


STATus:OPERation:ENABle

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers > Controlling the ENABle Part > STATus:OPERation:ENABle
STATus:OPERation:ENABle <SumBit>
STATus:QUEStionable:ENABle <SumBit>
STATus:QUEStionable:ACPLimit:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit<n>:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:SYNC:ENABle <BitDefinition>, <ChannelName>

This command controls the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to be reported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Controlling the Negative Transition Part

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers > Controlling the Negative Transition Part
Controlling the Negative Transition Part
List of Commands
STATus:OPERation:NTRansition
STATus:QUEStionable:NTRansition
STATus:QUEStionable:ACPLimit:NTRansition
STATus:QUEStionable:LIMit<n>:NTRansition
STATus:QUEStionable:SYNC:NTRansition


STATus:OPERation:NTRansition

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers > Controlling the Negative Transition Part > STATus:OPERation:NTRansition
STATus:OPERation:NTRansition <SumBit>
STATus:QUEStionable:NTRansition <SumBit>
STATus:QUEStionable:ACPLimit:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit<n>:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:SYNC:NTRansition <BitDefinition>,<ChannelName>

This command controls the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Controlling the Positive Transition Part

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers > Controlling the Positive Transition Part
Controlling the Positive Transition Part
List of Commands
STATus:OPERation:PTRansition
STATus:QUEStionable:PTRansition
STATus:QUEStionable:ACPLimit:PTRansition
STATus:QUEStionable:LIMit<n>:PTRansition
STATus:QUEStionable:SYNC:PTRansition


STATus:OPERation:PTRansition

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Status Registers > Querying the Status Registers > Controlling the Positive Transition Part > STATus:OPERation:PTRansition
STATus:OPERation:PTRansition <SumBit>
STATus:QUEStionable:PTRansition <SumBit>
STATus:QUEStionable:ACPLimit:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit<n>:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:SYNC:PTRansition <BitDefinition>,<ChannelName>

These commands control the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Commands for Compatibility

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Commands for Compatibility
Commands for Compatibility

The following commands are provided only for compatibility to remote control programs from WLAN applications on previous signal analyzers. For new remote control programs use the specified alternative commands.

The CONF:BURS:<ResultType>:IMM commands used in former R&S Signal and Spectrum Analyzers to change the result display are still supported for compatibility reasons; however they have been replaced by the LAY:ADD:WIND commands in the R&S FSW (see "Configuring the Result Display"). Note that the CONF:BURS:<ResultType>:IMM commands change the screen layout to display the Magnitude Capture buffer in window 1 at the top of the screen and the selected result type in window 2 below that.

List of Commands
MMEMory:LOAD:SEM:STATe
[SENSe:]DEMod:FORMat:BANalyze:BTYPe
TRIGger[:SEQuence]:MODE


MMEMory:LOAD:SEM:STATe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Commands for Compatibility > MMEMory:LOAD:SEM:STATe
MMEMory:LOAD:SEM:STATe <1>, <Filename>

This command loads a spectrum emission mask setup from an xml file.

Note that this command is maintained for compatibility reasons only. Use the SENS:ESP:PRES command for new remote control programs.

(See[SENSe:​]ESPectrum:​PRESet[:​STANdard] ).

See the R&S FSW User Manual, "Remote commands for SEM measurements" chapter.

Parameters:
<1> |
<Filename> | string Path and name of the .xml file that contains the SEM setup information.
Example: | MMEM:LOAD:SEM:STAT 1,'..\sem_std\WLAN\802_11a\802_11a_10MHz_5GHz_band.XML'


[SENSe:]DEMod:FORMat:BANalyze:BTYPe

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Commands for Compatibility > [SENSe:]DEMod:FORMat:BANalyze:BTYPe
[SENSe:]DEMod:FORMat:BANalyze:BTYPe <PPDUType>

This remote control command specifies the type of PPDU to be analyzed. Only PPDUs of the specified type take part in measurement analysis.

Parameters:
<PPDUType>
'LONG'

Only long PLCP PPDUs are analyzed.

Available for IEEE 802.11b, g.

'SHORT'

Only short PLCP PPDUs are analyzed.

Available for IEEE 802.11b, g.

'MM20'

IEEE 802.11n, Mixed Mode, 20 MHz sampling rate

Note that this setting is maintained for compatibility reasons only. Use the specified commands for new remote control programs (see [SENSe:​]DEMod:​FORMat:​BANalyze:​BTYPe:​AUTO:​TYPE and [SENSe:​]BANDwidth:​CHANnel:​AUTO:​TYPE).

For new programs use:

[SENSe:]DEMod:FORMat:BANalyze:BTYPe:AUTO:TYPE MMIX

[SENSe:]BANDwidth:CHANnel:AUTO:TYPE MB20

'GFM20'

IEEE 802.11n Green Field Mode, 20 MHz sampling rate

Note that this setting is maintained for compatibility reasons only. Use the specified commands for new remote control programs (see [SENSe:​]DEMod:​FORMat:​BANalyze:​BTYPe:​AUTO:​TYPE and [SENSe:​]BANDwidth:​CHANnel:​AUTO:​TYPE).

For new programs use:

[SENSe:]DEMod:FORMat:BANalyze:BTYPe:AUTO:TYPE MGRF

[SENSe:]BANDwidth:CHANnel:AUTO:TYPE MB20

Manual operation: See "PPDU Format"


TRIGger[:SEQuence]:MODE

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Commands for Compatibility > TRIGger[:SEQuence]:MODE
TRIGger[:SEQuence]:MODE <Source>

Defines the trigger source.

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​SOURce commands for new remote control programs.

This command configures how triggering is to be performed.

Parameters:
<Source>
IMMediate | EXTernal | VIDeo | RFPower | IFPower | TV | AF | AM | FM | PM | AMRelative | LXI | TIME | SLEFt | SRIGht | SMPX | SMONo | SSTereo | SRDS | SPILot | BBPower | MASK | PSENsor | TDTRigger | IQPower | EXT2 | EXT3


Programming Examples (R&S FSW-K91)

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Programming Examples (R&S FSW-K91)
Programming Examples (R&S FSW-K91)

This example demonstrates how to configure an EVM measurement in a remote environment.

Contents
  • Measurement 1: Measuring Modulation Accuracy for WLAN 802.11n Standard
  • Measurement 2: Determining the Spectrum Emission Mask


Measurement 1: Measuring Modulation Accuracy for WLAN 802.11n Standard

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Programming Examples (R&S FSW-K91) > Measurement 1: Measuring Modulation Accuracy for WLAN 802.11n Standard
Measurement 1: Measuring Modulation Accuracy for WLAN 802.11n Standard

This example demonstrates how to configure a WLAN IQ measurement for a signal according to WLAN 802.11n standard in a remote environment.

//---------- Preparing the application ------------
// Preset the instrument
*RST
// Enter the WLAN option K91n
INSTrument:SELect WLAN
// Switch to single sweep mode and stop sweep
INITiate:CONTinuous OFF;:ABORt

//---------- Configuring the result display ------------
// Activate following result displays:
// 1: Magnitude Capture (default, upper left)
// 2: Result Summary Detailed (below Mag Capt)
// 3: Result Summary Global (default, lower right)
// 4: EVM vs Carrier (next to Mag Capt)

LAY:REPL '2',RSD
LAY:ADD:WIND? '1',RIGH,EVC
//Result: '4'

//---------- Signal description ------------
//Use measurement standard IEEE 802 11n
CONF:STAN 6
//Center frequency is 13.25 GHz
FREQ:CENT 13.25GHZ

//---------- Configuring Data Acquisition ---------------------
//Each measurement captures data for 10 ms.
SWE:TIME 10ms
//Set the input sample rate for the captured I/Q data to 20MHz
TRAC:IQ:SRAT 20MHZ
// Number of samples captured per measurement: 0.01s * 20e6 samples per second
// = 200 000 samples
//Include effects from adjacent channels - switch off filter
BAND:FILT OFF

//---------- Synchronization -----------------
//Improve performance - perform coarse burst search initially
SENS:DEM:TXAR ON
//Minimize the intersymbol interference - FFT start offset determined automatically
SENS:DEM:FFT:OFFS AUTO

//---------- Tracking and channel estimation -----------------
//Improve EVM accuracy - estimate channel from preamble and payload
SENS:DEM:CEST ON
//Use pilot sequence as defined in standard
SENS:TRAC:PIL STAN
//Disable all tracking and compensation functions
SENS:TRAC:LEV OFF
SENS:TRAC:PHAS OFF
SENS:TRAC:TIME OFF

//---------- Demodulation ------------
//Define a user-defined logical filter to analyze:
SENS:DEM:FORM:BCON:AUTO OFF
//all PPDU formats
SENS:DEM:FORM:BAN:BTYP:AUTO:TYPE ALL
//20MHZ channel bandwidth
SENS:BAND:CHAN:AUTO:TYPE MB20
//an MCS Index '1'
SENS:DEM:FORM:MCS:MODE MEAS
SENS:DEM:FORM:MCS 1
//STBC field = '1'
CONF:WLAN:STBC:AUTO:TYPE M1
//Ness = 1
CONF:WLAN:EXT:AUTO:TYPE M1
//short guard interval length (8 samples)
CONF:WLAN:GTIM:AUTO ON
CONF:WLAN:GTIM:AUTO:TYPE MS

//---------- Evaluation range settings -----------------
//Calculate statistics over 10 PPDUs
SENS:BURS:COUN:STAT ON
SENS:BURS:COUN 10
//Determine payload length from HT signal
CONF:WLAN:PAYL:LENG:SRC HTS
//Payload length: 8-16 symbols
SENS:DEM:FORM:BAN:SYMB:EQU OFF
SENS:DEM:FORM:BAN:SYMB:MIN 8
SENS:DEM:FORM:BAN:SYMB:MAX 16

//---------- Measurement settings --------------------
//Define units for EVM and Gain imbalance results
UNIT:EVM PCT
UNIT:GIMB PCT

//---------- Defining Limits -----------------------
//Define non-standard limits for demonstration purposes
//and return to standard limits later.
//Query current limit settings:
CALC:LIM:BURS:ALL?
//Set new limits:
//Average CF error: 5HZ
//max CF error: 10HZ
//average symbol clock error: 5
//max symbol clock error: 10
//average I/Q offset: 5
//maximum I/Q offset: 10
//average EVM all carriers: 0.1%
//max EVM all carriers: 0.5%
//average EVM data carriers: 0.1%
//max EVM data carriers: 0.5%
//average EVM pilots: 0.1%
//max EVM pilots: 0.5%
CALC:LIM:BURS:ALL 5,10,5,10,5,10,0.1,0.5,0.1,0.5,0.1,0.5

//---------- Performing the Measurements -----
// Run 10 (blocking) single measurements
INITiate:IMMediate;*WAI

//---------- Retrieving Results -------------
//Query the I/Q data from magnitude capture buffer for first ms
// 200 000 samples per second -> 200 samples
TRACe1:IQ:DATA:MEMory? 0,200
//Note: result will be too long to display in IECWIN, but is stored in log file
//Query the I/Q data from magnitude capture buffer for second ms
TRACe1:IQ:DATA:MEMory? 201,400
//Note: result will be too long to display in IECWIN, but is stored in log file

//Select window 4 (EVM vs carrier)
DISP:WIND4:SEL
//Query the current EVM vs carrier trace
TRAC:DATA? TRACE1
//Note: result will be too long to display in IECWIN, but is stored in log file
//Query the result of the average EVM for all carriers
FETC:BURS:EVM:ALL:AVER?
//Query the result of the EVM limit check for all carriers
CALC:LIM:BURS:ALL:RES?

//Return to standard-defined limits
CALC:LIM:BURS:ALL
//Query the result of the EVM limit check for all carriers again
CALC:LIM:BURS:ALL:RES?

//---------- Exporting Captured I/Q Data-------------
//Store the captured I/Q data to a file.
MMEM:STOR:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar'


Measurement 2: Determining the Spectrum Emission Mask

WLAN application (R&S FSW-K91) > Remote Commands for WLAN Measurements > Programming Examples (R&S FSW-K91) > Measurement 2: Determining the Spectrum Emission Mask
Measurement 2: Determining the Spectrum Emission Mask
//---------- Preparing the application ------------
*RST
//Reset the instrument
INST:CRE:NEW WLAN,'SEMMeasurement'
//Activate a WLAN measurement channel named "SEMMeasurement"

//---------- Configuring the measurement ------------
DISP:TRAC:Y:SCAL:RLEV 0
//Set the reference level to 0 dBm
FREQ:CENT 2.1175 GHz
//Set the center frequency to 2.1175 GHz
CONF:BURS:SPEC:MASK
//Select the spectrum emission mask measurement

//---------- Performing the Measurement-----
INIT:CONT OFF
//Stops continuous sweep
SWE:COUN 100
//Sets the number of sweeps to be performed to 100
INIT;*WAI
//Start a new measurement with 100 sweeps and wait for the end

//---------- Retrieving Results-------------
CALC:LIM:FAIL?
//Queries the result of the limit check
//Result: 0 [passed]
TRAC:DATA? LIST
//Retrieves the peak list of the spectrum emission mask measurement
//Result:
//+1.000000000,-1.275000000E+007,-8.500000000E+006,+1.000000000E+006,+2.108782336E+009,
//-8.057177734E+001,-7.882799530E+001,-2.982799530E+001,+0.000000000,+0.000000000,+0.000000000,

//+2.000000000,-8.500000000E+006,-7.500000000E+006,+1.000000000E+006,+2.109000064E+009,
//-8.158547211E+001,-7.984169006E+001,-3.084169006E+001,+0.000000000,+0.000000000,+0.000000000,

//+3.000000000,-7.500000000E+006,-3.500000000E+006,+1.000000000E+006,+2.113987200E+009,
//-4.202708435E+001,-4.028330231E+001,-5.270565033,+0.000000000,+0.000000000,+0.000000000,

 [...]
Trace results for SEM measurement
Range No. | Start freq. [Hz] | Stop freq. [Hz] | RBW [Hz] | Freq. peak power [Hz] | Abs. peak power [dBm] | Rel. peak power [%] | Delta to margin [dB] | Limit check result | - | - | -
1 | +1.000000000 | -1.275000000E+007 | -8.500000000E+006 | +1.000000000E+006 | +2.108782336E+009 | -8.057177734E+001 | -7.882799530E+001 | -2.982799530E+001 | +0.000000000 | +0.000000000 | +0.000000000
2 | +2.000000000 | -8.500000000E+006 | -7.500000000E+006 | +1.000000000E+006 | +2.109000064E+009 | -8.158547211E+001 | -7.984169006E+001 | -3.084169006E+001 | +0.000000000 | +0.000000000 | +0.000000000
3 | +3.000000000 | -7.500000000E+006 | -3.500000000E+006 | +1.000000000E+006 | +2.113987200E+009 | -4.202708435E+001 | -4.028330231E+001 | -5.270565033 | +0.000000000 | +0.000000000 | +0.000000000
... | ... |  |  |  |  |  |  |  |  |  |


Annex: Reference

WLAN application (R&S FSW-K91) > Annex: Reference
Annex: Reference
Contents
  • Sample Rate and Maximum Usable I/Q Bandwidth for RF Input


Sample Rate and Maximum Usable I/Q Bandwidth for RF Input

WLAN application (R&S FSW-K91) > Annex: Reference > Sample Rate and Maximum Usable I/Q Bandwidth for RF Input
Sample Rate and Maximum Usable I/Q Bandwidth for RF Input
Definitions
  • Input sample rate (ISR): the sample rate of the useful data provided by the connected instrument to the R&S FSW input
  • (User, Output) Sample rate (SR): the sample rate that is defined by the user (e.g. in the "Data Aquisition" dialog box in the "I/Q Analyzer" application) and which is used as the basis for analysis or output
  • Usable I/Q (Analysis) bandwidth: the bandwidth range in which the signal remains undistorted in regard to amplitude characteristic and group delay; this range can be used for accurate analysis by the R&S FSW
  • Record length: Number of I/Q samples to capture during the specified measurement time; calculated as the measurement time multiplied by the sample rate

For the I/Q data acquisition, digital decimation filters are used internally. The passband of these digital filters determines the maximum usable I/Q bandwidth. In consequence, signals within the usable I/Q bandwidth (passband) remain unchanged, while signals outside the usable I/Q bandwidth (passband) are suppressed. Usually, the suppressed signals are noise, artifacts, and the second IF side band. If frequencies of interest to you are also suppressed, you should try to increase the output sample rate, since this increases the maximum usable I/Q bandwidth.

Bandwidth extension options

The maximum usable I/Q bandwidth provided by the R&S FSW in the basic installation can be extended by additional options. These options can either be included in the initial installation (B-options) or updated later (U-options). The maximum bandwidth provided by the individual option is indicated by its number, for example, B40 extends the bandwidth to 40 MHz.

Note that the U-options as of U40 always require all lower-bandwidth options as a prerequisite, while the B-options already include them.

Max. usable I/Q BW

Required B-option

Required U-option(s)

10 MHz

-

-

28 MHz

B28

U28

40 MHz

B40

U28+U40 or

B28+U40

80 MHz

B80

U28+U40+U80 or

B28+U40+U80 or

B40+U80

160 MHz

B160

U28+U40+U80+U160 or

B28+U40+U80+U160 or

B40+U80+U160 or

B80+U160

320 MHz

B320*)

U28+U40+U80+U160+U320 or

B28+U40+U80+U160+U320 or

B40+U80+U160+U320 or

B80+U160+U320 or

B160+U320

500 MHz

B500**)

See data sheet

*) The bandwidth extension option R&S FSW-B320/-U320 requires a reference board revision 3.14 or higher.

**) The bandwidth extension option R&S FSW-B500 requires a reference board (1312.8075.06) revision 4.06 or higher and a motherboard 1313.4180.02 or 1313.7698.02.

As a rule, the usable I/Q bandwidth is proportional to the output sample rate. Yet, when the I/Q bandwidth reaches the bandwidth of the analog IF filter (at very high output sample rates), the curve breaks.

Relationship between sample rate and usable I/Q bandwidth

Up to the maximum bandwidth, the following rule applies:

Usable I/Q bandwidth = 0.8 * Output sample rate

The figure "Relationship between maximum usable I/Q bandwidth and output sample rate with and without bandwidth extensions" shows the maximum usable I/Q bandwidths depending on the output sample rates.

R&S FSW without additional bandwidth extension options

sample rate: 100 Hz - 10 GHz

maximum I/Q bandwidth: 10 MHz

Maximum I/Q bandwidth
Sample rate | Maximum I/Q bandwidth
100 Hz to 10 MHz | proportional up to maximum 10 MHz
10 MHz to 10 GHz | 10 MHz
R&S FSW with options B28 or U28 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 28 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 35 MHz | proportional up to maximum 28 MHz
35 MHz to 10 GHz | 28 MHz
R&S FSW with option B40 or U40 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 40 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 50 MHz | proportional up to maximum 40 MHz
50 MHz to 10 GHz | 40 MHz
R&S FSW with option B80 or U80 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 80 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 100 MHz | proportional up to maximum 80 MHz
100 MHz to 10 GHz | 80 MHz
R&S FSW with activated option B160 or U160 (I/Q Bandwidth Extension):

sample rate: 100 Hz - 10 GHz

maximum bandwidth: 160 MHz

Sample rate | Maximum I/Q bandwidth
100 Hz to 200 MHz | proportional up to maximum 160 MHz
200 MHz to 10 GHz | 160 MHz
Relationship between maximum usable I/Q bandwidth and output sample rate with and without bandwidth extensions
Contents
  • Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320
  • Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500


Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320

WLAN application (R&S FSW-K91) > Annex: Reference > Sample Rate and Maximum Usable I/Q Bandwidth for RF Input > Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320
Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B320/U320
Sample rate | Maximum I/Q bandwidth
100 Hz to 400 MHz | proportional up to maximum 320 MHz
400 MHz to 10 GHz | 320 MHz
Relationship between maximum usable I/Q bandwidth and output sample rate for active R&S FSW-B320


Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500

WLAN application (R&S FSW-K91) > Annex: Reference > Sample Rate and Maximum Usable I/Q Bandwidth for RF Input > Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500
Max. Sample Rate and Bandwidth with Activated I/Q Bandwidth Extension Option B500

The bandwidth extension option R&S FSW-B500 provides measurement bandwidths up to 500 MHz.

Sample rate | Maximum I/Q bandwidth
100 Hz to 600 MHz | proportional up to maximum 500 MHz
600 MHz to 10 GHz | 500 MHz
Relationship between maximum usable I/Q bandwidth and output sample rate for active R&S FSW-B500


List of Remote Commands (WLAN)

WLAN application (R&S FSW-K91) > List of Remote Commands (WLAN)
List of Remote Commands (WLAN)
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel
[SENSe:]BANDwidth:CHANnel:AUTO:TYPE
[SENSe:]BANDwidth[:RESolution]:FILTer[:STATe]
[SENSe:]BURSt:COUNt
[SENSe:]BURSt:COUNt:STATe
[SENSe:]BURSt:SELect
[SENSe:]BURSt:SELect:STATe
[SENSe:]DEMod:CESTimation
[SENSe:]DEMod:FFT:OFFSet
[SENSe:]DEMod:FORMat:BANalyze
[SENSe:]DEMod:FORMat:BANalyze:BTYPe
[SENSe:]DEMod:FORMat:BANalyze:BTYPe:AUTO:TYPE
[SENSe:]DEMod:FORMat:BANalyze:DBYTes:EQUal
[SENSe:]DEMod:FORMat:BANalyze:DBYTes:MAX
[SENSe:]DEMod:FORMat:BANalyze:DBYTes:MIN
[SENSe:]DEMod:FORMat:BANalyze:DURation:EQUal
[SENSe:]DEMod:FORMat:BANalyze:DURation:MAX
[SENSe:]DEMod:FORMat:BANalyze:DURation:MIN
[SENSe:]DEMod:FORMat:BANalyze:SYMBols:EQUal
[SENSe:]DEMod:FORMat:BANalyze:SYMBols:MAX
[SENSe:]DEMod:FORMat:BANalyze:SYMBols:MIN
[SENSe:]DEMod:FORMat:MCSindex
[SENSe:]DEMod:FORMat:MCSindex:MODE
[SENSe:]DEMod:FORMat:NSTSindex
[SENSe:]DEMod:FORMat:NSTSindex:MODE
[SENSe:]DEMod:FORMat[:BCONtent]:AUTO
[SENSe:]DEMod:TXARea
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet
[SENSe:]POWer:SEM:CLASs
[SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]SWAPiq
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:TIME
[SENSe:]TRACking:IQMComp
[SENSe:]TRACking:LEVel
[SENSe:]TRACking:PHASe
[SENSe:]TRACking:PILots
[SENSe:]TRACking:TIME
[SENSe<n>:]DEMod:FORMat:SIGSymbol
[SENSe<n>:]POWer:SEM
ABORt
CALCulate:LIMit:ACPower:ACHannel:RESult?
CALCulate:LIMit:ACPower:ALTernate<ch>:RESult?
CALCulate:LIMit:BURSt:ALL
CALCulate:LIMit:BURSt:ALL:RESult?
CALCulate:LIMit:BURSt:EVM:ALL:MAXimum
CALCulate:LIMit:BURSt:EVM:ALL:MAXimum:RESult?
CALCulate:LIMit:BURSt:EVM:ALL[:AVERage]
CALCulate:LIMit:BURSt:EVM:ALL[:AVERage]:RESult?
CALCulate:LIMit:BURSt:EVM:DATA:MAXimum
CALCulate:LIMit:BURSt:EVM:DATA:MAXimum:RESult?
CALCulate:LIMit:BURSt:EVM:DATA[:AVERage]
CALCulate:LIMit:BURSt:EVM:DATA[:AVERage]:RESult?
CALCulate:LIMit:BURSt:EVM:PILot:MAXimum
CALCulate:LIMit:BURSt:EVM:PILot:MAXimum:RESult?
CALCulate:LIMit:BURSt:EVM:PILot[:AVERage]
CALCulate:LIMit:BURSt:EVM:PILot[:AVERage]:RESult?
CALCulate:LIMit:BURSt:FERRor:MAXimum
CALCulate:LIMit:BURSt:FERRor:MAXimum:RESult?
CALCulate:LIMit:BURSt:FERRor[:AVERage]
CALCulate:LIMit:BURSt:FERRor[:AVERage]:RESult?
CALCulate:LIMit:BURSt:IQOFfset:MAXimum
CALCulate:LIMit:BURSt:IQOFfset:MAXimum:RESult?
CALCulate:LIMit:BURSt:IQOFfset[:AVERage]
CALCulate:LIMit:BURSt:IQOFfset[:AVERage]:RESult?
CALCulate:LIMit:BURSt:SYMBolerror:MAXimum
CALCulate:LIMit:BURSt:SYMBolerror:MAXimum:RESult?
CALCulate:LIMit:BURSt:SYMBolerror[:AVERage]
CALCulate:LIMit:BURSt:SYMBolerror[:AVERage]:RESult?
CALCulate:LIMit:TOLerance
CALCulate:LIMit<k>:FAIL?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate:STATistics:RESult<t>?
CALCulate<n>:BURSt[:IMMediate]
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:UNIT:POWer
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
CONFigure:BURSt:AM:AM:COEFficients?
CONFigure:BURSt:AM:AM:POLYnomial
CONFigure:BURSt:AM:AM[:IMMediate]
CONFigure:BURSt:AM:EVM[:IMMediate]
CONFigure:BURSt:AM:PM[:IMMediate]
CONFigure:BURSt:CONSt:CCARrier[:IMMediate]
CONFigure:BURSt:CONSt:CSYMbol[:IMMediate]
CONFigure:BURSt:EVM:ECARrier[:IMMediate]
CONFigure:BURSt:EVM:ECHip[:IMMediate]
CONFigure:BURSt:EVM:ESYMbol[:IMMediate]
CONFigure:BURSt:EVM:ESYMbol[:IMMediate] (IEEE 802.11b and g (DSSS))
CONFigure:BURSt:PREamble:SELect
CONFigure:BURSt:PREamble[:IMMediate]
CONFigure:BURSt:PVT:AVERage
CONFigure:BURSt:PVT:RPOWer
CONFigure:BURSt:PVT:SELect
CONFigure:BURSt:PVT[:IMMediate]
CONFigure:BURSt:SPECtrum:ACPR[:IMMediate]
CONFigure:BURSt:SPECtrum:FFT[:IMMediate]
CONFigure:BURSt:SPECtrum:FLATness:CSELect
CONFigure:BURSt:SPECtrum:FLATness:SELect
CONFigure:BURSt:SPECtrum:FLATness[:IMMediate]
CONFigure:BURSt:SPECtrum:MASK[:IMMediate]
CONFigure:BURSt:SPECtrum:OBWidth[:IMMediate]
CONFigure:BURSt:STATistics:BSTReam[:IMMediate]
CONFigure:BURSt:STATistics:CCDF[:IMMediate]
CONFigure:BURSt:STATistics:SFIeld[:IMMediate]
CONFigure:POWer:AUTO
CONFigure:POWer:AUTO
CONFigure:POWer:AUTO:SWEep:TIME
CONFigure:POWer:EXPected:RF
CONFigure:STANdard
CONFigure:WLAN:ANTMatrix:ADDRess<add>
CONFigure:WLAN:ANTMatrix:ANTenna<Analyzer>
CONFigure:WLAN:ANTMatrix:STATe<state>
CONFigure:WLAN:DUTConfig
CONFigure:WLAN:EXTension:AUTO:TYPE
CONFigure:WLAN:GTIMe:AUTO
CONFigure:WLAN:GTIMe:AUTO:TYPE
CONFigure:WLAN:GTIMe:SELect
CONFigure:WLAN:MIMO:CAPTure
CONFigure:WLAN:MIMO:CAPTure:BUFFer
CONFigure:WLAN:MIMO:CAPTure:TYPE
CONFigure:WLAN:MIMO:OSP:ADDRess
CONFigure:WLAN:MIMO:OSP:MODule
CONFigure:WLAN:PAYLoad:LENGth:SRC
CONFigure:WLAN:PVERror:MRANge?
CONFigure:WLAN:RSYNc:JOINed
CONFigure:WLAN:SMAPping:MODE
CONFigure:WLAN:SMAPping:NORMalise
CONFigure:WLAN:SMAPping:TX<ch>
CONFigure:WLAN:SMAPping:TX<ch>:STReam<stream>
CONFigure:WLAN:SMAPping:TX<ch>:TIMeshift
CONFigure:WLAN:STBC:AUTO:TYPE
DIAGnostic:SERVice:NSOurce
DISPlay:FORMat
DISPlay[:WINDow<n>]:SELect
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:TABLe:ITEM
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe
FETCh:BURSt:ALL
FETCh:BURSt:COUNt:ALL?
FETCh:BURSt:COUNt?
FETCh:BURSt:CRESt:MAXimum?
FETCh:BURSt:CRESt:MINimum?
FETCh:BURSt:CRESt[:AVERage]?
FETCh:BURSt:EVM:ALL:AVERage?
FETCh:BURSt:EVM:ALL:AVERage?
FETCh:BURSt:EVM:ALL:MAXimum?
FETCh:BURSt:EVM:ALL:MAXimum?
FETCh:BURSt:EVM:ALL:MINimum?
FETCh:BURSt:EVM:ALL:MINimum?
FETCh:BURSt:EVM:DATA:AVERage?
FETCh:BURSt:EVM:DATA:MAXimum?
FETCh:BURSt:EVM:DATA:MINimum?
FETCh:BURSt:EVM:PILot:AVERage?
FETCh:BURSt:EVM:PILot:MAXimum?
FETCh:BURSt:EVM:PILot:MINimum?
FETCh:BURSt:FERRor:AVERage?
FETCh:BURSt:FERRor:MAXimum?
FETCh:BURSt:FERRor:MINimum?
FETCh:BURSt:GIMBalance:AVERage?
FETCh:BURSt:GIMBalance:MAXimum?
FETCh:BURSt:GIMBalance:MINimum?
FETCh:BURSt:IQOFfset:AVERage?
FETCh:BURSt:IQOFfset:MAXimum?
FETCh:BURSt:IQOFfset:MINimum?
FETCh:BURSt:LENGths?
FETCh:BURSt:PAYLoad:MAXimum?
FETCh:BURSt:PAYLoad:MINimum?
FETCh:BURSt:PAYLoad[:AVERage]?
FETCh:BURSt:PEAK:MAXimum?
FETCh:BURSt:PEAK:MINimum?
FETCh:BURSt:PEAK[:AVERage]?
FETCh:BURSt:PREamble:MAXimum?
FETCh:BURSt:PREamble:MINimum?
FETCh:BURSt:PREamble[:AVERage]?
FETCh:BURSt:QUADoffset:AVERage?
FETCh:BURSt:QUADoffset:MAXimum?
FETCh:BURSt:QUADoffset:MINimum?
FETCh:BURSt:RMS:MAXimum?
FETCh:BURSt:RMS:MINimum?
FETCh:BURSt:RMS[:AVERage]?
FETCh:BURSt:STARts?
FETCh:BURSt:SYMBolerror:AVERage?
FETCh:BURSt:SYMBolerror:MAXimum?
FETCh:BURSt:SYMBolerror:MINimum?
FETCh:SYMBol:COUNt?
FORMat[:DATA]
INITiate:CONTinuous
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:COUPling
INPut:DIQ:CDEVice
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
INPut:SELect
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
MMEMory:LOAD:IQ:STATe
MMEMory:LOAD:SEM:STATe
MMEMory:STORe:IQ:STATe
OUTPut:IF:IFFRequency
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth
STATus:OPERation:CONDition?
STATus:OPERation:ENABle
STATus:OPERation:NTRansition
STATus:OPERation:PTRansition
STATus:OPERation[:EVENt]?
STATus:PRESet
STATus:QUEStionable:ACPLimit:CONDition?
STATus:QUEStionable:ACPLimit:ENABle
STATus:QUEStionable:ACPLimit:NTRansition
STATus:QUEStionable:ACPLimit:PTRansition
STATus:QUEStionable:ACPLimit[:EVENt]?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:ENABle
STATus:QUEStionable:LIMit<n>:CONDition?
STATus:QUEStionable:LIMit<n>:ENABle
STATus:QUEStionable:LIMit<n>:NTRansition
STATus:QUEStionable:LIMit<n>:PTRansition
STATus:QUEStionable:LIMit<n>[:EVENt]?
STATus:QUEStionable:NTRansition
STATus:QUEStionable:PTRansition
STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:PTRansition
STATus:QUEStionable:SYNC[:EVENt]?
STATus:QUEStionable[:EVENt]?
STATus:QUEue[:NEXT]?
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon[:STATe]
TRACe:IQ:DATA:MEMory
TRACe:IQ:SRATe
TRACe<n>[:DATA]
TRACe<n>[:DATA]:X?
TRIGger:SEQuence:LEVel:POWer:AUTO
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:MODE
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval
UNIT:BURSt
UNIT:EVM
UNIT:GIMBalance


Legal Notice

R&S®FSW-K91
WLAN Measurements
Version:
2.00 and higher

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.